NOD32 won't update on DC since last Windows Update

Discussion in 'ESET NOD32 Antivirus' started by EnGenie, Jun 16, 2008.

Thread Status:
Not open for further replies.
  1. EnGenie
    Offline

    EnGenie Registered Member

    Last Wednesday 11 June we updated the Domain Controller and other servers and workstations with the latest Microsoft updates.

    Since that time NOD32 has been unable to update successfully on the Domain Controller although all other servers and workstations update with no problem.

    The updates are downloaded OK but fail to install.

    I have changed the update server from "Choose automatically" to our ERA Server and back again with no effect.

    The log shows the following entries:

    16/06/2008 15:01:23 Update Updater: retval = 0x101a, failures: 104 NT AUTHORITY\SYSTEM
    16/06/2008 15:01:23 Update Updater: compile error 0 NT AUTHORITY\SYSTEM
    16/06/2008 14:59:28 Update Updater: retval = 0x101a, failures: 103 NT AUTHORITY\SYSTEM
    16/06/2008 14:59:28 Update Updater: compile error 0 NT AUTHORITY\SYSTEM
    12/06/2008 12:49:58 Update NT AUTHORITY\SYSTEM
    11/06/2008 20:49:41 Kernel Virus signature database successfully updated to version 3179 (20080611).

    I have tried flushing the cache but this makes no difference and the last update always fails to install.

    We are running NOD32 3.0.657 Business Edition on Windows 2003 SP2.

    Does anyone have any idea about the cause of this error and any possible solution?
  2. EnGenie
    Offline

    EnGenie Registered Member

    Why has this thread been moved?

    The error is with NOD32 not with ERA Server.

    The computer in question is configured to update direct from the Eset servers. (I only temporarily reconfigured it to update from our ERA Server (on a different computer) as a test, then restored the original configuration when there was no change in behavior).

    There are many other threads relating to NOD32 Business Edition in the NOD32 forum, so I naturally assumed that this was the correct place for my thread.

    o_O
  3. Bubba
    Offline

    Bubba Updates Team

    It was moved to the "Other ESET Products Forum" based on the understanding\interpretation of info given. It has now been placed back in the ESET NOD32 Antivirus Forum for the time being.

    Also, it's not an exact science sometimes, so bare with us as We attempt to do our best in seeing members get proper support by our placement of threads.

    Bubba
  4. SoCal_Sparrow
    Offline

    SoCal_Sparrow Registered Member

    I haven't seen a problem like this on my systems since pre-3.0.621 but it sounds similar enough...

    Try opening "C:\Program Files\Eset\ESET NOD32 Antivirus" and delete all of the emXXX_32.dat files. Then run the update again.

    Hope this helps!
  5. ASpace
    Offline

    ASpace Guest

    http://www.eset.com/support/kb.php

    Undocumented serious error 0x101a

    Try to reinstall the program

    1. Download fresh new version of ESET NOD32 Antivirus 3.0 from
    http://www.eset.com/download . Make sure that you choose the correct version.

    2. Uninstall your current version from Control Panel
    3. Reboot the computer when prompted
    4. Delete manually these folders:

    - C:\Program files\ESET
    - C:\Documents and Settings\All users\Application data\Eset
    - C:\Documents and Settings\~username~\Local Settings\Application data\Eset

    5. Reinstall your ESET software using the file you downloaded in step1 . Use typical install. :thumb


    AFAIK - 0x101a may also be a symptom of another bigger problem - disk errors or OS errors , for example
  6. EnGenie
    Offline

    EnGenie Registered Member

    OK. Thanks Bubba. No problem :D

    Thanks. I'll give this a go when I return to work tomorrow.
    Is this different from clearing the update cache (which I've already done)?

    Thanks HiTech Boy. If nothing else works, I'll give it a go.
    I tried a "repair" installation but that didn't fix it.

    As its our primary domain controller, I'll have to wait until the end of the day before I can reboot it without causing too much disruption to everyone else.
  7. EnGenie
    Offline

    EnGenie Registered Member

    This seems to have fixed the problem.

    Thanks for your help. :thumb:
Thread Status:
Not open for further replies.