NOD32 v3.0.621 - Cannot access localhost

Discussion in 'ESET NOD32 Antivirus' started by wickedmx, Jan 21, 2008.

Thread Status:
Not open for further replies.
  1. wickedmx
    Offline

    wickedmx Registered Member

    Ok, I've seen a few threads that have touched on this but as yet no solutions have actually been posted.

    I run Vista Business with a local test server using Wampserver 2.0. and had NOD32 2.7 working fine. However, I just installed v3.0.621 and can no longer access anything at a localhost address (eg http://localhost/testsite/). If I use 127.0.0.1 it sort of works but PHP and MySQL don't work properly.

    With v3 loaded, Firefox tries to forward to www.localhost.com, IE7 just wont display the page, and Safari gives me "kCFErrorDomainWinSock:10054". As soon as I uninstall v3, everything starts working again.

    Any ideas would be great as I really like the new interface but will have to stick with the old until a solution is found.

    Thanks
  2. wickedmx
    Offline

    wickedmx Registered Member

    Right, just opened my hosts file using the text editor and discovered the first 2 entries were:

    127.0.0.1 localhost
    ::1 localhost

    I removed the "::1 localhost" entry(as per another thread) and all is working again.

    Ever since I started using Spybot I have always used it to view my hosts file. However, it doesn't display the entries in their entirity, hence i did not see the 2 variations of the localhost entry.

    Hope this works for everyone experiencing this issue.
  3. tropauer
    Offline

    tropauer Registered Member

    I'm having exactly the same issue. Sorry for my ignorance, but I don't understand what file you have modified. Can you explain better? Is a file in NOD32 or a file on your local web server?
  4. wickedmx
    Offline

    wickedmx Registered Member

    Hi tropauer

    The hosts file is a system file and can be found in the folder Windows\System32\drivers\etc

    It is another tool used by the operating system to resolve domain names and is used by some antispyware applications to block access to certain websites. It can also be hijacked some nasty programs to redirect valid addresses to a different ips.

    It is an extensionless file but can be edited by double clicking on it and selecting the notepad from the list of editing options. The only entry you want to remove is the ::1 localhost and not the 127.0.0.1 localhost.

    Hope this helps.
  5. HAN
    Online

    HAN Registered Member

    If it helps, the default Windows HOSTS file looks like the following.


    # Copyright © 1993-1999 Microsoft Corp.
    #
    # This is a sample HOSTS file used by Microsoft TCP/IP for Windows.
    #
    # This file contains the mappings of IP addresses to host names. Each
    # entry should be kept on an individual line. The IP address should
    # be placed in the first column followed by the corresponding host name.
    # The IP address and the host name should be separated by at least one
    # space.
    #
    # Additionally, comments (such as these) may be inserted on individual
    # lines or following the machine name denoted by a "#" symbol.
    #
    # For example:
    #
    # 102.54.94.97 rhino.acme.com # source server
    # 38.25.63.10 x.acme.com # x client host
    #
    127.0.0.1 localhost
  6. tropauer
    Offline

    tropauer Registered Member

  7. dsearles
    Offline

    dsearles Registered Member

  8. signalnetworks
    Offline

    signalnetworks Registered Member

    We had the same issue today using NOD32 v3.0.621

    user unable to browse http://localhost, http://127.0.0.1 was working.

    from a command prompt

    Ping localhost was returning
    ::1

    we checked the host file and just the following was listed
    localhost 127.0.0.1

    The solution was to uninstall the IPV6 network module from the Network interface tab.

    problem solved.
  9. PsyChoses
    Offline

    PsyChoses Registered Member

    I have Xampp and No ::1 in hosts file ... Unchecked IPv6 from network still ping localhost gets me ::1 .. I'm on vista Ultimate and using Nod32 v3.0.642 ... Plz I need help ASAP ....
  10. TravisO
    Offline

    TravisO Registered Member

    Troubleshooting 101 guys..

    1. upgrade to the latest version
    2. reboot
    3. if still broken, then ask

    and when #1 is free, there's no excuse not to run the latest version.
  11. PsyChoses
    Offline

    PsyChoses Registered Member

    like I said b4 :
    What should I do I need it as I'm running a test machine for new scripts coming out :S
  12. Neoxellos
    Offline

    Neoxellos Registered Member

    Hello,
    Is there someone who can provide me with another solution to this localhost problem? I'm not able to run the inventor 2009 content library with NOD32 V3 installed. It has to connect to localhost. I tried removing the "::1 localhost" but that only made it worse, because inventor wouldn't run.
    Now I had to uninstall V3.

    I have send a bug report and they asked me to send some info back (auditmypc). I send the info a month ago ( march 28 ). No reply as of yet. Send a reminder mail a week ago, no reply.

    So maybe anybody out here could help me?

    Thank you.
  13. Anthony Shaw
    Offline

    Anthony Shaw Registered Member

    Is there a resolution to this issue? I am a paying subscriber for NOD32, but if I can't use it due to this issue, we're going to have a problem :mad:
  14. Marcos
    Offline

    Marcos Eset Staff Account

    If you don't like commenting out the aforementioned entry in the hosts file, you can either uninstall IPv6 or simply exclude the problematic application from http scanning by putting a cross next to it in the http setup -> web browsers list.
    The next version of EAV/ESS will use a different way of scanning http/pop3 by employing a new technology first introduced in Windows Vista.
  15. Anthony Shaw
    Offline

    Anthony Shaw Registered Member

    Thing is... I did remove the entry from the hosts file.

    I also disabled IPv6 from all of my network devices, as well as making a change in the registry that is supposed to disable IPv6 for Vista as well. At some point, each of these solutions worked... temporarily!

    I finally gave up and uninstalled NOD32 v3.0 and voila, everything works just fine as it should. I undid all the other changes that I had made and still no issues since.

    I shouldn't have to hack around in system files and whatnot to make sure I can still accomplish my daily job to use your software. Do you have some sort of EAP for getting ahold of this new version? I really don't like the idea of not running anti-virus free while I sit around and wait.
    Last edited: Oct 10, 2008
  16. madman045
    Offline

    madman045 Registered Member

    The reason for this is is the HTTP filtering for Port 80 (if this is what you are using), if you remove the exception, it should start working, however this defeats the object of having internet protection, hence this sort of thing would normally go on a server of which with NOD, does not have the IMON module loaded (but then you dont surf the net with a server)

    So what you are seeing is normal as the AV product is doing it's job for a client PC
  17. dorbar
    Offline

    dorbar Registered Member

    The fact is that NOD32 ESS is RESPONSIBLE for this. So I expect that you guy from Eset fix it. Period! Otherwise my money at the end of license expiration will go elsewhere. I have to say that I uninstall ESS for 4 month because this localhost issue happens on first install. But I decide to reinstall it. For a month or so it works fine but now with no particular reason this bloody fxxking issue reapers from nowhere.

    Really, really disappointing. :mad: :mad: :mad: :mad: :mad: :mad:
  18. doktornotor
    Offline

    doktornotor Registered Member

    And the value of the following registry key is exactly what?

    Code:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\DataBasePath 
  19. Marcos
    Offline

    Marcos Eset Staff Account

    I'd add that ESS/EAV v4 do not redirect the http communication via a local proxy any more.
  20. dorbar
    Offline

    dorbar Registered Member

    The value for DataBasePath is %SystemRoot%\System32\drivers\etc

    What now?:blink:
  21. agoretsky
    Offline

    agoretsky Eset Staff Account

    Hello,

    Try downloading the public beta test version of ESET NOD32 Antivirus v4.0 from ESET's beta portal at http://beta.eset.com/ and see if it resolves the issue.



    Regards,

    Aryeh Goretsky
Thread Status:
Not open for further replies.