NOD32 no longer updating properly

Discussion in 'ESET NOD32 Antivirus' started by BurtieLad, Jul 26, 2008.

Thread Status:
Not open for further replies.
  1. BurtieLad
    Offline

    BurtieLad Registered Member

    Hi all

    First post and all that, although have been using NOD32 for about 2 years now.

    Until recently NOD32 had been updating just fine and even has the 3300 sig d/base from yesterday but when I try to run a manual update instead of saying the d/base is already up to date, it says "error downloading file". I changed the LAN setting to Specified User and put in my NOD username and pass but this does not seem to have sorted it either. It now does not seem to autoupdate properly either and I have a ready balloon tip informing me of this.

    Ideas most welcome and have also sent a ticket to Eset.

    TIA

    BL
  2. Marcos
    Offline

    Marcos Eset Staff Account

    Just to make sure, you're trying to update EAV and not ESET Smart Security, right? If so, the best would be if you create a log from Wireshark (former Ethereal) and send it to ESET's support.
  3. zoatebix
    Offline

    zoatebix Registered Member

    I'm having the exact same problem. I'm using EAV 3.0.560.0.

    By the way, the "User account" they're looking for under the "LAN" tab of "Advanced update setup" refers to your Windows user account and not your ESET subscription account.

    Is this what you meant by Wireshark? http://www.wireshark.org/
  4. Kelon
    Offline

    Kelon Registered Member

    I am having the same problem - program is no longer updating. Everything was working fine yesterday, today no luck. EAV 3.0.621.0 signature database 3300, running under Vista x64.

    Edit: My fiancee is having the same issue as well, with the same version and a similar system config.
    Last edited: Jul 26, 2008
  5. paulsaz
    Offline

    paulsaz Registered Member

    Same problem here as well, updated to 3300 and will now not talk to the update server.

    v3.0.621.0 on vista home premium 64 bit. I'll get a traffic capture and see if there's anythin in there and forward it to support.

    Looking at the logs this started on the 23rd with infrequent failures but nothing at all since yesterdays update to 3300.

    edit: Updated the program to v3.0.669.0 and it appears to be working again. Seems odd that program updates aren't pushed out to clients in any way?
    Last edited: Jul 26, 2008
  6. derekivey
    Offline

    derekivey Registered Member

    Same problem here as well. I'm running Vista Ultimate x64. I'm using NOD32 version 3.0.621.0, virus signature database: 3300.

    Stopped working around Thursday I believe.
  7. acooldozen
    Offline

    acooldozen Registered Member

    Last update was Friday 25th.....................

    Update 3300 (20080725)
    2008-07-25 19:46
    Win32/Adware.AdMedia (2), Win32/Adware.Agent.NJC, Win32/Adware.IESuper, Win32/Adware.SpyShredder (4), Win32/Adware.Vapsup (7), Win32/Adware.Virtumonde (5), Win32/Adware.XLGuarder.A (7), Win32/Adware.XLGuarder.B, Win32/Agent.NZQ, Win32/Agent.NZR (2), Win32/BHO.NFH, Win32/DNSChanger, Win32/Spy.Agent.NHV, Win32/TrojanClicker.Agent.BCI (4), Win32/TrojanClicker.Agent.NDT, Win32/TrojanDownloader.Agent.OBE, Win32/TrojanDownloader.Banload.OAI (2), Win32/TrojanDownloader.Banload.OZS, Win32/TrojanDownloader.Delf.OFD, Win32/TrojanDownloader.Zlob.BXN (3), Win32/TrojanDownloader.Zlob.CEP, Win32/TrojanDownloader.Zlob.CEQ, Win32/TrojanDownloader.Zlob.CER, Win32/TrojanDownloader.Zlob.CES (2), Win32/TrojanDropper.Autoit.E
    http://www.eset.eu/podpora/aktualizacia-3300?lng=en
    http://www.eset.eu/support/update-xy1

    earlier
  8. mikeyf
    Offline

    mikeyf Registered Member

    Add me to the "me too list", no updates in a couple of days.
  9. Marcos
    Offline

    Marcos Eset Staff Account

    All those having this problem, please try clearing the update cache (either via the program setup, or by deleting the content of the "C:\Users\All Users\ESET\ESET NOD32 Antivirus\Updfiles" folder manually). If it doesn't make any difference, please create a log from Wireshark and send it to ESET's customer care. Does someone of you use a different OS than Vista x64?
    Last edited: Jul 27, 2008
  10. Kelon
    Offline

    Kelon Registered Member

    I wound up uninstalling NOD32 and reinstalling the current version yesterday, and it seems to have done the trick. Updated to 3301 and seems to be running properly now.
  11. mikeyf
    Offline

    mikeyf Registered Member

    Yes to Vista x64 here. I'll grab wireshark and see what I can give to support from that.
  12. zoatebix
    Offline

    zoatebix Registered Member

    I cleared the update cache shortly before making my post. It didn't have an immediate effect (I must have clicked the update link a dozen times), but Nod32 is reporting that it sucessfully updated at 5:31:35 AM (EST). It's also reporting that there was an "Error downloading file from update server," so it's probably only a matter of time before my icon turns orange again.
  13. Marcos
    Offline

    Marcos Eset Staff Account

    Please create a log from Wireshark with the http communication on port 80 captured where we should see the whole communication between EAV and the update servers.
  14. asmodai
    Offline

    asmodai Registered Member

    Clearing that directory makes no difference.

    I am using Windows x64.

    And it only started in the course of last week. And the problem is intermittent, given that after a while it apparently updated just fine again. It updated to 3001 this morning and then a little while ago was complaining about not being able to update.

    Looking with Wireshark shows an authentication problem:

    GET /download/engine3/em006_64_l0.nup HTTP/1.1
    Accept: */*
    User-Agent: ESS Update (Windows; U; 32bit; VDB 3241; BPC 3.0.621.0; OS: 5.2.3790 SP 2.0 NT; LNG 1033; x64c)
    Host: u32.eset.com
    Connection: Keep-Alive
    X-NOD32-Mode: passive
    Pragma: no-cache
    Cache-Control: no-cache

    HTTP/1.1 401 Authorization Required
    Date: Sun, 27 Jul 2008 16:31:24 GMT
    Server: Apache/2.0.53 (Unix)
    WWW-Authenticate: Basic realm="NOD32 Engine Updates"
    Content-Length: 401
    Keep-Alive: timeout=15, max=100
    Connection: Keep-Alive
    Content-Type: text/html; charset=iso-8859-1

    Although, I also get a 200 OK and this:

    HTTP/1.1 304 Not Modified
    Date: Sun, 27 Jul 2008 17:04:40 GMT
    Server: Apache/2.0.53 (Unix)
    Connection: Keep-Alive
    Keep-Alive: timeout=15, max=100
    ETag: "1e0000c5-9fa-c938f7c0"

    And neither of these three reset the status in the client.
    Last edited: Jul 27, 2008
  15. derekivey
    Offline

    derekivey Registered Member

    It looks like mine was able to update to 3001 this morning, but when I do a manual update, I still get that same error.
  16. eriwik
    Offline

    eriwik Registered Member

    I had the same problem (and I'm also running 64-bit Vista), the problem started sometime the 23rd but after a while it managed to download 3301 and then continues to fail. I was running 3.0.566.0. I downloaded and installed 3.0.669.0 (same as paulsaz) and everything seems to work now.

    For those who still can't update: try downloading the latest version of NOD32.
  17. mproudfoot
    Offline

    mproudfoot Registered Member

    Unfortunately, now having the same issue - Vista 64-bit Ultimate and it was working fine up to a few days ago. Yesterday it had issues updating but eventually managed to do so, however today it's just failed repeatedly.

    I'm going to give the suggestion above a try (update to latest version) but I wonder, should the update not automatically update the program files anyway?
  18. derekivey
    Offline

    derekivey Registered Member

    Upgrading to the latest version seems to have fixed it for me also.
  19. asmodai
    Offline

    asmodai Registered Member

    For me updating also worked. But like the poster above I was under the, mistaken?, assumption the program files would also get updated.
  20. slowofmind
    Offline

    slowofmind Registered Member

    Greetings,

    I am running WIN_XP_SP2 (Media Center Edition)
    I am using ESET NOD32 Antivirus Version 3.0.650.0

    My last successful antivirus update was:
    07/21/2008 09:50:57 PM
    Version of virus signature database: 3285 (20080721)

    Since then I am having the following error condition:
    ______________________________________________
    Virus signature database update failed
    Maximum protection of your computer is not ensured.

    Virus signature database could not be updated
    Error downloading file from update server.
    _______________________________________________
    Each time I try, the update begins by trying to download
    the file "em002_32_l0.nup" (filesize = 9166 kb).
    The download never completes, and there is no other indication why.

    Please note: The very first time the update was done after
    signature version 3285, I aborted the update due to the filesize
    and it was late at night. (My problem started after that.)

    Victor G.
    Any help would be much appreciated.
  21. eriwik
    Offline

    eriwik Registered Member

    slowofmind: Have you tried clearing the cache? See Marcos post for details.
  22. jongie
    Offline

    jongie Registered Member

    And another "me too".

    jongie
  23. jongie
    Offline

    jongie Registered Member

    Yes. Windows XP (32-bit). It's occuring on all three computers in our household. That doesn't sound like a cache problem to me. It's more serious than that, and needs an urgent response from ESET.
  24. Bubba
    Offline

    Bubba Updates Team

    Which build ?
  25. kaisernc
    Offline

    kaisernc Registered Member

    I am also noticing update issues in our corporate environment from our 3.0.621.0 clients. I have two Windows Server 2003 machines that are also having issues updating. They cannot be manually updated. I get an Error downloading file from update server message. The auto update is randomly causing alert emails to be sent through our server side of NOD. the emails have a subject line of %s: Error and the message contains a blank warning.

    7/25/2008 17:31:31 PM - During execution of Update on the computer machine_name, the following warning occurred:

    The machines are able to stay at the current signature version though cause it appears that the auto update does not fail all the time and at least one goes through. Only two out our four machines that have 3.0.621.0 installed are behaving in this manner. The others are able to update fine. I suppose i should add that the two machines having the issue are 64-bit and the others are 32-bit Windows Server 2003.

    Any thoughts?
Thread Status:
Not open for further replies.