Never update

Discussion in 'Returnil releases' started by Robin A., Aug 26, 2010.

Thread Status:
Not open for further replies.
  1. Robin A.
    Offline

    Robin A. Registered Member

    I use Returnil 2011 Free Version on Windows 7 x64.

    The “Update” frequency is selected as “Never”, but the “Last successful update” and “Last update attempt” times are updated continuously (and they are always the same). Please see the attached image.

    Why is this so? Is RVS updating anything?

    Attached Files:

  2. safeguy
    Offline

    safeguy Registered Member

    It's a bug I guess...the current release tries to make connections despite whatever settings you have applied to it. Well, that's how it is on my lappie.:p
  3. Boyfriend
    Offline

    Boyfriend Registered Member

    I have blocked Returnil access to internet via KIS Firewall. Now Returnil is complaining about connection. I have disabled hints in tray icon. No problem now as it cannot make connections nor can complain about connections. It is still trying to update, as last update attempt is today’s date in communication tab. Cloud protection still shows enabled although it cannot connect to Internet.
  4. Coldmoon
    Offline

    Coldmoon Returnil Moderator

    Hi Guys,
    Thanks for the heads up and we are investigating. This may be related to the new Cloud Protection feature and the team is looking into it. They suggest the following work-around while this is being investigated:

    1. Open preferences > Communications tab
    2. In the Proxy Settings section enter localhost IP for Proxy Host and enter a port that is usually unused like 50505

    Let me know if this helps resolve the outside connection issue here...

    Mike
  5. philby
    Offline

    philby Registered Member

    Hi Mike

    I've done as you suggested - I'm assuming update attempts are now blocked:
    Capture.PNG
    but I just this second got an (unwanted) red notification box popping up from the system tray telling me there was a problem getting updates...

    philby
  6. Coldmoon
    Offline

    Coldmoon Returnil Moderator

    Try activating the preferences > User Interface tab option for "Do not show hints in Tray Icon" option and let me know if this resolves the warnings. The warning itself is logical as the program cannot connect to anything other than local host which does not contain the update (obviously).

    The work around is to provide a means to block the outside communications while this is investigated and fixed. Turning off the tray icon hints should stop the annoying popups in this case.

    Let me know and will update the team if this is not successful.

    Mike
  7. philby
    Offline

    philby Registered Member

    Hi Mike

    Tried checking the 'Do not show hints' option, but I'm using the free version, so I get the purchase prompt.

    Maybe this will work for other, non-freeloader users...

    :)

    philby
  8. Coldmoon
    Offline

    Coldmoon Returnil Moderator

    The working theory at the moment is that it is related to the Cloud protection feature. Given that this is valid, I wouldn't be too concerned about the connections until it is resolved as all it is doing is looking for policy updates based on malware information from the AI/Machine learning engine.

    This means that it is related directly to updating itself regarding newly discovered malware and suspicious activities rather than a general Virus Guard signature update. So even though it may be unwanted for any connection, the connection is only looking for that type of information and nothing else.

    Until a fix is released, you can use the work around but will get the messages in the freeware version.

    Mike
Thread Status:
Not open for further replies.