How does Google Mail know my real time zone?

Discussion in 'privacy problems' started by dumpydonk, Mar 18, 2010.

Thread Status:
Not open for further replies.
  1. dumpydonk

    dumpydonk Registered Member

    This is a privacy problem because it relates to the information Gmail is able to acquire when a user is behind a Tor Proxy.

    Here is the situation.

    Gmail interacts with the user's system time settings. You can test this by going into your Gmail then changing your clock time. The length of time ago the e-mail was sent field (once you have opened the message) will change according to your system time. So if you put your clock back 3 hours the message will now appear to have been sent 3 hours earlier.

    This is what I do not understand:

    I am GMT.
    I set my system clock to 10:00 which is 5 hours behind the real GMT - so American time on the East coast.
    I use Tor with an American proxy.
    I set all about:config options in Firefox such as general.useragent.locale to en-US.
    I connect to a Gmail account which was set-up with the country and the time zone as being United States.
    However, when a friend of mine sends me an e-mail from America when I log in the time on that e-mail is a GMT time even though this is impossible considering the United States is 5 hours behind GMT on the East coast. In my opinion, the message should show American time.

    As I write this for example it cannot be 14:38 in the United States because it is 14:38 GMT but Gmail would say the e-mail was received at 14:38 - even though everything has been set-up not to use GMT (I think!)

    I cannot see how Gmail knows I am using GMT.

    However, one answer may be that although displays the time shown on my system (after modification to make it East coast time) it informs me that this time is still BST - British Standard Time.

    This would suggest somewhere else on my system is a variable that Gmail (and other e-mail providers) can access to ascertain my real time irrespective of system time and browser settings.

    Any ideas how to prevent this information being transmitted so I can appear not to be using GMT / BST? Thanks.
  2. lotuseclat79

    lotuseclat79 Registered Member

    East Coast time is now in Daylight Saving Time (as of this past Sunday), and is -4 GMT hours, so in fact, your time if it is -5 hours GMT is using Central Time Zone not East Coast Time Zone times.

    When I boot up into Kubuntu 9.10, I use the lower right-hand clock (right-click for Preferences), and set up Time Zone as New York. In doing so, I have to search for New York, click on it so it is selected in the window, and then at the bottom, select Locale as New York instead of Local Locale setting - in order to set my computer's clock to East Coast time. Perhaps you need to do something similar (don't know how you set your computer clock). I know the date -u mmddhhmm (month, day, hour, min) command will also set the computer clock for Linux (as root account), but when you set it, you choose the current GMT time in the date -u command, and other mechanisms in the system correct it to the time zone locally - i.e. /etc/timezone where the contents of mine are US/Eastern.

    -- Tom
    Last edited: Mar 18, 2010
  3. dumpydonk

    dumpydonk Registered Member

    You are correct.

    The issue is not the time on my computer. The issue is the time zone. When I set it to an American time zone then Google Mail changes the time accordingly.

Thread Status:
Not open for further replies.