Help!

Discussion in 'SpywareBlaster & Other Forum' started by rufusboy, Feb 4, 2005.

Thread Status:
Not open for further replies.
  1. rufusboy
    Offline

    rufusboy Registered Member

    I have a problem,I was running Spywareguard but decided to remove it from my system.I closed the program and used the uninstaller to remove Spywareguard.I was left with 2 dll's to remove manually.but now at each boot up the Spyware guard BHO still loads into IE6. I have run a reg editor and deleted every entry I can find.Hijack This,Spybot,BHO Demon,Giant antispy have all tried to remove this but it just keeps coming back!There must be another file loading this at start up but I have run out of places to look.
    BHO listed in Internet Explorer BHO's :4A3668E80-174F-4872-96B5-0B27DDD11DB2
    Running XPHome(SP2)
    Does anyone have any ideas?http://www.wilderssecurity.com/newthread.php?do=newthread&f=23#
    Huh?
  2. Bubba
    Offline

    Bubba Updates Team

    Hmmm....that is not SpywareGuards clsid....it's clsid is 81559C35-8464-49F7-BB0E-07A383BEF910. I also did a Google for that clsid you are listing....and it it brings back nothing.

    If you want to re-install SpywareGuard and then attempt to properly remove it....follow this post instructions. That post is part of the below thread.

    This thread---> Can't uninstall the spywareguard
  3. Vietnam Vet
    Offline

    Vietnam Vet Registered Member

    Hi Bubba,

    On my system, it is listed this way.

    Clsid {4A368E80-174F-4872-96B5-0B27DDD11DB2}
    Comments SpywareGuard Download Protection
    Desc dlprotect.dll - SpywareGuard

    And confirmed here:
    http://computercops.biz/clsid-263.html

    rufusboy posted Clsid has an extra 6, perhaps, just a nervous trigger finger?

    Best wishes,
    VV
  4. rufusboy
    Offline

    rufusboy Registered Member

    Hi Bubba,
    Have tried following this method already,have even tried shutting down as described ,then restarting my PC before uninstalling spywareguard,but the next time I start up Giant/microsoft throws up the warning that an unknown BHO is being added.Giant,Spybot and Highjack This all list this as being Spyware guard at the CLSID I quoted,Spybot actually says "Spywareguard download protection,dlprotect.dll". Nothing seems to be able to terminate this and I can see no process that is causing it to load at start up .I have a good firewall and nothing suspicious is trying to get out and no spyware has been found.
    Don't know where to go from here!
  5. Bubba
    Offline

    Bubba Updates Team

    Thanks VV....that's why I couldn't find it in my registry....or on Google....and yes that is the Download Protection dll....whereas the one I referenced is the Spywareguard.dll....the main one he needs to get rid of.

    Thanks again for the heads up VV [​IMG]
  6. rufusboy
    Offline

    rufusboy Registered Member

    OOOps ,Sorry... Getting old ,too many hours staring at the registry!
    Yup ,I added too many sixes .(Still can't get rid of the problem though)
  7. Bubba
    Offline

    Bubba Updates Team

    Hmm....since you are using XP....are you signed on as a user with Admin rights when installing\un-installing ?

    Also....do you recall placing any shortcuts in the All Users folder as far as start-up ?

    "then restarting my PC before uninstalling spywareguard"

    That in itself may be one of your problems. When you followed the un-install instructions from that above link to properly shut it down....you can then un-install it....but....taking into account my above Admin rights question....if you followed those instructions and un-checked the 3 General Protection Options boxes and then the Save Settings....unless you have Admin rights they really don't get un-checked....meaning they will attempt to load on re-boot and cause MSAS and\or Spybot to fire a shot across your bow with their warning message.

    Just brain storming :doubt:
  8. rufusboy
    Offline

    rufusboy Registered Member

    Hi Bubba,
    I am signed in with full admin rights,there are two desktops,mine and my sons,both have full rights. I have looked at both startup folders and All users plus default user. Can find no reference to Spywareguard .After uninstall the CLSID that you quote for Spywareguard is NOT present in the registry and having re-read the posts you refered me to I tried the whole process again from scratch,but end up in the same place! Nothing shows in Task manager and I have tried 3rd party progs to try to find the process but failed.
    An expert I am not ,but I can usually hunt down problems like this .
    http://www.wilderssecurity.com/images/icons/icon9.gif
    Unhappy
  9. Bubba
    Offline

    Bubba Updates Team

    What version of Spybot are you using....and if it's the old version of TeaTimer (non Spybot 1.4ß2)....do you recall ever selecting “Remember this decision” on an "Deny" ?

    If you answer 1.3 as version....and a yes to the....“Remember this decision” on an "Deny". I would appreciate if you would try something for me.

    Find the regkeyblack.sbe file....in the below folder....and temporarily move that file to a folder of your choice for safe keeping. Then delete the regkeyblack file from the below folder. Re-boot and see what happens.

    RegKeyBlack located here:
    • Windows NT/2000/XP
      C:\Documents and Settings\All Users\Application Data\Spybot - Search & Destroy\Excludes
  10. rufusboy
    Offline

    rufusboy Registered Member

    Hi Bubba,
    SORTED!!!
    Having tried all else I shut down my firewall(Agnitum Pro),Spybot resident and MS/Giant antispy then installed and uninstalled Spywareguard again . This time it has gone. Though nothing flagged up any query during the uninstal,
    it was obviously one of these applications that was causing the problem.
    Too much protection perhaps,which was why I wanted to remove Spywareguard
    in the first place. Not a problem I have encountered before ,but a lesson learned
    the hard way,we are told to close all other applications before install but I have never bothered before Uninstall!
    Thanks for all your efforts,and maybe this could help others
    that find problems removing this program.
  11. Bubba
    Offline

    Bubba Updates Team

    Yes it could...."help others that find problems removing this program".....but would you mind answsering the above questions concerning your Spybot version....or to be more precise....the date of Spybot's TeaTimer.exe file....because that will also be beneficial and more important concerning your problem. While shutting down the above mentioned programs "SORTED" your problem....which of those programs was the actual culprit would be way more beneficial to users with this problem than shutting down all the above mentioned programs fixed the problem.
  12. rufusboy
    Offline

    rufusboy Registered Member

    Hi Bubba,
    Our posts must have crossed ,your qestion about Spybot was not there when I started my last post.I am running Spybot 1.3 and must have allowed the
    change for Spywareguard to run. I have tried this again for you ,install Spywareguard,shutdown,uninstall, turn off/exit Spybot resident and that cures the problem, hope that helps.
    Thanks again for your trouble,much appreciated.
  13. rufusboy
    Offline

    rufusboy Registered Member

    Spybot1.3 last update 28-1-2005. Tea Timer File Version 1.3.0.12 ..(12-05-04)
    TEA TIMER.EXE-1F57E47A-pf . 20KB PF file 21-12-04.
    Have played with this again and the problem only occurs with Spybot resident
    switched on. Shut this down prior to uninstall and Spywareguard can be removed without problem.I am sorry if my last post was muddled the'flu' is getting the better of me. Hope this is OK
  14. Bubba
    Offline

    Bubba Updates Team

    Your more than Welcome
    I would caution you about using the TeaTimer feature with version 1.3 as far Allowing\Disallowing and "Remember this decision". I would also suggest you consider un-installing Spybot ver. 1.3 and installing their 1.4ß2 version. While that version is technically a ßeta version....through testing for over a month and following numerous threads in Spybots ßeta Forum....this version might as well be called a Released Candidate(RC1)....IMHO. One of the main problems is what I alluded to earlier concerning "Remember this decision" as noted in the below post.

    This Spybot Forum post---> http://forums.net-integration.net/index.php?showtopic=27626&view=findpost&p=130271

    Download for 1.4ß2 version---> http://forums.net-integration.net/index.php?showtopic=25574

    Edit:
    "Tea Timer File Version 1.3.0.12 ..(12-05-04)"

    Our posts crossed due to my slowness in typing :)

    In anycase....my above comments still stand concerning TeaTimer and ver 1.3 ;)
  15. rufusboy
    Offline

    rufusboy Registered Member

    Thanks for your advice re Spybot,I had no idea that there could be a problem! It has always seemed to be a totally reliable program,I will try the new version as per your advice and will keep up with events at the spybot forum and indeed here as I have now found such a useful and friendly help centre!
Thread Status:
Not open for further replies.