GMAL-04 Error

Discussion in 'FirstDefense-ISR Forum' started by dickcu, Feb 25, 2013.

Thread Status:
Not open for further replies.
  1. dickcu

    dickcu Registered Member

    Joined:
    Dec 24, 2009
    Posts:
    17
    Location:
    Seattle USA
    Has anyone yet figured out a solution to the GMAL-04 Error which prevents you from booting to any other snapshot other than the one you're in. I've Defragged, run DskChk and uninstalled and reinsalled First Defense with no luck. I see this error goes back to 2006 and I still can't find a solution online. Does anyone have an answer? Thanks so much!
     
  2. stapp

    stapp Global Moderator

    Joined:
    Jan 12, 2006
    Posts:
    5,184
    Location:
    England
    This was posted by Todd (Leapfrog Software) in this thread

    http://www.wilderssecurity.com/showthread.php?t=304596

    Other than that perhaps someone else may have some more ideas.
     
  3. dickcu

    dickcu Registered Member

    Joined:
    Dec 24, 2009
    Posts:
    17
    Location:
    Seattle USA
    Thanks for the quick reply Stapp. What I've done as I mentioned before is DiscCheck, defragged with Perfect Disk to no avail. Then reformatted the C-Drive. Started from scratch and everything was normal. Then when I tried to copy over the archived that caused this problem it booted to it but couldn't fully load. Using Acronis True Image I put all the original snapshots back and had the same GMAL error problem. Guess it's time to go to System Restore and Acronis for backup. I've been a FD-ISR user from the beginning and dread giving it up...scary. My many thanks for this program goes out to Todd at Leapfrog!!
     
  4. starfish_001

    starfish_001 Registered Member

    Joined:
    Jan 31, 2005
    Posts:
    1,039
    it is pain that you have this error but still no reason to give up FD ISR. o_O


    I had this again shortly after I went to Windows 8. I don't think there is a formula to fix this but luck is invloved no doubt but

    this fixed it for me


    I had to delete a snapshot and restore one from an archive
     
  5. dickcu

    dickcu Registered Member

    Joined:
    Dec 24, 2009
    Posts:
    17
    Location:
    Seattle USA
    I appreciate your interest in helping me very much but I had done all those things with the exception of cCleaner but I don't think this was a registry problem from what Todd and others are saying. However, yesterday I found an Acronis image I'd made in January...copied it over and everything's now back to normal. I have First Defense BACK!! Files have been updated from another backup and I'm totally back where I was.
     
  6. starfish_001

    starfish_001 Registered Member

    Joined:
    Jan 31, 2005
    Posts:
    1,039
    cc deletes junk out of the MFT as does privaser - that relates very well to your problem
     
  7. dickcu

    dickcu Registered Member

    Joined:
    Dec 24, 2009
    Posts:
    17
    Location:
    Seattle USA
    Thanks for the info Starfish. I'm good now but should it ever happen again I'll try both of those. Appreciate the help!
     
  8. jwcca

    jwcca Registered Member

    Joined:
    Dec 6, 2003
    Posts:
    628
    Location:
    Toronto
    Not saying that the problem was PerfectDisk in your case but, after years of them coding to play nice with FD, they scrapped that and their V 12 modified the MBR so that FD could only boot into the last active snapshot. I used ShadowProtect to recover an image with PerfectDisk V 11 and MBR and everything was OK.
    After spending way too much time trying to find out why, they said that a new feature, to allocate new file writes to a larger free space which would reduce the fragmentation for a given file, was the cause and if I installed V 12 without that feature, FD would be OK. I didn't bother, I wasn't going to take the chance that they'd make the 'feature' mandatory rather than optional in a future release, I stayed with V 11 until I switched to all SSDs and don't need to defrag.

    J

    You can search these forums for the posts that I made to warn other FD users.
     
Thread Status:
Not open for further replies.