Ghostwall + uTorrent/p2p apps

Discussion in 'Other Ghost Security Software' started by Comp01, Aug 15, 2007.

Thread Status:
Not open for further replies.
  1. Comp01
    Offline

    Comp01 Registered Member

    How can I setup ghostwall to allow utorrent, Shareaza and ares? Works fine if I disable the firewall, but as soon as I enable it, nothing, so how would I go about adding the rules for it?
  2. WSFuser
    Offline

    WSFuser Registered Member

    I believe the rule you should create is:

    Protocol: TCP (some p2p may also need UDP)
    Local ip: any
    Local port: any
    Remote ip: any
    Remote port: port number here

    For Shareaza I believe teh port is 6346. For uTorrent you have to check its settings to see what ports it uses.
  3. Erik Austin
    Offline

    Erik Austin Registered Member

    you've probably sorted this out already but,

    description: utorrent
    protocol: TCP/UDP
    local IP: any
    local port: the port specified in utorrent for incoming connections. mine is 20005. randomizing the port is not recommended
    action: allow
    direction: incoming (if you don't have the default 'allow all outbound' rule you'll have to make this both)
    remote IP: any
    remote port: any

    basically you need to allow all incoming udp & tcp to utorrent's port and allow all outgoing udp & tcp from utorrent to anywhere
  4. pittuf
    Offline

    pittuf Registered Member

    Hi, I'm having the exact same problem with utoorent and ghostwall.

    I have tried the settings listed above but to no avail.

    I know my port is forwarded correctly on my router as as soon as I set ghostwall to "allow all" and check the port with utorrent it is fine, but then when I revert back to the rule utorrent says no again.

    I only have the standard install rules running on ghostwall, could this be an issue?

    Any help or ideas would be very appreciated.

    Cheers

    Jonathan
  5. WSFuser
    Offline

    WSFuser Registered Member

    Did you make sure to place the utorrent rule above the Block all rule?
  6. pittuf
    Offline

    pittuf Registered Member

    Cheers for the reply.

    I continued playing with it after I posted and only after staring at the screen for a bit did I spot the up and down arrows and thought "I wonder!!"

    All working now so I'm happy. Utorrent is still showing an error when I run its port tester, but it is uploading now so I'm not going to worry about it.

    Still having problems accessing my bank (www.halifax.co.uk), and my hotmail account through outlook, and also the live mail site. Not sure yet if its ghostwall, or the fact I am now running on xp64? Gonna have to do a bit more investigation on that and possibly ask for help here later on if I can't get anywhere.

    Cheers again.

    Jonathan

    edit : sorted that now too, had to tinker with the mtu seeting.
    Last edited: Mar 24, 2008
Thread Status:
Not open for further replies.