Dual Boot XPSP3 & Windows 7RC1

Discussion in 'Acronis Disk Director Suite' started by Stairs007, Jul 22, 2009.

Thread Status:
Not open for further replies.
  1. Stairs007
    Offline

    Stairs007 Registered Member

    OK here it is.

    Attached Files:

  2. MudCrab
    Offline

    MudCrab Imaging Specialist

    Here's a file to try.

    There are two Vista entries, Vista Ultimate and Vista Entry 2. #2 was added by OSS (I renamed the entry so we could tell it apart more easily).

    From looking at the file, it seems that Vista's files were placed on the Primary partition on the other drive (STORAGE). I suspect this is because the drives were swapped when you installed Vista. This means you'd need to reinstall Vista correctly or move the booting files to the Vista partition and then update them.

    Let me know which entries boot and which ones don't. For those that don't, let me know what happens.

    I'm not seeing anything wrong with the Windows 7 entry. If it still doesn't boot from OSS, try this and see if it does:
    1. Deactivate OSS. Select XP as the default OS.
    2. Boot to the DD CD and start DD. Set the Windows 7 partition Active and hide the XP and Vista partitions. Apply the changes.
    3. Reboot and see if Windows 7 boots automatically.
    If it doesn't boot, reactivate OSS and let me know what happened.

    Check the STORAGE partition for the bootmgr file and BOOT folder (enable showing of hidden and system files, if necessary). Also check the Vista partition for this file and folder.

    Attached Files:

  3. Stairs007
    Offline

    Stairs007 Registered Member

    In the STORAGE folder there are 29 objects. 25 are folders and each every one of those has a bootmgr :eek: so what am I looking for specifically? These oflders have names like cs-CZ, en-US, Fonts, Nb-NO etc etc
    Did you move the booting files to the Vista partition or should I re-install Vista in the HDD 0 all over again? I don't know how this could have happened though since originally it was showing in the same HDD where 7 and XP are.
    I'll troubleshoot and let you know what happened.
    Strange thing, My Computer right now is not displaying 7 nor Vista. When I go into DD they're there. Disc Management shows them, why isn't My Computer showing those partitions?
    P.S.
    I know why Storage shows the boot stuff. I had saved those versions in there when in fact what I should be doing is aving the .txt file since this created more confusion. Man this stuff is subtle! OK fro now on in the new bootwiz have to saved as .txt and when ready to use do I convert them to OSS.
    Last edited: Aug 13, 2009
  4. MudCrab
    Offline

    MudCrab Imaging Specialist

    I set XP to hide the Windows 7 and Vista partitions. You can change this for the XP entry if you wish and then reboot into XP.

    It may indeed be easier to just reinstall Vista, but first check the Vista partition for the booting files. If you do decide to do this, I can give you specific instructions so it hopefully will work properly the first time.
  5. Stairs007
    Offline

    Stairs007 Registered Member

    This is the problem now My Computer does not see those partitions so I don't know how to get to them. I have not rebooted yet with your Bootwiz file so let's see if that will help any.

    Ouf not something I want to do re-install Vista since it's not a fast OS install like 7. Oh well if push comes to shove so be it. This has definitely been a learning experience to say the least.
  6. MudCrab
    Offline

    MudCrab Imaging Specialist

    When you reboot, you can edit XP's properties from the OSS menu. You can also do it from XP if you have OSS installed.
  7. Stairs007
    Offline

    Stairs007 Registered Member

    This thing seems to have gone south.
    I am able to get into XP but neither 7 nor Vista are cooperating any more.
    7 and Vista go into the Windows logo screen but no further as they hold on cue.
    I am thinking to back up the settings in the active XP user and install an image I have which has a working copy of XP and 7, unless you think otherwise, but it seems to be a bloody mess. Which I know I created. It's like a bad marriage right now :eek:
  8. MudCrab
    Offline

    MudCrab Imaging Specialist

    If you want to restore back, that's fine. I've done that too. It's the main reason I recommend creating a backup image of the drive before you start.

    Are Windows 7 and Vista not even booting manually? With OSS deactivated and the correct partition set Active?

    I really think things got messed up with the Vista installation. Especially since it had Windows 7 in its menu.

    If you're going to totally redo the drive and you have backups, I would suggest that you place all the Primary Windows partitions at the start of the drive and then have the Logical partition(s). Vista, for example, is in the slowest part of the drive (being at the end).
    [XP][Windows 7][Vista] -- [Programs - Logical][New Volume ?? - Logical]
Thread Status:
Not open for further replies.