Don't install HFS+ for windows 9.0 without a backup of you HDD

Discussion in 'NTFS for Mac & ExtFS for Mac' started by scutzi128, May 16, 2011.

Thread Status:
Not open for further replies.
  1. scutzi128
    Offline

    scutzi128 Registered Member

    Just installed HFS+ 9.0 and it made my OSX partition unreadable. Luckily I have a backup of my hard drive so no damage done.

    I first started with HFS 8.0 but that would not install with Windows 7 64 SP1 so I was directed by Paragon to HFS 9.0. It installed but it also made my OSX Partition unreadable. The only solution to getting my osx partition back to a readable state was to recover from an image I have of the hdd.

    Running everything on a 2010 13.3" Macbook pro with OSX 10.6.6 and Windows 7 Ultimate 64bit with SP1 on a 250gb OCZ Agility SSD.
  2. Mephist
    Offline

    Mephist Paragon Support

    Hello scutzi128,

    What operations were performed (copy on Mac OS Volume, copy from Mac OS Volume, delete files from Mac OS Volume etc.)?
  3. stenorman2001
    Offline

    stenorman2001 Registered Member

    I just had the same problem as scutzi128. I installed the drivers and rebooted, and after about 20 mins of working I got a BSOD. After restarting my HFS+ drives are considered RAW by Windows and do not appear by holding down the ALT-key when turning on my Mac.

    I'm running Windows 7 x64 SP1.

    After booting up off my Mac OS X Install DVD I was able to perform a disk repair with several errors being found:

    Incorrect number of extended attributes
    Volume header needs minor repair
    Invalid volume file count
    Invalid volume free block count

    After the repair was finished I was then able to re-access my main boot disk and return to Mac OS X. I could also recover my other partitions (stored on a Drobo) that were also HFS+ formatted and that were damaged by the software.

    Clearly there is a significant issue with this software and, since we both myself and scutzi128 are running Windows 7, Windows 7. In any case the product should definitely not be being sold to people who may lose access to their data.

    I'm extremely disappointed that a company such as Paragon would place software such as this on sale and will not be making purchases from them in the future, nor will I recommend their products. I will be pursuing, and expecting a full refund. Users have the right to expect a certain level of QA from companies and Paragon has definitely dropped the ball on this one.
  4. scutzi128
    Offline

    scutzi128 Registered Member

    I did not even access the mac osx partition from windows. After I installed the HFS+ drivers I rebooted as it instructed to do so and upon reboot my osx partition was borked. On a side note I installed ntfs for mac v9 and that worked fine no issues. Seems just HFS+ v9 has some serious issues atm.

    I also ran disk repair but was not successful in being able to restore the drive again. Although it did say it detected some errors when I tried to verify it.
    I ran the disk repair once it told me it could not repair it so I tried again. This time it did say it repaired it and when I held down the alt/option button the osx partition appeared but when I tried to boot to it I got the circle with a line through it and could get any further (tried rebooting several times) until I restored the disk from my backup.

    I also tried uninstalling HFS+ for windows v9 from my windows 7 partition but this also did not help restore the mac osx partition.

    PS: I beleive I posted this in the wrong forum. I posted it in the NTFS for mac instead of the HFS+ for Windows forum. My mistake. Could a moderator please move it?
  5. topcool
    Offline

    topcool Registered Member

    I have the same problem than both of you !! My mac DD is with HFS+, I tried HFS+9 on Windows 7.

    The first time Paragon HSF+9, it was perfect, and after a reboot it is a catastroph: RAW partition, no possibility to read it... So I hope I will recover my data on a mac... If I don't, I'll definitely be very upset!



    thx for posting
  6. macperl
    Offline

    macperl Registered Member

    Same issue here with win7 enterprise and v.9.0. It seems to work fine from windows (create a single directory, copy one file, then do safe eject), but will not mount without doing a disk repair on Mac Lion. This has happened twice, but I doubt I'll try this again unless there's a fix.
  7. LosNikitos
    Offline

    LosNikitos Registered Member

    Paragon support wrote that this issue is fixed in the latest release: -http://ftp.paragon.eu.com/support/HFS/PSG-216-PEE_002.msi-
    Last edited by a moderator: Nov 23, 2011
Thread Status:
Not open for further replies.