command line help?

Discussion in 'NOD32 version 2 Forum' started by joliv, Sep 9, 2003.

Thread Status:
Not open for further replies.
  1. joliv

    joliv Guest


    is there a command line switch to disable "use MAPI interface"?

    i have unchecked this option in every profile to remove the outlook warning, and in a manual scan this works fine. but when i go into the nod32 control center and click "local" or "diskettes", i always get that outlook warning first. i have unchecked the "use MAPI interface" but this is not saved, or even if i save it in another profile, when i click on local or diskettes again the next time, this new profile is not used, and i get the outlook warning again. anyone have a solution?

    also im using msn messenger 6. there is an option to "scan files for viruses using:"
    i have entered "C:\Program Files\Eset\nod32.exe" but when this executes, i get the outlook warning first. now i know amon will catch it anyway so i don't really need to use this option, but now i just want to know how to get rid of that darned outlook warning. if there is a command line switch that would be great.

    thanks :)
  2. joliv

    joliv Guest


    forgot to add... using nod32 v2 on win xp home
  3. martindijk

    martindijk Registered Member

    Jun 13, 2003
    Gorredijk - the Netherlands
    Hi joliv,

    When you have made a 'profile', you can use any custom made 'profile' to scan your disks.

    Lets say you have "My profile' and for instance 'joliv' where you have disabled the option to use Mapi, then Nod will scan the disk without the option 'Mapi'

  4. jocera

    jocera Registered Member

    Jan 28, 2003
    forgot i was registered here :)
    thanks for the reply Martin,

    I have only 1 profile that i named "JOLIV" in which i unchecked "use MAPI interface". all other profiles were deleted.

    well, here's what happens. when i click NOD32 in the control center. the right pane pops up and gives me 3 choices:

    1. Run NOD32
    2. Local
    3. Diskettes

    when i click on "Run NOD32", the on-demand scanner opens, with the title "JOLIV" so obviously its using the profile i made. no problem with the outlook warning.

    when i click on "Local" or "Diskettes", the outlook warning pops up first, then when i press the OK button, the on-demand scanner opens up with the title "<Profile configured from a command line>" apparently, it's not using the profile i saved.

    i then uncheck "use MAPI interface" and NOD will only let me save it to "JOLIV" profile or create a new profile. I have saved it to "JOLIV" and i have tried saving to a profile i named "Profile configured from a command line", however, the next time i click on "Local" or "Diskette", i get the outlook warning first.

    same when i receive a file in msn messenger 6, and it tries to open nod, i get the outlook popup first. i have to click the OK button, and the nod scanner opens with the title "<Profile configured from a command line>" (notice the chevrons before and after the profile name)

    the funny thing is if i double click nod32.exe in c:\program files\eset (which is where msn 6 is pointed to), the nod scanner opens without the outlook warning popping up. the title is "Profile configured from a command line" (notice there are no chevrons at the beginning and end of the profile name)

    is anyone with NOD32 running outlook (not outlook express) getting this same behavior when they press "Local" and "Diskettes"? if not, how did you get the warning to stop popping up first without having to make outlook your default email client?

    anyway, i just thought this was weird behavior... it's probably just my machine. i'm sorry for being so persistent. it's really not that big of a deal, nod works perfectly fine except for that nagging outlook popup. my curiosity is just getting the better of me.
  5. indodude

    indodude Registered Member

    Jul 2, 2003
    Hi jocera,

    you are not the only one...

    It seems that LOCAL and DISKETTES start always with the default profile which has "use MAPI interface" enabled, and you get the MS Outlook warning by default.

    The developers should say why we cannot save profiles for these 2 settings and have them started using these profiles.

    Likewise, I prefer to have downloaded files checked immediately, and up comes the MS Outlook warning. There should be a command line switch to tell Nod32 which profile to use. Developers?

  6. jocera

    jocera Registered Member

    Jan 28, 2003
    good to know its not just my machine

    thanks indodude :)
Thread Status:
Not open for further replies.