Cisco VPN and Firewall

Discussion in 'other firewalls' started by thenoble06, Feb 21, 2007.

Thread Status:
Not open for further replies.
  1. thenoble06

    thenoble06 Registered Member

    Aug 15, 2006
    Has anyone any experience of personal firewalls being installed on PCs running the Cisco VPN Client?

    My laptop has been running Outpost Pro for a while with no problems (I liked it!) but due to work I have had to install the Cisco VPN Client - and it has sent Outpost mental! It seems the Cisco software has some components of Zone Alarms firewall - and these problems mean the Cisco software doesn't work.

    Anyone used the Cisco software and a personal firewall on the same machine in harmony?
  2. FirePost

    FirePost Registered Member

    Jul 29, 2005
    Hello thenoble06,
    Does your work require the use of the ZA components? If not, perhaps a visit to the Outpost forum will give you a suggestion that works to allow both.
    Outpost 2.5 and Cisco VPN

    Agnitum also has a knowledge base article that disucsses how make it work.
    I am having problems using Outpost Firewall with Cisco VPN Client.
  3. thenoble06

    thenoble06 Registered Member

    Aug 15, 2006
    Thanks for the reply :)

    I've actually followed the steps that the Outpost forums to get Outpost to work with the VPN Client but to no avail :(

    Thanks for the links though.
  4. gagman

    gagman Registered Member

    Feb 5, 2006
    ZA is now part of Checkpoint, and Checkpoint and Cisco are not the best friends in the world regarding security business.
    Should be amazing if Cisco VPN is usoing some ZA components.

    BTW, I am using VPN client all the time on my laptop (with stateful firewall activated, so no real need to extra FW).
    But sometimes, I install some other FWs (comodo, coreforce, sygate) with no trouble.

    By not working, you mean the ipsec tunnel is not up ? Right ?
    Are you sure of the rules of the FW ? Try to use the "allow all" policy with outpost. Does this work ?
  5. ph2000

    ph2000 Registered Member

    Jun 22, 2006
    Don't know if it will help but -

    I already had Cisco VPN on - Then Outpost. I had the same problem but it works now.

    I did the following based on the variations given at their forum:

    Searched for vsdata.dll and vsdatant.sys, rename the files. Rebooted.

    Opened regedit, navigate to HKEY_LOCAL_MACHINE, then System. Under HKEY_LOCAL_MACHINE\System\ControlSet001 or ControlSet002 or CurrentControlSet\Services, look for a key called vsdatant. Delete the key. Reboot.

    Added CVPND.EXE and VPNGUI.EXE to the trusted applications list.

    I never did any of these:

    1 - Disable Cisco Stateful firewall.

    2 - On the Outpost Firewall's Tools menu, select Options.

    Click the System tab and under Global rules and rawsocket access click Rules.
    Click Add and create the following rules:
    Where the protocol is TCP
    and Where the direction is Outbound
    and Where the remote host is (your VPN host address)
    and Where the remote port is (your VPN port number)
    Allow It

    Where the protocol is UDP
    and Where the direction is Inbound
    and Where the remote host is
    and Where the local port is 62500-62600
    Allow It

    Now I could not connect at all with the VPN. Now it's fine. I don't know if your issue is different. I've seen problems where it will connect...but nothing works correctly. Either way, removing and reinstalling sometimes fixes VPN problems here. Of course you will need to repeat the instructions above.

Thread Status:
Not open for further replies.