Beware of Acronis "Leftovers" Issues

Discussion in 'backup, imaging & disk mgmt' started by Arvy, Jan 17, 2012.

  1. Nebulus
    Offline

    Nebulus Registered Member

    This is very interesting to know in case it's happening. Until now though, I installed and uninstalled Acronis True Image (free WD edition), and none of the described problems manifested itself.
  2. Arvy
    Offline

    Arvy Registered Member

    I'm not sure what that comment is intended to imply, but there are very significant differences between the current Acronis True Image 2012 release and WD's derivative utility based on earlier Acronis versions. For one thing, Acronis has changed their device class filter setup and its driver loading completely.

    If you're simply saying that you currently have no obvious issues with your own computer, I'm sure we're all happy for you. But if you think that means that all of the people who have experienced disastrous problems are delusional, think again. Have you actually looked inside your system registry to see what leftover "goodies" are lurking there in wait for a future conflict with other software?
  3. Nebulus
    Offline

    Nebulus Registered Member

    I was merely stating that the version I mentioned doesn't seem to have the problems you mentioned, not that ALL versions are free of problems.

    I never said that.
  4. Gorkster
    Offline

    Gorkster Registered Member

    Did you check to see if the registry entries and corresponding files that the problem referred to were removed upon uninstallation of the version you used? If not, the problems still could show up later if the low level drivers (or whatever they're called) were actually left on the machine. Some people have reported, in other versions, not having issues until later on after they install something else which isn't compatible with the Acronis "left behinds." Because of this I'm curious if you performed a thorough check or if you simply haven't noticed any problems thus far.
  5. oldcoder
    Offline

    oldcoder Registered Member

    Just FYI,

    I used Revo to remove TIH 2010 as you can no longer download the Acronis TIH 2010 cleanup utility.

    There are a few entries remaining in the registry but nothing frightening.
  6. majoMo
    Offline

    majoMo Registered Member

    Like advertised in first post Revo isn't suitable to uninstall this kind of applications. Some luck is needed. :ouch:
  7. oldcoder
    Offline

    oldcoder Registered Member

    Phew, glad to be lucky on this occasion then! :)
  8. Nebulus
    Offline

    Nebulus Registered Member

    Actually, I tested some other imaging solutions after uninstalling Acronis True Image, and no problem manifested itself. However, after your inquiry I got curious and decided to check the registry myself - and there was indeed a leftover LowerFilter from Acronis (vidsflt53). Needles too say I removed it...

    Note to self: Next time be more careful before writing a post about something :)
  9. Arvy
    Offline

    Arvy Registered Member

    As majoMo says, there's an element of luck involved. Or, more precisely, a convoluted combination of circumstances that may or may not arise in any given case. Most times, so long as the Acronis driver files remain in place corresponding to the device class filters in the registry, the issue will go unnoticed. It's when that correspondence between the registry "leftovers" and the available drivers gets disturbed (whether by subsequent software installs or for any other reason) that the real "fit hits the shan" so to speak.

    Anyhow, I'm only trying to make people aware of potential issues. Not saying that the worst is always going to happen; only that it can and sometimes does. And, since Acronis has now barred me and many other critics from their own forums in a desperate effort to keep things quiet, this seemed like an appropriate place to post a fair warning which I've tried to keep as strictly factual as possible.

    For the lucky ones who see no problem, that's great. I'm glad to hear it and just hope it stays that way.
  10. oldcoder
    Offline

    oldcoder Registered Member

    I'm surprised they haven't shut their forums down completely - I still pop in to lurk for entertainment reasons and it's truly apocalyptic.
  11. John Doe Genius
    Offline

    John Doe Genius Registered Member

    A quick install/uninstall isn't enough. ATIH2012 turned out be a creepy micro-organism; the app started well, but the bad behaviour escalated, specially after “help” from the support to update some drivers. (I have used ATIH for years, never needed support … until I installed 2012.)

    Nebulus, are you running Win7? Is MS's backup feature through the CP still working?
  12. Nebulus
    Offline

    Nebulus Registered Member

    No, it is XP SP3 32 bit.
  13. Gorkster
    Offline

    Gorkster Registered Member

    They are locking threads right and left now though...
  14. Arvy
    Offline

    Arvy Registered Member

    Yup. In fact, it appears that some of my old warning posts there have disappeared completely. And at least one of their more honest and forthright MVPs also seems to be "missing in action" lately. Just the sycophantic "Acronis is never wrong" MVP suck-ups left now.

    Strangely, their email about my own banning came out of the blue weeks after, having moved on to other things, I had stopped posting anything there at all myself. Somebody (perhaps the missing MVP?) tried to contact me personally via PM thereafter, but of course I couldn't log in to read the message.

    Anyhow, it's all "water under the bridge" so far as I'm concerned. It's themselves they're hurting most, not me. It's quite sad, really.
    Last edited: Apr 6, 2012
  15. John Doe Genius
    Offline

    John Doe Genius Registered Member

    I recently discovered that my event viewer constantly recorded an error at boot up: BitLocker-Driver Event ID 24620. Encrypted volume check: Volume information on \\?\Volume{71239103-091e-11e0-909e-806e6f6e6963} cannot be read. I googled for the issue, Microsoft says: This event does not indicate that a system error has occurred. Therefore, you can safely ignore this event. However, I was not able to run chkdsk /r; Windows reported (at reboot) that an error prevented the process to start, and most likely a newly installed SW package had caused the error. I learned to use the mountvol command to display the volumes:
    \\?\Volume{71239103-091e-11e0-909e-806e6f6e6963}\
    *** NOT MOUNTABLE UNTIL A VOLUME MOUNT POINT IS CREATED. ***

    I ran MOUNTVOL /R, and the error in the system log disappeared, but now MOUNTVOL displayed:
    \\?\Volume{ca592f25-7fa4-11e1-b210-806e6f6e6963}\
    *** NO MOUNT POINT ***
    Still I could not run chkdsk /r.

    During my googling I found a post asking “have you ever installed Acronis True Image?”, but the guy had only used a Paragon product. My error reporting started the day after I uninstalled Paragon Drive Copy with hotcore3.sys driver (?), but I have previously had TrueImageHome2012. I really do not fully understand these volume Upper/LowerFilter issues. Another cause for my problems might be Nero InCD (now uninstalled) and that my USB HDD has been disconnected in a wrong way?

    What I did: I restored from a Paragon backup archive created BEFORE I installed Paragon Drive Copy. Still mountvol displays the “No mount point” message, but now I am able to run chkdsk /r.

    Is anybody capable to enlighten me?
  16. Arvy
    Offline

    Arvy Registered Member

  17. John Doe Genius
    Offline

    John Doe Genius Registered Member

    Thanks, Arvy, yes I have read the linked article including this paragraph:

    If a volume is damaged, you can use the BitLocker Repair Tool to salvage any recoverable data. Using the BitLocker Repair Tool is an advanced procedure that should be performed by an experienced administrator.

    I have no drive with unreadable data. I do not like to start this “advanced procedure” suitable for “an experienced administrator”.

    The MS statement I referred to, can be found here: http://support.microsoft.com/kb/976733/EN-US

    BTW, the discussion about Acronis & Paragon is here: http://social.technet.microsoft.com...f/thread/1f8cbab3-f235-45e6-9358-43c374c92613
  18. Arvy
    Offline

    Arvy Registered Member

    Well, in that case, if it's not actually causing a substantive operational problem, I'd suggest just ignoring the event log message.

    Other measures, such as trying to mount a non-existant volume, are only likely to add to the confusion. In fact, my guess would be that that's why BitLocker is raising an error message in the first place. Probably harmless in the circumstances.
  19. John Doe Genius
    Offline

    John Doe Genius Registered Member

    But I am not satisfied, when 'chkdsk /r' denies to run due to a newly installed SW package, something is “not good”. As I already have said, I have succeeded to re-enable chkdsk through a backup restore.

    Still it is impossible to run 'sfc /scannow'. Windows notifies me: “Windows Resource Protection could not start the repair service.”
    I have found answers like this: “This happens if the TrustedInstaller (Windows Modules Installer) service is disabled. Use these steps to reset the service startup type.”. But, no, the service IS set to manual start as described.

    I have succeeded to run sfc from a WinPE boot (Windows Repair Disk):

    DISKPART> list volume
    Volume ### Ltr Label Fs Type Size Status Info
    ---------- --- ----------- ----- ---------- ------- --------- --------
    Volume 0 G Reparer dis UDF DVD-ROM 283 MB Healthy
    Volume 1 J DVD-ROM 0 B No Media
    Volume 2 C System NTFS Partition 99 MB Healthy <-- Normally no drive letter
    Volume 3 E COMPAQ NTFS Partition 136 GB Healthy <-- My C: drive in normal boot
    Volume 4 D Data NTFS Partition 150 GB Healthy
    Volume 5 F FACTORY_IMA NTFS Partition 11 GB Healthy
    Volume 6 H CORSAIR_1 FAT32 Removable 7700 MB Healthy
    Volume 7 I VERBATIM_1 FAT32 Removable 3822 MB Healthy

    DISKPART> exit
    Leaving DiskPart...

    X:\windows\system32>sfc /scannow /offbootdir=C:\ /offwindir=E:\Windows

    Beginning system scan. This process will take some time.

    Windows Resource Protection found corrupt files but was unable to fix some of them.
    Details are included in the CBS.Log windir\Logs\CBS\CBS.log.
    For example C:\Windows\Logs\CBS\CBS.log

    I have performed the actions described by Microsoft:
    To determine which files could not be repaired by the System File Checker tool, follow these steps:
    Open an elevated command prompt.
    Type the following command, and then press ENTER:
    findstr /c:"[SR]" %windir%\Logs\CBS\CBS.log >%userprofile%\Desktop\sfcdetails.txt

    This gives me an empty sfcdetails.txt file; there is no entries like “[SR] Cannot repair member file” in the CBS.log. The only error messages I can find, are these:
    SQM: Failed to start upload with file pattern: C:\Windows\servicing\sqm\*_std.sqm, flags: 0x2 [HRESULT = 0x80004005 - E_FAIL]
    SQM: Failed to start standard sample upload. [HRESULT = 0x80004005 - E_FAIL]
    SQM: Failed to start upload with file pattern: C:\Windows\servicing\sqm\*_all.sqm, flags: 0x6 [HRESULT = 0x80004005 - E_FAIL]
    SQM: Failed to start always sample upload. [HRESULT = 0x80004005 - E_FAIL]
    In c:\Windows\Logs\CBS I found a 'suspicious' file, FilterList.log, only 4 days old, the content:
    InCDRec 0 0
    KLIF 9 0
    luafv 1 0
    FileInfo 9 0

    I do not know how/why this file is created. “InCD” is the free software from Nero I have tried to get rid off. I still have these files:
    c:\Windows\System32\catroot\{F750E6C3-38EE-11D1-85E5-00C04FC295EE}\InCDF.cat
    c:\Windows\System32\catroot\{F750E6C3-38EE-11D1-85E5-00C04FC295EE}\InCDPass.cat
    c:\Windows\System32\catroot\{F750E6C3-38EE-11D1-85E5-00C04FC295EE}\InCDRec.cat

    Maybe I should try to delete them? (But is not a good idea to fiddle with the system without knowing what I am doing...).

    I should like to receive an advice. Of course I do not know that the problem is bundled with Acronis, it might be Nero InCD. It cannot be related to Paragon Drive Copy (with hotcore3.sys) since I still have the problem after restoring a backup from a day BEFORE PDC was installed (for some days).
  20. John Doe Genius
    Offline

    John Doe Genius Registered Member

    Through uninstalling of some USB mobile drivers (not working anymore), deleting several registry entries, I had a kind of success. The System File Checker did run, but reported 'corrupted files, not able to repair'. I have to go for a 'format C:' and a complete re-installation.

    BTW, No Acronis this time!
  21. SandyH
    Offline

    SandyH Registered Member

    Very good article and so true, as I found out the hard way. Gave True Image a try and decided that my current system of backing up to external hard drives worked better for me. After uninstalling and trying to remove a couple drivers Win7 wouldn't start. Restoring to an older good boot fixed it. Anyone who asks me now about backup software will be told that Acronis True Image is toxic. A couple external drives are just as effective and a lot safer.
  22. Gorkster
    Offline

    Gorkster Registered Member

    Yeah, I'll probably one day soon be utilizing @Arvy's prowess to safely uninstall ATIH 2011 completely. It was truly a disaster switching from Ghost to Acronis. Since I still want to keep my system Symantec free (bad support, buggy bloated software) my current #1 choice as a replacement for Acronis is Macrium Reflect.
  23. MarcP
    Offline

    MarcP Registered Member

    That's where I ended up too. Been using Macrium for two months now and even got to use it once to recover an image. It just works!

    I've been increasingly unhappy with Acronis and voiced my displeasure on their forums. I was banned forthwith. There are bugs that have been around since last year with no indication when they'll be fixed. Since I bought Macrium, they had 3 updates that were easily applied. The difference in response speed to issues was a nice welcome change.
  24. Gorkster
    Offline

    Gorkster Registered Member

    I asked Acronis for a refund for the ATIH 2012 I bought five months ago and never downloaded or installed. I didn't expect much, and that's exactly what I got. I was basically told that I should upgrade my ATIH 2011 install to 2012. I was told 2012 was a bit rocky at first but a patch back in December fixed all the problems. I think they believe I'm a fool. I think they believe we're all fools!

    I considered, with a refund for 2012, keeping 'em around until ATIH 2013 was released. I guess I tend to think (false hope) with the amount of flack they've taken over the last 2-3 releases that they'd finally own up and maybe 2013 would be worth its salt. But with their decision to decline my exception request for a refund I'll probably never know.

    I'll keep ATIH 2011 around 'cuz I have family and friends' backed up images I may need at some point, but I'll only install it on vms where I can totally "undo" the installation after using it for a specific incident. But once I uninstall (and maybe format my hard drive?) the software from my hardware computer I won't visit their forums or read about them at all anymore. I think it's disgusting how they've deleted helpful posts in their forums all in an apparent effort to make themselves look better, even though the posts contained relative user-to-user information to provide help that can't be obtained elsewhere. It also pains me to no end that they have updated their uninstall routines and instructions due to hard work by @Arvy and others in the forum without giving due credit. Or without even thanking them!

    Acronis has a large customer base, and this has led them toward an apparent casual attitude about their software. But money talks. Hopefully if they continue to swindle customers they'll either end up on the wrong side of a law suit and/or lose enough of their customer base that it will hit them hard. I, for one, have decided my money will be giving speeches form a different pulpit. ;) I'm following the direction many others have already taken, and I hope to one day learn that even more will follow in my direction.
  25. Gorkster
    Offline

    Gorkster Registered Member

    Hmm.... I should probably share this due to my somewhat scathing previous post...

    I sent Acronis one last email letting them know how I felt about the denial of my "exception request" for a refund and they reconsidered. They have started the $40 refund process for the 2012+PP upgrade and the second 2012+PP full license. I'm quite surprised, but happy they have chosen to do the right thing. What makes me happiest about this is that refunds are money and money talks so perhaps actions like this will "help them" to improve.

    Not sure I care at this juncture whether or not they improve, but I have taken them off my list of companies I will never do business with again. I may wait and see what ATIH 2013 brings, but with them clamping up their forums it may not be possible to make an informed decision if/when the time comes anyway.

    Sorry, in retrospect I probably should have started a new thread for these two posts.