Answer for those trying to get Media Player Sharing Working

Discussion in 'ESET Smart Security' started by RoloTomasi, Oct 23, 2011.

Thread Status:
Not open for further replies.
  1. RoloTomasi

    RoloTomasi Registered Member

    Jan 15, 2011
    Ran into a bunch of issues trying to play content from my (ESET protected) laptop on the new Samsung Smart TV. The symptoms I was facing was
    - "allshare" function on the TV peristently saying "no device connected"
    - Media player failing to show the TV in the device list under "Stream - More Streaming Options" even after you've enabled home media sharing in the network options and "Automatically allow devices to play my media" and "Allow remote control of my player" in Media Player 12.

    Didn't find the definitive answer on the web so here it is (I think) for anyone else struggling:

    1) Firstly, forget Samsung's Allshare software. I could NOT get that to work at all (and I mean even locally on the PC and adding shared folders). It never seemed to properly update the shared folders, and yet seemed to send the CPU through the roof a LOT failing to do so. The one answer I found on the web was to simply use Media Player, and that's what I have working now.

    2) Despite the "Trusted Zone" stuff in ESET (obviously the TV is on the home network and therefore should be trusted) ESET was definitely preventing something with the firewall. I could "push and pull" video's and pictures to and from the TV as soon as I disabled it, but I didn't want to leave it that way

    3) I set the firewall to "automatic filtering mode with exceptions" and defined a rule to open up all the Media Player firewall ports both TCP and UDP (Microsoft article here lists them to the local trusted zone. This didn't produce results immediately so not sure this was required in the end.

    4) I set another firewall rule to open all ports to the one IP address my TV is on (192.x.x.x so can't come from the internet) - how much damage can a TV do right? Again, no instant result to not sure this was required, I may try removing this again at some point and I'll update the post with comments

    5) This bit seemed to do it : I went into "Advanced Firewall Setup" - then - "IDS and Advanced options" and checked the following
    • Allow UPNP for system services in the trusted zone
    • Maintain Inactive TCP connections
    • Allow Multicast address resolution in the trusted zone

    and Bingo: the TV started showing up in Media Player shared device options, and I could also see it in the PlayTo drop down (you need to put some Media in the right hand side "Play list" to use this option to "push" content to the TV. The TV also started seeing the computer (in AllShare, Photo's etc when in the SmartTV button).

    Now it's all working, it's great to show your photo's on the nice big screen you've invested in!:D
  2. tony_m

    tony_m Eset Staff Account

    Nov 22, 2010
    Hi RoloTomasi and welcome to the forum!

    Thank you for sharing your experience here with us, this can be very helpful for others :thumb:

    What we usually recommend is to make sure that the device IP address was added to the Trusted zone, as well as to the "Addresses excluded from active protection (IDS)" zone in the Personal firewall.

    Glad to know it is now working for you :)
Thread Status:
Not open for further replies.