XBOX Live failed MTU with Nod32

Discussion in 'ESET Smart Security' started by Defiant1337, Jan 2, 2008.

Thread Status:
Not open for further replies.
  1. Defiant1337

    Defiant1337 Registered Member

    Joined:
    Jan 1, 2008
    Posts:
    3
    I have to keep switching the Nod32 firewall off because it keeps failing the MTU test when I have it switched on. Does anyone know a way around this problem ?

    EDIT: I should add I the firewall setup for sharing as I have a ICS network and my sons computer doesn't have any problems
     
    Last edited: Jan 2, 2008
  2. asmithz

    asmithz Registered Member

    Joined:
    May 28, 2008
    Posts:
    1
    I have the same problem and I am looking for a solution
     
  3. Marcos

    Marcos Eset Staff Account

    Joined:
    Nov 22, 2002
    Posts:
    14,374
    Does disabling all IDS options make a difference? If you enable logging all blocked connections, does the firewall log show blocked connection attempts?
     
  4. Eriksrocks

    Eriksrocks Registered Member

    Joined:
    Jun 17, 2008
    Posts:
    3
    I've been searching about this issue and I came upon this thread, so I thought I would chime in. I'm using a 360 connected to my Vista PC through ICS (Internet Connection Sharing) with ESS version 3.0.657.0. :)

    Completely disabling the firewall allows the 360 to connect flawlessly to Xbox Live. However, when the firewall is enabled, no matter what I try I can't get it to work. I tried the instructions here multiple times, but I couldn't get it to work. As mentioned above the 360 passes the IP test, the DNS test, and then fails the MTU test. I've enabled logging for both blocked connections and blocked incoming worm attacks, and after multiple connection attempts there are no blocked connections in the log.

    Disabling all IDS options doesn't do anything. :(

    It seems like there is something beyond configuration in the GUI that is blocking the 360. I don't know why a firewall would filter or change the MTU, but apparently that's what's happening here. :)

    Could anyone give some input? It would be greatly appreciated. :thumb:

    Thanks! :D
     
  5. mata7

    mata7 Registered Member

    Joined:
    Nov 8, 2005
    Posts:
    635
    Location:
    Mississauga, Canada
    i did report this when it was on beta and still you guys have the problem
     
  6. Capp

    Capp Registered Member

    Joined:
    Oct 16, 2004
    Posts:
    2,125
    Location:
    United States
    I have my xbox 360 connected through a router that my computer is connected to as well and it connects just fine on my end. Have you considered getting a switch to share your internet connection instead of ICS? They are pretty inexpensive and make networking a breeze.
     
  7. Eriksrocks

    Eriksrocks Registered Member

    Joined:
    Jun 17, 2008
    Posts:
    3
    I've been using a router, but our basement is getting finished so I had to move the 360 upstairs in the same room as the PC where there is no ethernet wiring. My PC is connected wirelessly to the router, and I didn't want to shell out $100 for Microsoft's proprietary 360 wireless adapter. :rolleyes: ICS seemed like the easiest option, requiring only one (short) ethernet cable. :)

    Once the construction is done, I'm going to move it back down into our usual setup. The thing is, I just can't afford to disable my firewall for a month. ;)

    Marcos, I got your PM and I'll try that when I have the time and report back to you. Thanks. :)
     
  8. Marcos

    Marcos Eset Staff Account

    Joined:
    Nov 22, 2002
    Posts:
    14,374
    Those having problems connecting to Xbox, try creating a rule that will allow all UDP packets from Xbox's IP on all ports.
     
  9. Eriksrocks

    Eriksrocks Registered Member

    Joined:
    Jun 17, 2008
    Posts:
    3
    Okay, I finally found a solution. I never got the ICS situation resolved, so hopefully that will be fixed in the next version, but I did find a workaround to connecting the 360 through the PC without it being blocked by the firewall.

    This worked for me, it might not work for everyone, but hopefully if somebody is in the same situation that I am this will work for them as well. :)

    Instead of doing ICS, I bridged both my ethernet connection and my wireless connection within the Network Connections panel in Windows Vista. Follow this instructable here, but make sure that you turn the Xbox 360 off before you bridge them, then turn it on after. That seemed to solve some problems for me. :)

    This allows the Xbox 360 to connect to the internet through the PC, and the PC still has an internet connection. For some reason, this is not filtered by the firewall and therefor the 360 can connect to Xbox Live flawlessly, even when the firewall is fully enabled in Automatic mode.

    Again, I don't know if this will help everyone, I don't know if it will work on XP, but hopefully it will help someone that is in the same situation that I was in. ;)

    Thanks,
    Erik.
     
Thread Status:
Not open for further replies.