Workstation borked. What happened here?

Discussion in 'hardware' started by Gullible Jones, Jan 21, 2013.

Thread Status:
Not open for further replies.
  1. This evening I attempted to unlock the screen on my workstation - a used Dell Precision 390 running Ubuntu 12.10 - and discovered that the USB keyboard had stopped working.

    Unplug and replug keyboard -> no go. I figured a reboot might help, and couldn't do anything else anyway; so I hit "Switch user" and attempted to shut down using LightDM's power menu. The computer refused to shut down.

    After waiting a while and verifying that Alt+SysRq didn't work, I manually powered the machine down and rebooted.

    On subsequent boot attempts, it never got as far as the OS. It just hung on the POST screen, and refused to respond to any keyboard input other than Ctrl-Alt-Delete. After a few tries it started complaining about a keyboard failure.

    I decided maybe it had overheated or something, and went off to do other things for five minutes. When I returned, I tried booting again, and got the keyboard failure again.

    So I tried plugging in a known good PS/2 keyboard. This time, it allowed me to select a boot drive. I selected the main SATA drive and it booted Ubuntu, albeit rather more slowly than normal. Hallelujah! So I looked through through the kernel logs to see if there was anything odd. There wasn't. Hmm, I thought, maybe I can find something in the BIOS setup screen... Reboot again.

    It let me into the BIOS screen, but nothing looked out of whack. Okay, exit and reboot...

    Only to be met with another BIOS screen hang. Reboot again, and this time it complains about the keyboard failure again, and refuses to boot at all.

    I'm quite perplexed at this point. What could possibly be going wrong?

    Edit: okay, I got it to boot and seem to have localized the problem - the rear USB ports don't work any more. Bizarre. Maybe power connector came loose or something.

    Edit: Umm, motherboard light is amber now! Not good!
     
    Last edited by a moderator: Jan 23, 2013
  2. Resolved - the diagnostic lights on the front indicate that a motherboard failure has occurred.

    Boo.

    :mad:
     
Loading...
Thread Status:
Not open for further replies.