Wireless Internet Connection

Discussion in 'ESET Smart Security' started by ilovepie, Dec 27, 2010.

Thread Status:
Not open for further replies.
  1. ilovepie

    ilovepie Registered Member

    Joined:
    Dec 27, 2010
    Posts:
    10
    Hi,

    I have just installed ESET Smart Security 4.2.67.10 English. After I installed it, ESET keeps on blocking the wifi network. I can use the internet, but WLAN will not connect. I have tried to uncheck ARP Poisoning attack detection and DNS Poisoning attack detection, and it did not work. The firewall logs shows block incoming SSDP (UPNP) requests. Any help is appreciated.

    Thanks in advance
     
  2. Marcos

    Marcos Eset Staff Account

    Joined:
    Nov 22, 2002
    Posts:
    14,374
    Probably you meant that you connect via WLAN to the Internet fine but computers in your LAN do not see each other when connected via wifi? Do you have your LAN subnet in the Trusted zone?
     
  3. ilovepie

    ilovepie Registered Member

    Joined:
    Dec 27, 2010
    Posts:
    10
    how do I set up LAN subnet in the Trusted zone
     
  4. Marcos

    Marcos Eset Staff Account

    Joined:
    Nov 22, 2002
    Posts:
    14,374
    In the Zone and rule setup section, activate the Zones tab, double-click "Trusted zone", click the "Add IPv4 address" button and enter your subnet.
     
  5. ilovepie

    ilovepie Registered Member

    Joined:
    Dec 27, 2010
    Posts:
    10
    After I added Lan subnet the firewall log still says the same thing.
     

    Attached Files:

  6. stackz

    stackz Registered Member

    Joined:
    Dec 27, 2007
    Posts:
    619
    Location:
    Sydney Australia
    I added a rule for svchost.exe to allow inbound TCP/UDP communication from the Trusted zone.

    Host Process for Windows Services
    Allow TCP/UDP from Trusted zone for svchost.exe
    Direction: In
    Action: Allow
    Protocol: TCP & UDP

    Remote side: Zone: Trusted zone, For every port

    Local side: For every port
     
  7. Marcos

    Marcos Eset Staff Account

    Joined:
    Nov 22, 2002
    Posts:
    14,374
    Does disabling the "Block incoming SSDP (UPnP) requests" rule make a difference? Note that rules are applied in all firewall modes except the default automatic mode.
     
  8. ilovepie

    ilovepie Registered Member

    Joined:
    Dec 27, 2010
    Posts:
    10
    @stackz I tried your setting but it makes no difference

    @Marcos After I disable "Block incoming SSDP (UPnP) requests" rule, I get somthing new on the firewall log
     

    Attached Files:

  9. Marcos

    Marcos Eset Staff Account

    Joined:
    Nov 22, 2002
    Posts:
    14,374
    Try creating a rule for outgoing communication via the IGMP protocol as shown in the screenshot. Also allow UPnP in the Trusted zone in the IDS section of the firewall setup.
     

    Attached Files:

    • igmp.JPG
      igmp.JPG
      File size:
      29.9 KB
      Views:
      480
  10. ilovepie

    ilovepie Registered Member

    Joined:
    Dec 27, 2010
    Posts:
    10
    I created the rule and in ISD and advanced options I have enable all the option in "Allowed services" and "Vista/Window 7 services"
     

    Attached Files:

  11. uup115

    uup115 Registered Member

    Joined:
    Jan 2, 2011
    Posts:
    4
    HI Im new to eset and i was having this problem but i found out a way to solve it WITHOUT disabling your firewall.

    For some reason eset ss dose something to wireless adapter when its installed
    i fooled around with eset for a day or 2 and then i realized eset was not the problem, it was windows

    so i went in to Control Panel...>Network and Internet Connections...> Network connections. Now all u have to do is right click on your LAN or HIGH SPEED INTERNET connection (whatever you are using, for me i got a wireless network)
    then go down to properties select it...AND right there in the general tab look down and u will see ( this connection uses the following items: ) scroll threw the list and u should come across ESET PERSONAL FIREWALL make sure the box next to it is unchecked ( If its checked then uncheck the box) select ok and your internet connect should come right on

    i dont know if this will mess up anything but i have not gotten any thing yet (thx to eset) and i scan my computer every night befor bed so its up to u
    hope this will help oh yea im use in windows xp x32 so i dont know if this will work on any other versions HAVE A HAPPY NEW YEAR!!!!

    i posted this in another thread but i'll do it here just in case someone dont see it
     
  12. Marcos

    Marcos Eset Staff Account

    Joined:
    Nov 22, 2002
    Posts:
    14,374
    Doing so will disable the personal firewall for the given NIC completely.
     
  13. Marcos

    Marcos Eset Staff Account

    Joined:
    Nov 22, 2002
    Posts:
    14,374
    What exactly doesn't work now? According to the firewall log, only a standard HTTP communication with 206.33.55.126 was blocked that time.
    To troubleshoot the issue further, we'd need you to create 2 pcap logs; one as per the instructions here when the problem occurs and the other one using Wireshark and the firewall disabled when the issue does not occur.
     
  14. uup115

    uup115 Registered Member

    Joined:
    Jan 2, 2011
    Posts:
    4
    @Marcos So what you are saying is disabling the option makes my connection go around esets firewall not allowing it to check for malicious data coming inbound?
     
  15. ilovepie

    ilovepie Registered Member

    Joined:
    Dec 27, 2010
    Posts:
    10
    @Marcos The problem is shown in the picture. Also, I will do what you suggested.
     

    Attached Files:

  16. uup115

    uup115 Registered Member

    Joined:
    Jan 2, 2011
    Posts:
    4
    @ ilovepie i have that problem when my wireless adepter's not in windows config mode but it looks like u have windows 7 so the icons could look different
    sorry if i am not of any help
     
  17. ilovepie

    ilovepie Registered Member

    Joined:
    Dec 27, 2010
    Posts:
    10
    @uup115 thanks for trying to help and i have window vista
     
  18. Robin Springall

    Robin Springall Registered Member

    Joined:
    May 17, 2009
    Posts:
    9
    @Marcos

    I'm having similar problems on one of my PCs: the wi-fi connection was disabled when I upgraded ESS from 4.2.35 to 4.2.67.

    This only happened on my desktop, which has a RealTek wireless-G NIC under XP SP3, not on my laptop with an Atheros adaptor and Vista 32-bit SP2. Disabling the firewall didn't cure the problem, so I've reverted to 4.2.35 and everything's hunky-dory again.

    I tried the upgrade three times: firstly using existing settings (they work, after all), then again using new interactive mode settings, and finally new automatic mode settings: in each case ESS stopped the Wifi NIC from getting past the router to the internet. Something's changed for the worse between 4.2.35 and 4.2.67 :(
     
  19. Marcos

    Marcos Eset Staff Account

    Joined:
    Nov 22, 2002
    Posts:
    14,374
    Here are general instructions for troubleshooting connectivity issues:
    If disabling the firewall helps:
    - enable logging of blocked connections in the IDS setup
    - enable special firewall logging per the instructions here
    - reproduce the problem
    - disable the firewall
    - start capturing the network traffic using Wireshark (we recommend to leave the bare minimum of network-aware applications running)
    - try to reproduce the problem (everything should work)
    - stop the capturing

    Provide the following stuff to an ESET personnel:
    1, ESS configuration exported to an XML file
    2, the output of running "ipconfig /all"
    3, both pcap logs created by the firewall and Wireshark
    4, description of your network topology (e.g. what devices you use, such as routers, modems, network printers, Xbox, etc.), also provide the IP address of your computer and the remote device.

    If disabling the firewall doesn't help:
    - does switching the firewall integration to "Only scan application protocols" or "Personal firewall is disabled completely" and restarting the computer make a difference?
    - outcome of "sc query epfwndis"
     
  20. Robin Springall

    Robin Springall Registered Member

    Joined:
    May 17, 2009
    Posts:
    9
    ... or just stick with 4.2.35 rather than reduce the protection of 4.2.67 :)
     
  21. ilovepie

    ilovepie Registered Member

    Joined:
    Dec 27, 2010
    Posts:
    10
    @Robin Springall just wondering where do you get 4.2.35? I can't find it on the site
     
  22. toxinon12345

    toxinon12345 Registered Member

    Joined:
    Sep 8, 2010
    Posts:
    1,200
    Location:
    Managua, Nicaragua
    You've lost the installer of version 4.2.35?
    Previous Releases (4.0.474) here: http://www.eset.com/download
     
  23. Robin Springall

    Robin Springall Registered Member

    Joined:
    May 17, 2009
    Posts:
    9
    I keep a local copy of the previous version, just in case the latest one on the downloads page throws a wobbly. Here's 4.2.35 32-bit (the link will expire in 7 days):
     
    Last edited by a moderator: Jan 4, 2011
  24. Radzha

    Radzha Registered Member

    Joined:
    Sep 16, 2010
    Posts:
    2
    yes it does, but in my case it is the best and the easiest solution.

    because I have Internet on my PC via LAN, but I share internet via WLAN, so my brother could use it on his notebook.


    Thanks guys ;)
     
  25. ilovepie

    ilovepie Registered Member

    Joined:
    Dec 27, 2010
    Posts:
    10
    I want to unblock this rule but I don't know how. I tried to create a rule like in Marcos previous post but it didn't work.
     

    Attached Files:

Thread Status:
Not open for further replies.