WinPatrol 20.5

Discussion in 'other anti-malware software' started by The Seeker, May 15, 2011.

Thread Status:
Not open for further replies.
  1. The Seeker

    The Seeker Registered Member

    Joined:
    Oct 24, 2005
    Posts:
    1,100
    Location:
    Adelaide
    WinPatrol 20.5

    This release has fixed a problem I had with increased boot times. Very happy.
     
  2. Blues7

    Blues7 Registered Member

    Joined:
    May 11, 2009
    Posts:
    858
    Location:
    Blue Ridge Mountains
    I see it's not mentioned but I wonder if this version has fixed the issue for XP users not being able to "kill" running tasks?
     
  3. J_L

    J_L Registered Member

    Joined:
    Nov 6, 2009
    Posts:
    8,516
    This time, WinPatrol install automatically terminates applications without consent, and doesn't restart them. Bad behaviour in my opinion.

    When's the native 64-bit version coming?
     
  4. Blues7

    Blues7 Registered Member

    Joined:
    May 11, 2009
    Posts:
    858
    Location:
    Blue Ridge Mountains
    J_L, can you provide some info regarding the apps which were terminated?

    I haven't installed the new version as yet. Still using the last version which works with XP (without the "kill task" issues).

    Thanks in advance. :thumb:
     
  5. J_L

    J_L Registered Member

    Joined:
    Nov 6, 2009
    Posts:
    8,516
    AquaSnap, Ditto, Firefox, JDownloader, Malwarebytes Anti-Malware (even Protection), TrueCrypt, and WordWeb. It was rather annoying.
     
  6. Blues7

    Blues7 Registered Member

    Joined:
    May 11, 2009
    Posts:
    858
    Location:
    Blue Ridge Mountains
    Hmmm, I don't have all those apps (haven't used WordWeb recently) and I'd have already closed Firefox but I wouldn't be happy about having MBAM closed without any kind of notification or alert.

    Thanks for sharing that. I think I'll hold off on installing, at least for now.

    Much appreciated.
     
  7. G1111

    G1111 Registered Member

    Joined:
    May 11, 2005
    Posts:
    2,127
    Location:
    USA
    I am running MBAM Pro with protection enabled and just installed the latest WP version. the WP installer didn't close anything here. I disabled WP before installing over the existing version and disabled Emsisoft to exclude its BB popup warnings.
     
  8. SIR****TMG

    SIR****TMG Registered Member

    Joined:
    May 31, 2004
    Posts:
    757
  9. J_L

    J_L Registered Member

    Joined:
    Nov 6, 2009
    Posts:
    8,516
    That may be why. What version of Windows are you running?
     
  10. Blues7

    Blues7 Registered Member

    Joined:
    May 11, 2009
    Posts:
    858
    Location:
    Blue Ridge Mountains
    After reading your reply I decided to see what would happen on my XP system.

    Closed WP, installed over the top and nothing was closed by the installation.

    It did request a reboot (which I did) and everything seems to be up and running just fine.

    However, the "Kill Task" feature still does not appear to be working with XP. (At least on my system.) Not sure it's a big issue as I have Process Hacker and Process Explorer to handle those tasks if need be so I probably won't bother to revert back to the earlier version.
     
    Last edited: May 16, 2011
  11. G1111

    G1111 Registered Member

    Joined:
    May 11, 2005
    Posts:
    2,127
    Location:
    USA
    Windows 7 Home Premium 32-bit.
     
  12. nn110

    nn110 Registered Member

    Joined:
    Mar 5, 2011
    Posts:
    2
    J_L, you are not alone:) .
    for me, the WP installer terminated MBAM PRO's GUI (mbamgui.exe, but mbamservice.exe was still running) and Hostman (hm.exe) and avast!'s gadget.
     
    Last edited: May 16, 2011
  13. Francis93

    Francis93 Registered Member

    Joined:
    Feb 1, 2011
    Posts:
    311
    Same here. During the installation, the installer crashed Google Chrome and killed background processes.

    Have you guys noticed any strange post-installation behavior?
     
    Last edited: May 16, 2011
  14. SKA

    SKA Registered Member

    Joined:
    Aug 2, 2002
    Posts:
    154
    Any one has link to earlier stable version - its missing at winpatrol.com download page

    SKA
     
  15. stapp

    stapp Global Moderator

    Joined:
    Jan 12, 2006
    Posts:
    7,293
    Location:
    England
  16. Triple Helix

    Triple Helix Webroot Product Advisor

    Joined:
    Nov 20, 2004
    Posts:
    12,012
    Location:
    Ontario, Canada
    Small GUI bug anyone else seeing this? Options Tab>Confirm Exit when closing Winpatr~~ I sent an email to Bill!

    TH
     

    Attached Files:

  17. The Seeker

    The Seeker Registered Member

    Joined:
    Oct 24, 2005
    Posts:
    1,100
    Location:
    Adelaide
    I noticed this too.

    Clipboard01.png
     
  18. Blues7

    Blues7 Registered Member

    Joined:
    May 11, 2009
    Posts:
    858
    Location:
    Blue Ridge Mountains
    I saw that as well.

    I'd like to hear from Win XP users if they find any other bugs besides the "Kill Task" issue. I can live with that one if all the other features and alerts are operating properly. (Don't want to revert back unless necessary.)

    Thanks in advance..
     
  19. Triple Helix

    Triple Helix Webroot Product Advisor

    Joined:
    Nov 20, 2004
    Posts:
    12,012
    Location:
    Ontario, Canada
    Thanks for the confirmation! As I said I already sent an email to Bill maybe others should also? support[at]WinPatrol.com

    TH
     
  20. BoerenkoolMetWorst

    BoerenkoolMetWorst Registered Member

    Joined:
    Dec 22, 2009
    Posts:
    3,771
    Location:
    Outer space
    More detailed changelog
     
  21. jmonge

    jmonge Registered Member

    Joined:
    Mar 20, 2008
    Posts:
    12,883
    Location:
    Canada
    improved alitle bit then:)
     
  22. Brummelchen

    Brummelchen Registered Member

    Joined:
    Jan 3, 2009
    Posts:
    1,732
    Cookie handling for Mozilla fails on start - i need to chose the profile-folder
    manually (not cookies.sqlite). but gui need a fix:
     

    Attached Files:

  23. Doraemon

    Doraemon Registered Member

    Joined:
    Aug 5, 2009
    Posts:
    202
    I'm going crazy about WinPatrol in these latest releases... A bug here, a bugfix there... I miss the good old 2008/2009 versions which IMO were very stable! o_O :blink: :gack:
     
  24. emmjay

    emmjay Registered Member

    Joined:
    Jan 26, 2010
    Posts:
    883
    Location:
    Triassic
    I installed it yesterday over an existing release which was still running ... it shut it down and killed my ISP GUI and the laptop power manager. I could not get the ISP gui to reinstate in that session but the power manager did reinstate. Restarted system and all went back to normal. Never seen this happen before. WinPatrol is a great product...would not be without it.
     
Thread Status:
Not open for further replies.