Windows Update Settings in W7

Discussion in 'other software & services' started by emmjay, Sep 5, 2016.

  1. emmjay

    emmjay Registered Member

    Joined:
    Jan 26, 2010
    Posts:
    883
    Location:
    Triassic
    Today I clicked on Change Settings (W7) under Windows Update and the drop down box for Important Updates is frozen - the down arrow does nothing. It is currently set to 'check for updates but let me choose whether to download and install them'. I have Microsoft Update and Software notifications ticked but nothing else ticked. I removed the tick from Microsoft Updates to see if that changed the drop down box, but it did not, so I put the tick back.

    I want to change the setting in Important Updates to Never Check but I can not (it has always worked before). I have chosen to just install security-only updates from the MS Update Catalog starting Oct 1, 2016. I know I can ignore whatever MS sends me in WU, but I'd rather not have LMS eating 50% of my CPU every month. I'm done with this service.

    Has MS disabled the WU settings because of their policy change on updates for W7/8 ? I can not find anything on any MS sites about the settings being disabled. I'd appreciate it if anyone here would check their W7 system for me - tnx .
     
  2. Minimalist

    Minimalist Registered Member

    Joined:
    Jan 6, 2014
    Posts:
    5,085
    I've checked mine and it's OK, I can choose what I want.
    Did you set your update options through Gpedit? This could prevent managing it from Control panel.
    And one suggestion - disable Windows update service and enable it only when you check for updates.
     
  3. emmjay

    emmjay Registered Member

    Joined:
    Jan 26, 2010
    Posts:
    883
    Location:
    Triassic
    No I did not edit group policies at all. I did delete a standard user today and had to make a regedit modify to allow (permission) the delete. Could that have done it - I did it to myself? :oops:

    Good suggestion on WU - I can do it that way too.
     
  4. Minimalist

    Minimalist Registered Member

    Joined:
    Jan 6, 2014
    Posts:
    5,085
    That's strange. Setting permissions on registry keys to allow, shouldn't prevent you from modifying it, but who knows...
    Do you try to change this settings while logged in as admin or as a standard user?
     
  5. emmjay

    emmjay Registered Member

    Joined:
    Jan 26, 2010
    Posts:
    883
    Location:
    Triassic
    I was logged in as admin when I removed the standard user. I changed the permissions from SYSTEM to myself (admin), then changed the permission back to SYSTEM after it deleted the standard user and all the files (I chose not to keep the files).
     
  6. Minimalist

    Minimalist Registered Member

    Joined:
    Jan 6, 2014
    Posts:
    5,085
  7. emmjay

    emmjay Registered Member

    Joined:
    Jan 26, 2010
    Posts:
    883
    Location:
    Triassic
    I went with the first suggestion and deleting the suggested 2 registry entries reset WU back to normal. All fixed. Tnx for finding that link.
     
  8. Minimalist

    Minimalist Registered Member

    Joined:
    Jan 6, 2014
    Posts:
    5,085
    You're welcome :)
     
Loading...