Windows 7 - Why must I manually add "Everybody" security permission to share stuff with XP?

Discussion in 'other software & services' started by paulescobar, Jan 14, 2013.

Thread Status:
Not open for further replies.
  1. paulescobar

    paulescobar Registered Member

    Joined:
    Sep 22, 2008
    Posts:
    181
    For the last two days, I have existed in a never-ending hell trying to figure out the Windows 7 method of sharing folders.

    I am a die-hard XP user who has just installed Windows 7 Ultimate. As I wish to use my PC as a god...I used the actual "Administrator" account. I also enabled "File/Printer Sharing" & "Public Folder Sharing", while disabling "Password Protected Sharing".

    Within my "Administrator" account's USER folder, there are various "My..." folders (My Pictures, My Videos, etc.). I simply wanted to share them on the Workgroup so that my other XP computer could access them.

    Problem is, my XP computer would return "Access is denied" errors whenever attempting to connect to these Windows 7 shares.

    What I noticed was that there was a lock icon on my Windows 7 Administrator account user folder (this supposedly means it is a "private" folder). There seems to be no way to disable such "private" folders. This apparently affected the sub-folders which I wanted to share.

    The only solution I could find was to add "Everyone" with "Full Control" in the Windows 7 folder "Security" tab. Yes, this worked. My XP computer could access and modify (depending on the share permission).

    But the implication is that anytime I want to share a folder within my Windows 7 User account folder...I must set BOTH the share and security permission to "Everyone".

    When I used Windows XP, I never had to set both share & security. I would just set the share to "Everyone" and the security permissions would oblige.

    Is there any way to make this happen in Windows 7?
     
    Last edited: Jan 14, 2013
  2. Brian K

    Brian K Imaging Specialist

    Joined:
    Jan 28, 2005
    Posts:
    8,647
    Location:
    NSW, Australia
    paulescobar,

    I just checked my computers. WinXP to Win7. WinXP to Win8. I don't have that issue. It just works.

    Our only differences is I don't have Guest or Public Sharing and I have a password for each computer. Maybe you need passwords.
     
  3. berryracer

    berryracer Suspended Member

    Joined:
    Jan 24, 2008
    Posts:
    1,640
    Location:
    Dubai, UAE
    I also have to add everyone to each sharing folder otherwise they can't access it

    I have homegroup disabled and set it to manage using usernames and passwords and turned password protected sharing OFF
     
  4. paulescobar

    paulescobar Registered Member

    Joined:
    Sep 22, 2008
    Posts:
    181
    So we have the same problem.

    Too bad, because I was hoping this wasn't some widespread thing...and perhaps I had over-looked something.

    Do you mean that you have similar User/Pass accounts on each computer?
    XP = User1 / Pass1
    7 = User1 / Pass1

    If so, then it is interesting. But I would rather have a solution which allows any XP account to access...without having to tediously add an "Everyone" security entry each time.

    Again, what I'm trying to get at is this...
    In XP, when I share a folder from the C: drive...all I have to do is add an "Everybody" share setting.
    But in 7, I have to do both a share setting & a security setting.
    Totally odd.
     
  5. Brian K

    Brian K Imaging Specialist

    Joined:
    Jan 28, 2005
    Posts:
    8,647
    Location:
    NSW, Australia
    I do use the same username and password on each computer but that's not essential. Just me being lazy.

    Password protected sharing is turned ON.

    I've never needed to change permissions.
     
  6. Sully

    Sully Registered Member

    Joined:
    Dec 23, 2005
    Posts:
    3,719
  7. berryracer

    berryracer Suspended Member

    Joined:
    Jan 24, 2008
    Posts:
    1,640
    Location:
    Dubai, UAE
    To make things worse dude, try formatting your computer, the next time you want to share a folder you have to first go into the security tab of that folder, then remove the permissions associated with the previous user, then only can you share it, you don't have to re-add "Everyone" again to the list as it will already be saved in the properties of the folder but you have to remove the 2394932874236%9231874 user permissions that you see before you can share it
     
  8. Sully

    Sully Registered Member

    Joined:
    Dec 23, 2005
    Posts:
    3,719
    That should be standard procedure. The NT File System (NTFS) allows objects and containers (that is, files and folders) to have a DACL (discretionary access control list). This list contains all rights and permissions for that file or folder.

    When you add a user or group to that DACL for a file/folder, then delete the OS and reinstall, the OS has new security descriptors basically (sort of). Since you did not create the folder new again (I presume it was on a different drive etc), the DACL did not change on it. It would be normal then for that "old" information to still exist, and it would normal for it to cause conflicts. Not that is has to, just understanding what information is there and how it effects things explains what you are talking about.

    A PITA yes, but not really a bug or other stupid new improvement. Just the nature of things.

    Sul.
     
  9. berryracer

    berryracer Suspended Member

    Joined:
    Jan 24, 2008
    Posts:
    1,640
    Location:
    Dubai, UAE
    Thanks for this informative post bro.

    I will format my partitions in FAT32 format in this case :)

    Cheers
     
  10. Sully

    Sully Registered Member

    Joined:
    Dec 23, 2005
    Posts:
    3,719
    FAT32 limitations to be aware of.

    You have no way to set permissions other than shared or not shared. Not of much concern for a local network with nothing sensitive stored.

    You cannot have a file larger than 4gb. This limitation is the real killer IMO, as many files are now larger than this.

    Sul.

    Edit: I used to prefer FAT32 myself, but the file size limitation caught up with me ;)
     
  11. berryracer

    berryracer Suspended Member

    Joined:
    Jan 24, 2008
    Posts:
    1,640
    Location:
    Dubai, UAE
    ohh crap! it's good you told me that before I went ahead and formatted!

    thanks bro
     
  12. paulescobar

    paulescobar Registered Member

    Joined:
    Sep 22, 2008
    Posts:
    181
    I just realized what you were getting at, and I tried it.

    I created a standard-level user account in Windows 7, and noted its user/pass combo. Then I used Windows XP and entered those credentials to access my Windows 7 shares.

    While I got the Windows 7 share listing...when I tried to enter a particular shared folder, I received the same error as before: "Access is denied".

    The standard-level user/pass combo could not be used to access shares that were made in an administrator-level USER folder.

    Obviously, I could just provide my network users with an administrator-level user/pass combo. But that would mean they could get physical administrator access to my actual computer...or even use remote admin$ share listing (which I have enabled). There are many reasons why this would be undesirable (for example, my brother gets pissed off at me and goes on a delete spree).

    Ugh! So annoying. Guess I'll still have to do the tedious two-step "Advanced Share & Security Permissions" hoopla.
     
  13. paulescobar

    paulescobar Registered Member

    Joined:
    Sep 22, 2008
    Posts:
    181
    For those who might stumble upon this topic in the future...

    I would just like to highlight that the solution (or rather, clarification) of the core issue can be found here:
    https://www.wilderssecurity.com/showpost.php?p=2174299&postcount=7

    I completely missed the grouping of "User" folder shares into a "User" item in the WorkGroup. Since the shares were not appearing as individual items in the WorkGroup...I assumed that that both shares & security permissions had to be manually set for the shares to appear.

    The point being, Windows 7 Sharing Wizard does automatically configure the security permission when the share is set. But if the share is set from within the "User" folder, it will be grouped within the "User" item in the WorkGroup.

    Manual share & security permissions would only be required if you wish to display that kind of share as an individual item in the WorkGroup.

    Anyways, a special thanks to Sully who kindly tolerated my foolish oversight and hijacking of his topic. Here is his excellent and detailed response which provided clarity on the issue:
    https://www.wilderssecurity.com/showpost.php?p=2174887&postcount=11
     
Loading...
Thread Status:
Not open for further replies.