Windows 7 Hosts file

Discussion in 'other security issues & news' started by mllopes, Dec 27, 2010.

Thread Status:
Not open for further replies.
  1. mllopes

    mllopes Registered Member

    Joined:
    Feb 10, 2005
    Posts:
    92
    Location:
    Portugal
    Hi
    I have recently deleted hosts file in my windows 7 PC because of jailbreak of iphone 3gs, my question is (since now i can use tiny umbrella for that) how can i restore the hosts of windows and do i need it to do it, is it necessary?
    Thank you
     
  2. siljaline

    siljaline Former Poster

    Joined:
    Jun 29, 2003
    Posts:
    6,619
  3. mllopes

    mllopes Registered Member

    Joined:
    Feb 10, 2005
    Posts:
    92
    Location:
    Portugal
    Thank you for your answear, however i can tell you that jailbreak in most of the countries is legal
     
  4. mllopes

    mllopes Registered Member

    Joined:
    Feb 10, 2005
    Posts:
    92
    Location:
    Portugal
    Still have a problem doing this:

    Create the new default hosts file. To do this, follow these steps:

    1. Right-click an open space in the %WinDir%\system32\drivers\etc folder, point to New, click Text Document, type hosts, and then press ENTER.
    2. Click Yes to confirm that the file name extension will not be txt.

    Because i dont have the file hosts anymore and when i right click there is no option to new text document
     
  5. siljaline

    siljaline Former Poster

    Joined:
    Jun 29, 2003
    Posts:
    6,619
    Perhaps, though, there are jailbreak issues in the US, this is a US Based board.

    I will not reply to any further questions on the jailbreak aspect of your query.

     
  6. m00nbl00d

    m00nbl00d Registered Member

    Joined:
    Jan 4, 2009
    Posts:
    6,623
    1. Open Notepad with Administrator rights.
    2. Copy and paste the text for the Windows 7 hosts file, presented at the link (near the bottom).
    3. In the field for the name, type *. (then press enter)
    4. Then write "HOSTS" (without the quotes) and save.

    Go to the C:\Windows\System32\drivers\etc and see if the file HOSTS is without extension. If it is, then is OK.

    Kind regards. ;)

    P.S: Obviously, before performing steps 3 and 4, you need to go to C:\Windows\System32\drivers\etc
     
  7. siljaline

    siljaline Former Poster

    Joined:
    Jun 29, 2003
    Posts:
    6,619
    Use the MS Fit It tool in the middle of the preceeding screen.

    If no joy, post a query to the Microsoft Social Answers Forum

     
  8. mllopes

    mllopes Registered Member

    Joined:
    Feb 10, 2005
    Posts:
    92
    Location:
    Portugal
    Thank you moonblood and sljaline but i am going to try mvp hosts.
     
  9. siljaline

    siljaline Former Poster

    Joined:
    Jun 29, 2003
    Posts:
    6,619
    Going to a third party Hosts file will not resolve your issue. Follow the suggestions provided, Here, Here
     
    Last edited: Dec 27, 2010
  10. mllopes

    mllopes Registered Member

    Joined:
    Feb 10, 2005
    Posts:
    92
    Location:
    Portugal
    I have used the microsoft tool and now in drivers/etc the hosts placed by mvp the type has changed to File OLD, is it repaired?
     
  11. xxJackxx

    xxJackxx Registered Member

    Joined:
    Oct 23, 2008
    Posts:
    4,045
    Location:
    USA
    The default hosts file for Windows 7 looks like this:

    # Copyright (c) 1993-2009 Microsoft Corp.
    #
    # This is a sample HOSTS file used by Microsoft TCP/IP for Windows.
    #
    # This file contains the mappings of IP addresses to host names. Each
    # entry should be kept on an individual line. The IP address should
    # be placed in the first column followed by the corresponding host name.
    # The IP address and the host name should be separated by at least one
    # space.
    #
    # Additionally, comments (such as these) may be inserted on individual
    # lines or following the machine name denoted by a '#' symbol.
    #
    # For example:
    #
    # 102.54.94.97 rhino.acme.com # source server
    # 38.25.63.10 x.acme.com # x client host

    # localhost name resolution is handled within DNS itself.
    # 127.0.0.1 localhost
    # ::1 localhost


    Since it is all commented out I assume it doesn't do much but if you want the original back you can copy all of those lines into notepad and save it as hosts with no extension. This will require you to change the "Save as type" to "All files (*.*)". You can replace it with the MVP file (again, no extension) but I recommend finding a filtering DNS service instead (OpenDNS, Norton DNS) if you want to block sites.
     
  12. Franklin

    Franklin Registered Member

    Joined:
    May 12, 2005
    Posts:
    2,517
    Location:
    West Aussie
    I think the HOSTS file is hidden by default so in order to see if it's around you need to "Show hidden files, folders or drives" through Tools - folder options - View tab.
     
  13. mllopes

    mllopes Registered Member

    Joined:
    Feb 10, 2005
    Posts:
    92
    Location:
    Portugal
    Right now i am using NIS 2011 so there is no problem if i delete the hosts file right?
     
  14. xxJackxx

    xxJackxx Registered Member

    Joined:
    Oct 23, 2008
    Posts:
    4,045
    Location:
    USA
    I would just put the default one back. Why delete it?
     
  15. mllopes

    mllopes Registered Member

    Joined:
    Feb 10, 2005
    Posts:
    92
    Location:
    Portugal
    Because i cant do it, when i do it like you say and changed the type of file when saving when i go check at system32\etc it shows as a text file
     
  16. mllopes

    mllopes Registered Member

    Joined:
    Feb 10, 2005
    Posts:
    92
    Location:
    Portugal
    Ok
    Fixed it already, the problem relies in changing read file only, for that requires administrator privilegies.
    Thank you for all your help, now i have the default hosts file
     
  17. siljaline

    siljaline Former Poster

    Joined:
    Jun 29, 2003
    Posts:
    6,619
    Thanks for advising of the positive result :thumb:

     
    Last edited: Dec 30, 2010
Loading...
Thread Status:
Not open for further replies.