Win 7 x64, ess 4.71.2 HomeGroup not working!

Discussion in 'ESET Smart Security' started by ecsjjgg, Aug 22, 2011.

Thread Status:
Not open for further replies.
  1. ecsjjgg

    ecsjjgg Registered Member

    Joined:
    Jun 26, 2008
    Posts:
    4
    Location:
    Lindesberg, Sweden
    Hi all, the topic says it all... I'm trying to get the homegroup in windows 7 working with ess, the about says that I have Personal firewall module: 1068 (20110727) installed. Is this the recommended versiono_O And I have read this forum and taken the following actions: turned off "tcp and utp scanning attack detection", and also turned off "block unsafe addresses after attack detection"

    Plus that I have of course enabled the Windows 7 HomeGroup support.

    Now, the only way to be able to see other computers in my HomeGroup is to select "Do not filter network traffic (Disable firewall)". But I can then enable the firewall again, and the other computers will still be visible for some time (about 15 minutes), but then they are gone again! I am using a Linksys E4200 Router, with my main computer wired to it, and my 3 laptops + my other peripherals (a Samsung TV, bluray player, and android phone) connected wireless...

    How do I go forward with my problem??


    Is this a bug in ess 4.x that is fixed in the ess 5 RCo_O

    Should I try installing ess 5 RC??

    Is this problem fixable??

    Thanks in advance for any help You may have, I'm willing to try 'em all out...


    Oooh, btw, my 2 computers running ess 4 is visible from the other 2 computers. running Microsoft Security Essentials and Windows 7's built-in firewall! it's just from the 2 computers running ess 4, that has a problem seeing any other computers! When i run the HomeGroup troubleshooter, it comes to the conclusion that I have ess 4 installed, and that it is blocking the HomeGroup from functioning properly...
     
  2. IvanFraser

    IvanFraser Registered Member

    Joined:
    Feb 3, 2008
    Posts:
    14
    The default settings disable your networking, but are generally very good otherwise. Same issue was had here on my Win7 with ESS 4.

    You need to enable UPNP. Check you have it set to allow file and printer sharing in the trusted zone. (available in the advanced setup section) Then, run the firewall in the interactive mode and permanently allow the network permissions in the alerts. Once that's running, change the firewall to run in automatic mode (if that's what you want) 'with exceptions'.

    The new 5RC is running perfectly well on my setup - but had to make the same adjustments to get the network communication going between my pc and laptop and tv.
     
  3. NoobStick

    NoobStick Guest

    Joined:
    Jun 23, 2011
    Posts:
    0
  4. stackz

    stackz Registered Member

    Joined:
    Dec 27, 2007
    Posts:
    619
    Location:
    Sydney Australia
    Go to Setup -> Network -> Configure rules and zones -> Zones tab.

    Zone Name: Addresses excluded from active protection (IDS)
    Add your subnet or the LAN addresses needed + make sure they're also listed in the Trusted zone.
     
  5. ecsjjgg

    ecsjjgg Registered Member

    Joined:
    Jun 26, 2008
    Posts:
    4
    Location:
    Lindesberg, Sweden

    And IvanFraser, how do I select "interactive mode"? That whole section is completely grayed out in my ESS! I can't seem to select that mode...
     
  6. Marcos

    Marcos Eset Staff Account

    Joined:
    Nov 22, 2002
    Posts:
    14,374
    Do you have HomeGroup support enabled in the IDS section?
     

    Attached Files:

  7. ecsjjgg

    ecsjjgg Registered Member

    Joined:
    Jun 26, 2008
    Posts:
    4
    Location:
    Lindesberg, Sweden

    Yes Marcos, of course I have HomeGroup support enabled, check my first post...
     
  8. IvanFraser

    IvanFraser Registered Member

    Joined:
    Feb 3, 2008
    Posts:
    14
    If it's greyed out, I'm not sure, but that maybe some glitch in your installation - so perhaps a reinstall?

    You should be able to get to the network settings in the menu via setup - network - advanced personal firewall setup. in there you should have a drop down menu under 'filtering mode'.

    The kb article linked in the post above from Noobstick should be all you need. Unless there's something up with your install - in which case a fresh install may be in order.

    Best of luck

    Ivan
     
  9. ecsjjgg

    ecsjjgg Registered Member

    Joined:
    Jun 26, 2008
    Posts:
    4
    Location:
    Lindesberg, Sweden

    Oops, it's not grayed out, it was the "learning mode" that was grayed out, but now I found where to enable it...

    I have now installed ess 5 rc1, and my HomeGroup seems to work now, thank you all for your tips...
     
    Last edited: Aug 23, 2011
Thread Status:
Not open for further replies.