Win 10 1803 Core Isolation and Memory Integrity

Discussion in 'other software & services' started by itman, Aug 18, 2018.

  1. itman

    itman Registered Member

    Joined:
    Jun 22, 2010
    Posts:
    7,514
    Location:
    U.S.A.
    The fun begins …………..

    Every attempt to set on memory integrity took out my RealTek audio driver circa 2010. Try as I might, every attempt to find an updated driver for Win 10 failed with Win stating I had the best driver. Tried the .cab files from the Win Update Catalog and the same thing happened. Finally found a Win 10 driver on the Realtek web site that works: http://218.210.127.131/downloads/do...=24&Level=4&Conn=3&DownTypeID=3&GetDown=false .

    Been running about a day with memory integrity enabled. After a few initial page rendering glitches in IE11, things settled down. Except for a tab slower performance in IE11, nothing else notable. Well, not really.

    Just started up Win 10 from standby mode and was greeted with a never before seen BIOS generated "black" screen stating system faulted due to overclocking. What the …….! Pondering that, I realized it was complaining about my DDR3 RAM speed of 1600 Mhz which is what it is rated at versus the motherboard bus supported speed of 1333 Mhz. Now I have been running at 1600 Mhz for years using multiple Win OS vers. w/o issue. So now have memory set at 1333 Mhz and have my fingers crossed that coming out of the next sleep cycle doesn't cause another black screen. Wonder if this is perhaps due to "hybrid" sleep which I kept enabled while at the same time having fast startup disabled? It might not play nicely with memory integrity protection when memory is overclocked.

    Presently waiting for the next "bork" from Win 10's new and improved security will cause.
     
  2. itman

    itman Registered Member

    Joined:
    Jun 22, 2010
    Posts:
    7,514
    Location:
    U.S.A.
    Tried everything I could think of to get standby mode to work. Zip success with memory integrity enabled. So standby is presently disabled.

    What is strange is I can hear the HDDs powering up etc.. It's just that the desktop never initializes.
     
    Last edited: Aug 18, 2018
  3. EASTER

    EASTER Registered Member

    Joined:
    Jul 28, 2007
    Posts:
    8,294
    Location:
    U.S.A. (South)
    @itman,

    That "exact" issue already plagued my sole Windows 10 unit and is/was a pain. Mainly because it continues to spam the same complaint no matter what. I also am trying to board Win 10 on as you say 'circa' machinery? When something gets remedied I may try to do that update but this is just another time wasting issue they keep pushing into it. Arggg. And why I am sooooooo comfortable back on 8.1 again
     
  4. reldel

    reldel Registered Member

    Joined:
    Aug 14, 2007
    Posts:
    26
    Location:
    Felton, DE, USA
    With Core Isolation and memory integrity turned on I got a green screen of death trying to install Emsisoft and could only recover using Macrium Reflect backup. Turned off memory integrity and EAM installed fine.
     
  5. wat0114

    wat0114 Registered Member

    Joined:
    Aug 5, 2012
    Posts:
    2,440
    Location:
    Canada
    I'm not sure if you tried it already or if it would work, but to recover from the green screen did you try booting into the BIOS and temporarily disable Virtualization, Intel VT-d and Memory protection?

    As for Core isolation memory integrity issues especially with older hardware, I remember reading somewhere that MS is apparently pointing the finger squarely at hardware developers to update their drivers so they can work with the feature.
     
  6. itman

    itman Registered Member

    Joined:
    Jun 22, 2010
    Posts:
    7,514
    Location:
    U.S.A.
    It appears my resume from standby mode issue is due to the Realtec based audio driver for Win 10 I installed. Looking at its settings, it appears to be missing options dealing with power related events that exist for example in Realtec network adapter drivers. Makes sense since the motherboard OEM's will take this driver and modify it to characteristics unique to their audio chip. So can't blame Win 10 memory integrity for this issue.

    What I did do was to reset my BIOS to its "optimized" settings which provide for a slight overclock. What is interesting is my PC especially in regards to program execution runs faster than with my previous custom memory overclock settings. Go figure.

    It does appear to me that the overclocking days per se are over in regards to Win 10 1803+. Memory integrity withstanding, MS has made multiple microcode updates to mitigate Spectre vulnerabilities. And those changes do modify CPU bus timings.

    Guess I will finally have to get around to installing this new Gigabyte motherboard that is Win 10 compatible that has been laying around in my closet for some time.
     
  7. itman

    itman Registered Member

    Joined:
    Jun 22, 2010
    Posts:
    7,514
    Location:
    U.S.A.
    BTW - there are no issues with Eset in regards to having memory integrity in Win 10 enabled.
     
  8. itman

    itman Registered Member

    Joined:
    Jun 22, 2010
    Posts:
    7,514
    Location:
    U.S.A.
    Well, that is not going to happen for motherboard OEMs whose products predate Win 10's release and are out of the warranty period.
     
  9. EASTER

    EASTER Registered Member

    Joined:
    Jul 28, 2007
    Posts:
    8,294
    Location:
    U.S.A. (South)
    Another worry that raises with my rather arcade hardware system as it currently stands, is I really do make good use of the temperature tint screen-or better known as nightlight-and whenever that system is on I just have that gnawing feeling the video card might not last.

    You can understand them wanting to sew up the Windows 10 system with all those new features-especially when traditionally they been their weakest in-security. And naturally as time goes on, newer machinery/hardware is going to be the only way to support all that safely.
     
  10. wat0114

    wat0114 Registered Member

    Joined:
    Aug 5, 2012
    Posts:
    2,440
    Location:
    Canada
    Personally I would not attempt to run Win 10 on hardware much older than 3-5 years. MS probably did the majority of or all their Win 10 development testing on much newer hardware. Just speculation of course, and maybe I'm wrong, but it wouldn't surprise me. In our household all three machines it's running on are < 2 years old and running Intel processors.
     
  11. Kerodo

    Kerodo Registered Member

    Joined:
    Oct 5, 2004
    Posts:
    7,948
    I have an old core 2 duo Asus laptop that's amost 9 years old running Win 10 off and on for over 3 years now and never had any substantial issues of any kind. I suppose it just depends on the specific hardware involved...
     
  12. wat0114

    wat0114 Registered Member

    Joined:
    Aug 5, 2012
    Posts:
    2,440
    Location:
    Canada
    Well that's almost shocking but all the same great to see someone here is running it successfully on older hardware. My comments were based simply on so many posts in these forum about members running into issues on older hardware. Maybe MS tested more thoroughly than I thought.

    Obviously other factors come into play such as 3rd-party programs, especially security, that might be causing issues as well.
     
  13. Azure Phoenix

    Azure Phoenix Registered Member

    Joined:
    Nov 22, 2014
    Posts:
    894
    I have read comments on this very forum of users saying they run W10 on old hardware, and it actually runs faster with Windows 10 on it.
     
  14. reldel

    reldel Registered Member

    Joined:
    Aug 14, 2007
    Posts:
    26
    Location:
    Felton, DE, USA
     
  15. reldel

    reldel Registered Member

    Joined:
    Aug 14, 2007
    Posts:
    26
    Location:
    Felton, DE, USA
    Can confirm you are correct about ESET having no problem with memory integrity. After finding issue with Emsisoft in that regard, I tried ESET and found no such installation or operational issue.
     
  16. Krusty

    Krusty Registered Member

    Joined:
    Feb 3, 2012
    Posts:
    6,744
    Location:
    Among the gum trees
    I can't enable Memory Integrity on this machine. I can slide the switch to On and I am prompted to restart but after restart Memory Integrity is still disabled.
     
  17. itman

    itman Registered Member

    Joined:
    Jun 22, 2010
    Posts:
    7,514
    Location:
    U.S.A.
    I decided to get to the bottom of if the Realtec site based audio driver was the "culprit" in regards to preventing normal return from sleep mode. Note that I am referring to S3 deep sleep mode. Using powercfg, verified that all elements of the Realtec audio driver were S3 sleep mode compatible. So its back to back to win 10 1803 memory integrity being the culprit.

    My best guess at this point is that memory integrity will not cause any conflicts with sleep activities only if fast startup is enabled. That option enables a "hybrid sleep" option in Win power management settings. The reason I have it disabled is it caused a blue screen on my Win 10 1803 build prior to enabling the memory integrity option. Reflecting on this, it may very well be that my prior memory overclocking could be related to that. So tomorrow, I will play around with enabling fast startup and see if that will allow my build to resume from sleep with memory integrity enabled.
     
  18. itman

    itman Registered Member

    Joined:
    Jun 22, 2010
    Posts:
    7,514
    Location:
    U.S.A.
    Your motherboard BIOS/UEFI has to support "virtualization":
    https://www.tenforums.com/tutorials...-isolation-memory-integrity-windows-10-a.html

    So search your BIOS/UEFI settings for a settings pertaining to virtualization and enable them. In my old Gigabyte motherboard BIOS, there was only one setting named virtualization which by default was disabled.
     
  19. Krusty

    Krusty Registered Member

    Joined:
    Feb 3, 2012
    Posts:
    6,744
    Location:
    Among the gum trees
    Thanks itman. I have checked and there is no mention of virtualisation in the BIOS of this machine. It's MBR not UEFI too if that matters.

    Interestingly, on my newer UEFI machine (which does support virtualisation) I'm not even given an option to enable Memory Integrity. Regedit shows Memory Integrity is disabled.
     
  20. itman

    itman Registered Member

    Joined:
    Jun 22, 2010
    Posts:
    7,514
    Location:
    U.S.A.
    BTW - you can verify that memory integrity is operation using "System Information" as shown in the below screen shot:

    Memory_Integrity.png
     
  21. Krusty

    Krusty Registered Member

    Joined:
    Feb 3, 2012
    Posts:
    6,744
    Location:
    Among the gum trees
    Ah ha!

    Thanks again @itman . :thumb:
     

    Attached Files:

  22. Azure Phoenix

    Azure Phoenix Registered Member

    Joined:
    Nov 22, 2014
    Posts:
    894
  23. Umbra

    Umbra Registered Member

    Joined:
    Feb 10, 2011
    Posts:
    5,694
    Location:
    Europe then Asia
    Last edited: Aug 20, 2018
  24. itman

    itman Registered Member

    Joined:
    Jun 22, 2010
    Posts:
    7,514
    Location:
    U.S.A.
    Also, your system must support the base level requirements listed below for core isolation and memory integrity to work. Note that core isolation should work on any system with BIOS/UEFI virtualization option enabled. Memory integrity however requires all existing drivers to be compatible or they will cease to function properly:
    https://docs.microsoft.com/en-us/windows-hardware/design/device-experiences/oem-vbs

    Note that the more advanced level of VBS protection is only available if your system meets the additional hardware requirements listed such as TPM 2.0, UEFI, etc..
     
  25. itman

    itman Registered Member

    Joined:
    Jun 22, 2010
    Posts:
    7,514
    Location:
    U.S.A.
    Well, I completed my testing on trying to get the PC to resume from S3 power mode; i.e. suspend to ram, without success.

    Interestingly, resume from standby in S1 power mode does work. However, that mode really doesn't provide any more power saving that you get with the current Win 10 "balanced" power settings; namely monitor shutdown after 10 mins. and hard drive shutdown after 20 mins.. Your PC is still powered up with all your case fans running in S1 standby mode.

    Others will have to report back if they are also experiencing resume from standby mode with Win 10 memory integrity enabled.
     
Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.