Wikipedia problem

Discussion in 'other software & services' started by lotuseclat79, Oct 15, 2012.

Thread Status:
Not open for further replies.
  1. lotuseclat79

    lotuseclat79 Registered Member

    Joined:
    Jun 16, 2005
    Posts:
    5,097
    When I use the default User-Agent string of blank in my Firefox browser, I get the message:

    Scripts should use an informative User-Agent string with contact information, or they may be IP-blocked without notice.

    This happens whether
    1) I try to access the address: https://en.wikipedia.org/wiki/Maqui_berry or
    2) by typing it into the FF browser address bar or
    3) try to search for it in the Wikipedia Search bar in the FF browser, or
    4) visit the Wikipedia website itself at: http://en.wikipedia.org/ and then search for macqui berry, or
    5) change the useragent from blank to Firefox/3.6.28

    What is an acceptable User-Agent string example to correct this problem? Anyone know?

    In effect, Wikipedia is now preventing a rather large user base from using their website for some reason, but they have not informed the user of what that reason is.

    -- Tom
     
  2. noone_particular

    noone_particular Registered Member

    Joined:
    Aug 8, 2008
    Posts:
    3,798
    I won't speculate on their reasons for requiring a user agent string. I ran a quick test to see what is acceptable to them. It appears that they'll accept most anything as a user agent string, regardless of whether it's valid or makes sense. I sent several spoofed strings to them, clearing the cache between runs. Some were valid. I also sent user agent strings like NotYourConcern and WinMacBSDNix. They were accepted. It seems that all they require is that a user agent string is present, regardless of what it says.

    There's several extensions that enable you to manipulate the user agent. A really nice one you might want to look at is PrefBar. Filtering proxies like Proxomitron can also change user agents.
    Screenshot of prefbar
    View attachment 234439
     
    Last edited: Oct 15, 2012
  3. lotuseclat79

    lotuseclat79 Registered Member

    Joined:
    Jun 16, 2005
    Posts:
    5,097
    I went into about:config and changed general.useragent and general.userAgent to Firefox/3.6.28 and was rejected.

    Which field in about:config did you change?

    -- Tom
     
  4. noone_particular

    noone_particular Registered Member

    Joined:
    Aug 8, 2008
    Posts:
    3,798
    Try adding:
    "general.useragent.override"
    followed by the string of your choice. Works on SeaMonkey. Can't test on FF.
     
  5. MikeBCda

    MikeBCda Registered Member

    Joined:
    Jan 5, 2004
    Posts:
    1,627
    Location:
    southern Ont. Canada
    I've only got one entry in my about:config (16.0.1) that relates to this, and that's general.useragent.compatMod.firefox, which is at the default setting of false. I've got no problems getting into Wikipedia, although admittedly I didn't (yet) try a search for the specific item you mentioned. I'll go back and give it a try now.

    (Follow-up) No problems hitting it via search in WP, although I copied-and-pasted the term from your (4) including its typo (shouldn't include the "c") on the first try and got the "did you mean ...?" message. Editing out the typo and trying again got me to the proper page just fine.

    Possibly it's your version of Firefox that's the problem?
     
    Last edited: Oct 15, 2012
  6. lotuseclat79

    lotuseclat79 Registered Member

    Joined:
    Jun 16, 2005
    Posts:
    5,097
    Apparently, when I set the value of general.useragent.override to any string - it resets to a null string after a few seconds and does not stay put.

    Anyone have a clue about this problem re: Firefox 3.6.28?

    -- Tom
     
  7. lotuseclat79

    lotuseclat79 Registered Member

    Joined:
    Jun 16, 2005
    Posts:
    5,097
    I finally fixed the problem by manually editing the prefs.js file (in the FF profile directory) to set the useragent strings.

    -- Tom
     
  8. chrisretusn

    chrisretusn Registered Member

    Joined:
    Jun 16, 2004
    Posts:
    1,322
    Location:
    Philippines
    Just for reference, a nice Firefox extension I use to control my user agent string is UAControl. It lets you control what user agent string to use on a per site basis. You could keep it blank for all but Wikipedia if that is what you wanted.

    UAControl :: Add-ons for Firefox - https://addons.mozilla.org/en-us/firefox/addon/uacontrol/

    I use this extension as a supplement to UAControl for JavaScript.

    User-Agent JS Fixer :: Add-ons for Firefox - https://addons.mozilla.org/en-us/firefox/addon/user-agent-js-fixer/
     
  9. lotuseclat79

    lotuseclat79 Registered Member

    Joined:
    Jun 16, 2005
    Posts:
    5,097
    Update: Unfortunately, my fix in post #7 didn't stay fixed. There are two problems:

    1) I am still using Firefox 3.6.28 (due to add-ons I like and prefer which haven't been upgraded)

    2) Conflicting add-ons which need to be identified (I have 44 add-ons, 2 of which are the likely culprits needing further attention).

    What happens is that every time I launch FF, the prefs.js file in which I edited the fixes get overridden by some default settings from somewhere that I have yet to sort out where they originate - and possibly prevent that from interacting in the adverse way it appears to behaving.

    With regard to UAControl and User-Agent JS Fixer - they are not compatible with FF 3.6.28.

    -- Tom
     
  10. lotuseclat79

    lotuseclat79 Registered Member

    Joined:
    Jun 16, 2005
    Posts:
    5,097
    I finally found the simplest solution. I merely need to deactivate the add-on RefControl when I use Wikipedia with a single click which puts a red X over the Refcontrol icon in the top right-hand corner of my FF browser.

    -- Tom
     
  11. lotuseclat79

    lotuseclat79 Registered Member

    Joined:
    Jun 16, 2005
    Posts:
    5,097
    Uh, oh - this is not over yet. The above solution seems to only work after I use a search engine, e.g. duckduckgo and then visit the Wikipedia link from there.

    Whenever I use about:config to Modify the useragent/userAgent string from blank to any string, after about 15 seconds the string disappears before my eyes.

    Obviously, there is something going on in the background that wipes it out.

    I even changed the default RefControl custom string from blank to otherwise and that also gets the "Sciprts..." message per 2nd line of post#1.

    Anyone understand what is going on here?
     
Loading...
Thread Status:
Not open for further replies.