What do I have to set to make an application "pingable"?

Discussion in 'ESET Smart Security' started by bolero, Jun 9, 2011.

Thread Status:
Not open for further replies.
  1. bolero

    bolero Registered Member

    Joined:
    Jan 19, 2011
    Posts:
    7
    Using Smart Security 4 I'm not able to allow an application to ping or traceroute. I can do that from within cmd.exe, but can't with the program I usually use for that: WSPing Pro Pack (old application from IPSwitch).
    Smarty security is in Learning mode (set by Remote Admin Server), but in this case it doesn't create any rules. Same, if I set to interactive mode, the connect is just ignored and all actions time out (I don't know if the outgoing or incoming packets get blocked). I've tried to setup rules manually, but these don't work either. I first set up one rule for ICMP, allowing just "everything", then for TCP & UDP, again allowing just everything. No go.
    I *have* two rules created in learning mode for it, but these are for DNS (one for UDP, one for TCP).
    How can I enable this application to use ping and traceroute?
    (Yes, if I disable network traffic filtering in Smart Security it all works, so it's definitely that what's blocking this functionality.)
     
  2. tony_m

    tony_m Eset Staff Account

    Joined:
    Nov 22, 2010
    Posts:
    239
    Hi,

    I replicated the issue here, you can use the following as a workaround:

    In ESET Smart Security, go into Setup> Personal Firewall> Advanced Personal Firewall Setup> IDS and advanced options> ICMP protocol attack detection: disable
    This will not make your machine vulnerable to viruses, it only means that someone can crash your computer remotely using an ICMP-based Denial-Of-Service attack (which is a very unlikely event).
     
  3. bolero

    bolero Registered Member

    Joined:
    Jan 19, 2011
    Posts:
    7
    Thanks! I don't have a "ICMP protocol attack detection" option. I found an option "Packet Inspection: ICMP protocol message checking" and disabled it. Then it works. Is my version of ESET SS 4 outdated or did you quote an older option name?

    The problem now is, though, that I use RAC and the server (correctly) overwrites the value I changed in the client. I've checked the policy editor up and down but I can't see any option that would resemble this one (or any of the options in the IDS and advanced options node). So, how do I change the policy, so that doesn't get set again?
     
  4. tony_m

    tony_m Eset Staff Account

    Joined:
    Nov 22, 2010
    Posts:
    239
    From your Policy manager, select the appropriate policy and click Edit.

    In the ESET Configuration Editor, go to ESET Smart Security, ESET NOD32 Antivirus > Personal firewall > Setup > Rule setup. Click Edit on the right hand side, go to the Advanced tab. If it is empty, click the "Default" button and all the advanced settings will appear, including that one for ICMP protocol attack detection.

    Hope this helps.
     
  5. bolero

    bolero Registered Member

    Joined:
    Jan 19, 2011
    Posts:
    7
    Thanks, I wasn't aware that the "see dialog" information refers to this. I was already missing other options and wondering why I couldn't set these. Now I know how to do. This worked fine. Interestingly, the name of that option in the policy manager is like you quoted it and not like it is in the client.
     
Thread Status:
Not open for further replies.