Webroot Filtering = Insecure Connection

Discussion in 'Prevx Releases' started by blinking_spirit, Nov 23, 2013.

Thread Status:
Not open for further replies.
  1. blinking_spirit

    blinking_spirit Registered Member

    Joined:
    Feb 21, 2013
    Posts:
    48
    Hi

    I started noticing that many of my HTTPS pages were started to show the ubiquitous warning in Chrome:
    http://i.imgur.com/W3Dg5YW.png

    On closer inspection on why this error kick in I check Chrome's tool and got this:
    The page at 'https://www' was loaded over HTTPS, but displayed insecure content from 'http://localhost:27019/': this content should also be loaded over HTTPS.

    After doing some checking around it seems that the Webroot Filtering Extension (1.0.0.14) is causing the problem because as soon as I disable it things are fine.

    Is there any reason to be concerned?
     
  2. Techfox1976

    Techfox1976 Registered Member

    Joined:
    Jul 22, 2010
    Posts:
    749
    Oh? Eeenteresting... *Goes to fire up Wireshark*
     
  3. PrevxHelp

    PrevxHelp Former Prevx Moderator

    Joined:
    Sep 14, 2008
    Posts:
    8,242
    Location:
    USA/UK
    This is just the local agent communicating with itself - Chrome and other browsers block outside communications from the browser to other applications, so we need to send messages back and forth to validate the pages as they're being visited. This doesn't compromise your security or cause outside websites/snoopers to be able to view content. I'm a bit surprised that Chrome is warning about it as we aren't showing content on the page (unless you're only seeing it on search results?) but I'll take a closer look to see what they're flagging.
     
  4. pegas

    pegas Registered Member

    Joined:
    May 22, 2008
    Posts:
    2,016
    It is known issue that was observed across all Chromium based browsers and is still pending a fix.
     
Thread Status:
Not open for further replies.