VMware virtual machine traffic blocked

Discussion in 'ESET Smart Security' started by iii1682000, May 12, 2008.

Thread Status:
Not open for further replies.
  1. iii1682000

    iii1682000 Registered Member

    Joined:
    May 12, 2008
    Posts:
    5
    Hi,

    I am using eset smart security suite 3.0.566 on both my host machine with VMware installed and the virtual machine. I have emule installed in the virtual mahcine with all the port forwarding correctly set in the router.

    When I do a TCP port connection test in emule, it fails. If I turn off the eset personal firewall in the host machine, the tcp port test in the virtual machine passes without any problem.

    It is obvious that the port forwarding from the router to the virtual machine is blocked by the eset personal firewall on the host machine. The problem is that I can't figure it out how to set a rule to let the eset firewall pass that traffic. I am using "interactive mode" on all my machines. but I never get a popup in the host machine to let me enable any traffic.

    I also gave full rights on the VMware application on the host machine and it didn't help.

    Can anybody give a help fix this issue for me.

    Thank you very much!
     
  2. iii1682000

    iii1682000 Registered Member

    Joined:
    May 12, 2008
    Posts:
    5
    Still no reply?

    I believe this issue is not un-common, not sure why there is no any answer on it.

    ESET is great, but it blocks some traffics to the virtual server mounted via VMWare. I am sure there must be a way to fix it. Who should I call?

    Thanks!
     
  3. COSMO26

    COSMO26 Registered Member

    Joined:
    Oct 21, 2003
    Posts:
    404
    https://www.wilderssecurity.com/showthread.php?t=192851

    (excerpt from post): its within the vmware prefernces, should be 3 options for networking mode. i find the simplest easiest way is to set each virtual machine to "NAT mode" -- its possible you have it left on its default settings of "bridged mode" (You say you gave full rights to Host machine but this sounds a little different - thought I'd show it)

    Great helpers in this Forum but until they show up you can in the future do what i just did: blue border up top: Search: Advanced Search: Key words: emule: show at least 1 response post: Search.

    That's how above was found. Good luck.
     
    Last edited by a moderator: May 15, 2008
  4. Marcos

    Marcos Eset Staff Account

    Joined:
    Nov 22, 2002
    Posts:
    14,374
    1, first of all, install the latest version of ESS
    2, make sure the "Allow inbound communication from virtual network adapters" rule is enabled as shown below
     

    Attached Files:

    • va.jpg
      va.jpg
      File size:
      3.5 KB
      Views:
      4,535
  5. iii1682000

    iii1682000 Registered Member

    Joined:
    May 12, 2008
    Posts:
    5
    I can't get the NAT mode work, even after reboot the host box, restart the VMWare services, and did a ipconfig/release and /renew. The problem is "Can't find the DHCP server". By the way, I only put one NIC card in the host box, will 2 NIC cards help?
     
  6. iii1682000

    iii1682000 Registered Member

    Joined:
    May 12, 2008
    Posts:
    5
    That rule is already enabled.

    Thanks for your help though.

    Any other recommendations?
     
  7. iii1682000

    iii1682000 Registered Member

    Joined:
    May 12, 2008
    Posts:
    5
    Hi, I reinstalled the lastest version of vmware workstation, and got the NAT mode working. More question. How do I use Terminal service (RDP) to connect to my virtual machine remotely

    My host IP is 172.16.0.x
    Now the NAT IP on the virtual box is 192.168.254.2

    Also in the bridged mode, there was a port forwarding set to forwarded to my virtual server, how should I set the forwarding under the NAT mode?

    Thanks.
     
    Last edited: May 19, 2008
Thread Status:
Not open for further replies.