Vista Ultimate x86 sp1 & Smart Security 3.0.642.0

Discussion in 'ESET Smart Security' started by erico, Mar 22, 2008.

Thread Status:
Not open for further replies.
  1. erico

    erico Registered Member

    Joined:
    Feb 21, 2008
    Posts:
    5
    Every time my Vista install starts up, Egui.exe is a blocked program which must be allowed to run with admin permision.

    There seem to be some unresolved issues with Vista compatibility.

    I disabled UAC to see if it would matter, but the problem became worse. I had to restore my system to a point before I made the change.

    Is there a workaround for this that anyone is aware of and is willing to share?
     
  2. ShaneR34

    ShaneR34 Registered Member

    Joined:
    Mar 9, 2008
    Posts:
    107
    Well, as I understand it, if you want full control over ESS within a normal (reduced privledges) account, you need to set egui.exe to run as an administrator (actually, this happens for an admin account as well). I'm fairly sure that Vista blocking it on start up is the way Vista is meant to work--so, I don't think it's a compatibility problem. Someone can correct me if I'm wrong.

    Not an annoyance to me at all (it just takes a second to unblock it with the admin password), but I can certainly see how it can be an annoyance for some. If there is a safe work around, I'd surely use it ;)
     
  3. shansmi

    shansmi Registered Member

    Joined:
    Feb 19, 2008
    Posts:
    130
    So are you running on Vista with a non-admin account for daily use?

    I am running Vista SP1 on 2 PC's with no issues but there is only one account on each machine and it is not "Administrator" but it does have Adminsitrator permissions.

    I get no erros on startup or when I launch the ESS MMI from either machine.


    I have seen other posts where you have to set the app permissions by right-clicking on the app then checking "run as admin" box. You should be prompted for the admin password if you are not an admin user. This should correct the issue.

    Hope this helps...
     
  4. ShaneR34

    ShaneR34 Registered Member

    Joined:
    Mar 9, 2008
    Posts:
    107
    This is what caused the poster's issue for me. And it was the only way I could work with ESS in my LUA account.

    I'm just a newbie...but, adding my input none-the-less :)
     
  5. ASpace

    ASpace Guest

    Are you sure it isn't Windows Defender which thinks ESET as not recongnised program ?

    I would suggest you disable Windows Defender's real-time protections , then disable its Service . Enable User Account Control and reinstall the program.

    1. Download fresh new version of the desired ESET product
    http://www.eset.com/download
    Make sure that you choose the correct version.

    2. Uninstall your current version from Control Panel
    3. Reboot the computer when prompted
    4. Delete manually these folders:

    - C:\Program files\ESET
    - C:\Program Data\Eset
    - C:\Users\~username~\Local Settings\AppData\Local\Eset

    5. Reinstall your ESET software using the file you downloaded in step1 . Use typical install.
     
  6. erico

    erico Registered Member

    Joined:
    Feb 21, 2008
    Posts:
    5
    Hi,
    Well... the curious thing is that I do have Windows Defender disabled when the blocked programs dialog pops up. I disabled Defender before I installed ESS. I will check to insure that the service is also disabled. I do have it running with admin privileges.

    If Vista continues to whine, I will take you suggestion and execute a fresh install after a complete removal of ESS. This issue (about more apps than ESS and egui.exe) is probably listed on an Windows annoyances site somewhere.

    Thanks for your prompt response.
    :)
     
    Last edited: Mar 23, 2008
  7. ASpace

    ASpace Guest

    Make sure you have UAC enabled during installation of ESS .




    Very strange but as a general rule you can make sure the application is always running as Administrator should this continue (even though I think it is not necessary)

    Right click it (when you find it in C:\Program files\ESET\ESET Smart Security)
    -> Properties and

    egui_admin_always.png


    If you still have problems , please make a screenshot so that we can see what is the message exactly :thumb:
     
Thread Status:
Not open for further replies.