Vista and Windows 7 RTM issues with backup and restore feature - BSOD

Discussion in 'other software & services' started by smipx013, Aug 31, 2009.

Thread Status:
Not open for further replies.
  1. smipx013

    smipx013 Registered Member

    Joined:
    Jan 4, 2006
    Posts:
    18
    Hi Everyone,

    I am new to this forum so hi to all - I use the NOD32 AV forums more and have NOD32 installed (V4) so I thought this would be a good place to ask the question below.

    I have a problem with my PC giving a bugcheck and wondered if someone can point me in the right direction before I shell out some cash on a new MOBO and HDD.

    I’m running Windows 7 Ultimate RTM and I occasionally get a system freeze and sometimes a BSOD. I can pretty much reproduce the issue by running a backup using the built-in Backup and restore. I back up my C drive (circa 80 out of 250Gb used) to a 400Gb USB hard drive.

    The C Drive is a Seagate SATA drive and the USB drive is a regular Maxtor IDE
    I have installed a second USB controller in to the PCI slot to eliminate that as a cause but no joy. The w7 was an upgrade from Vista Ultimate but I have now completely wiped and then reinstalled W7 from fresh and the problem persists. The problem also occurred on the Vista build.

    I have run the SEATOOLS on a full test and it tells me nothing was wrong with the source disk and I ran the Maxtor equivalent on the USB drive (removed it from the enclosure and installed it into the PC. I also ran Spinrite on a level 4 on the SATA disk (source) for 24 hours but got bored as it only completed 20%. This showed no errors up the point where I cancelled it.

    I have loaded Windbg and run a check of the memory.dmp and it comes up with the information below. It does suggest the drive is bad but I am not so sure and think it could be the mainboard drivers or the mainboard or SATA cable or even the RAM (it has two x 1Gb matched) . The mainboard is quite old and there are no more BIOS or driver updates for it (MAXDATA MS-7253 5123660003) which is a cronky old mobo that came with a MaxData PC but has been flashed to the most recent maxdata had before they went bust.

    I run NOD32 v4 A/V and I have purposely not installed this on the new build to eliminate that as a cause (filter driver conflict or some such). The problem is there without NOD so I have now installed it again (phew - I love NOD32).


    Microsoft (R) Windows Debugger Version 6.11.0001.404 X86
    Copyright (c) Microsoft Corporation. All rights reserved.


    Loading Dump File [C:\temp\dumps\30aug\MEMORY.DMP]
    Kernel Summary Dump File: Only kernel address space is available

    Symbol search path is: SRV*c:\symbols cache*http://msdl.microsoft.com/download/symbols
    Executable search path is:
    Windows 7 Kernel Version 7600 MP (2 procs) Free x86 compatible
    Product: WinNt, suite: TerminalServer SingleUserTS
    Built by: 7600.16385.x86fre.win7_rtm.090713-1255
    Machine Name:
    Kernel base = 0x8283d000 PsLoadedModuleList = 0x82985810
    Debug session time: Sun Aug 30 23:06:27.070 2009 (GMT+1)
    System Uptime: 0 days 3:28:14.023
    Loading Kernel Symbols
    ...............................................................
    ................................................................
    .............
    Loading User Symbols

    Loading unloaded module list
    .......
    1: kd> !analyze -v
    *******************************************************************************
    * *
    * Bugcheck Analysis *
    * *
    *******************************************************************************

    KERNEL_DATA_INPAGE_ERROR (7a)
    The requested page of kernel data could not be read in. Typically caused by
    a bad block in the paging file or disk controller error. Also see
    KERNEL_STACK_INPAGE_ERROR.
    If the error status is 0xC000000E, 0xC000009C, 0xC000009D or 0xC0000185,
    it means the disk subsystem has experienced a failure.
    If the error status is 0xC000009A, then it means the request failed because
    a filesystem failed to make forward progress.
    Arguments:
    Arg1: c04157d8, lock type that was held (value 1,2,3, or PTE address)
    Arg2: c000000e, error status (normally i/o status code)
    Arg3: 0399d860, current process (virtual address for lock type 3, or PTE)
    Arg4: 82afbe2b, virtual address that could not be in-paged (or PTE contents if arg1 is a PTE address)

    Debugging Details:
    ------------------


    ERROR_CODE: (NTSTATUS) 0xc000000e - A device which does not exist was specified.

    DISK_HARDWARE_ERROR: There was error with disk hardware

    BUGCHECK_STR: 0x7a_c000000e

    DEFAULT_BUCKET_ID: VISTA_DRIVER_FAULT

    PROCESS_NAME: System

    CURRENT_IRQL: 0

    TRAP_FRAME: 8a927a14 -- (.trap 0xffffffff8a927a14)
    ErrCode = 00000010
    eax=8559a901 ebx=00010000 ecx=2c000128 edx=00010000 esi=8559a888 edi=8557da80
    eip=82afbe2b esp=8a927a88 ebp=8a927ab0 iopl=0 nv up ei pl nz na pe nc
    cs=0008 ss=0010 ds=0023 es=0023 fs=0030 gs=0000 efl=00010206
    nt!PnpRequestDeviceRemoval:
    82afbe2b f8 clc
    Resetting default scope

    LOCK_ADDRESS: 829a2f60 -- (!locks 829a2f60)

    Resource @ nt!PiEngineLock (0x829a2f60) Exclusively owned
    Contention Count = 12
    Threads: 848bb020-01<*>
    1 total locks, 1 locks currently held

    PNP_TRIAGE:
    Lock address : 0x829a2f60
    Thread Count : 1
    Thread address: 0x848bb020
    Thread wait : 0xc3381

    LAST_CONTROL_TRANSFER: from 828f160a to 82919d10

    STACK_TEXT:
    8a92786c 828f160a 0000007a c04157d8 c000000e nt!KeBugCheckEx+0x1e
    8a9278e0 828e90d5 84b1b3b4 8a927938 82971540 nt!MiWaitForInPageComplete+0x2fd
    8a927974 828c4e3f 82971540 82afbe2b 84b1b320 nt!MiIssueHardFault+0x3b2
    8a9279fc 828835f8 00000008 82afbe2b 00000000 nt!MmAccessFault+0x2656
    8a9279fc 82afbe2b 00000008 82afbe2b 00000000 nt!KiTrap0E+0xdc
    8a927ab0 829e4a73 84960ac8 8557da80 00000002 nt!PnpRequestDeviceRemoval
    8a927ca4 829de61a 8557da80 84960ac8 8a927cd0 nt!PipProcessDevNodeTree+0x352
    8a927cd8 82850f7c 829a0e80 848bb020 829775bc nt!PiProcessReenumeration+0x74
    8a927d00 828aaf2b 00000000 00000000 848bb020 nt!PnpDeviceActionWorker+0x224
    8a927d50 82a4b66d 00000001 95405044 00000000 nt!ExpWorkerThread+0x10d
    8a927d90 828fd0d9 828aae1e 00000001 00000000 nt!PspSystemThreadStartup+0x9e
    00000000 00000000 00000000 00000000 00000000 nt!KiThreadStartup+0x19


    STACK_COMMAND: kb

    FOLLOWUP_IP:
    nt!MiWaitForInPageComplete+2fd
    828f160a cc int 3

    SYMBOL_STACK_INDEX: 1

    SYMBOL_NAME: nt!MiWaitForInPageComplete+2fd

    FOLLOWUP_NAME: MachineOwner

    MODULE_NAME: nt

    DEBUG_FLR_IMAGE_TIMESTAMP: 4a5bc007

    IMAGE_NAME: memory_corruption

    FAILURE_BUCKET_ID: 0x7a_c000000e_nt!MiWaitForInPageComplete+2fd

    BUCKET_ID: 0x7a_c000000e_nt!MiWaitForInPageComplete+2fd

    Followup: MachineOwner
    ---------



    Can anyone offer any advice?

    Many thanks
    Paul
     
Loading...
Thread Status:
Not open for further replies.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.