VirtualBox issue: guest mouse cursor range limited without Guest Additions installed

Discussion in 'sandboxing & virtualization' started by MrBrian, Aug 30, 2014.

  1. MrBrian

    MrBrian Registered Member

    Joined:
    Feb 24, 2008
    Posts:
    6,032
    Location:
    USA
    Workaround: Change virtual machine setting Pointing Device from "PS/2 Mouse" (the old default) to "USB Tablet" (the new default).

    Source: https://www.virtualbox.org/ticket/13108.

    From https://www.virtualbox.org/manual/ch03.html:
     
    Last edited: Aug 31, 2014
  2. Minimalist

    Minimalist Registered Member

    Joined:
    Jan 6, 2014
    Posts:
    5,060
    Nice trick. Might try it, when I set up new machine.
     
  3. J_L

    J_L Registered Member

    Joined:
    Nov 6, 2009
    Posts:
    8,516
    Known that for a while, and enabled it for all my virtual machines without Guest Additions available.
     
  4. MrBrian

    MrBrian Registered Member

    Joined:
    Feb 24, 2008
    Posts:
    6,032
    Location:
    USA
    "USB Tablet" has apparently been the default pointing device for a new virtual machine in recent versions of VirtualBox. "PS/2 Mouse" was the default for new virtual machines in older versions of VirtualBox. I changed it to "USB Tablet" in most of my existing virtual machines. Even if a given virtual machine has Guest Additions installed, "USB Tablet" is useful if you're using a boot cd/dvd/usb in the virtual machine.
     
Loading...