Virtual drive and USB

Discussion in 'ESET NOD32 Antivirus/Smart Security Beta' started by Mike1959, Jun 17, 2011.

Thread Status:
Not open for further replies.
  1. Mike1959

    Mike1959 Registered Member

    Joined:
    Aug 26, 2007
    Posts:
    7
    Since installing the latest build of v.50 I've been unable to unmount any of my virtual drives or to eject any of my USB's without a system warning telling me that the drive is still in use....can anyone offer a solution for this please.

    many thanks.

    Mike.

    just tested the previous build and all works fine...it's this latest build (5.0.84.0) x64 that seems to be having the issues.
     
    Last edited: Jun 18, 2011
  2. Phil_S

    Phil_S Registered Member

    Joined:
    Nov 13, 2003
    Posts:
    152
    Location:
    UK
    I can't offer a solution, but I am having exactly the same problem.

    It's not HIPS related, because I have had to disable HIPS to circumvent a problem with one of my programs not being able to access any drives:

    https://www.wilderssecurity.com/showthread.php?t=301449

    Now running with HIPS disabled, but the USB problem still persists. Again, this wasn't an issue experienced with the previous beta.
     
  3. Marcos

    Marcos Eset Staff Account

    Joined:
    Nov 22, 2002
    Posts:
    14,375
    We'd need to figure out the pattern of these cases. Did you scan the USB medium once it was detected and a scan was offered?
     
  4. Mike1959

    Mike1959 Registered Member

    Joined:
    Aug 26, 2007
    Posts:
    7
    in most cases I never opted to scan at the point the medium was introduced to my pc although after mounting the iso file to a virtual drive and then trying to unmount minutes later it refused to do so...only a reboot of my system would release the virtual drive.
     
  5. Phil_S

    Phil_S Registered Member

    Joined:
    Nov 13, 2003
    Posts:
    152
    Location:
    UK
    Marcos, tried again today after reading your post, and on every occasion I was able to remove the USB drive. At the time, HIPS was disabled.

    I enabled HIPS and rebooted to try and log any message relating to my other problem with Quicken. From that point on the USB drives failed to release every time. I tried it after allowing Nod to scan the drive, selecting the option to scan later, or just closing the notification without selecting an action. I also tried all of these both together with reading and/or writing to the removable drive, and not preforming any action on it other than simply mounting it, but was unable to subsequently release the drive on every occasion.

    Having disabled HIPS and rebooted again, I am still unable to release any USB drive that I mount. There were no enties generated in the HIPS log with HIPS and logging of blocked actions enabled.
     
  6. toxinon12345

    toxinon12345 Registered Member

    Joined:
    Sep 8, 2010
    Posts:
    1,200
    Location:
    Managua, Nicaragua
    hello, i frequently have the AMON service deactivated, and this problem doesnt occurs, but removable media insertion/blocking is not functional, as i reported before
     
  7. Mike1959

    Mike1959 Registered Member

    Joined:
    Aug 26, 2007
    Posts:
    7
    I concur with Phil's testing results...no matter what option I choose I can't get it to release my usb drives or a mounted image on a virtual drive.
     
  8. Marcos

    Marcos Eset Staff Account

    Joined:
    Nov 22, 2002
    Posts:
    14,375
    I've inquired the devs about this issue and they confirmed it'd been fixed in the mean time and the fix will be included in the next program build.
     
  9. Mike1959

    Mike1959 Registered Member

    Joined:
    Aug 26, 2007
    Posts:
    7
    thanks Marcos for the feedback..:)
     
Thread Status:
Not open for further replies.