uTorrent Rules

Discussion in 'LnS English Forum' started by whitedragon551, Mar 25, 2010.

Thread Status:
Not open for further replies.
  1. whitedragon551

    whitedragon551 Registered Member

    Joined:
    Sep 30, 2008
    Posts:
    3,189
    Location:
    USA
    I have uTorrent allowed through the application filtering part of the firewall, but the port is still not being forwarded. I have it also set to be allowed to connect. It works fine with LnS off so I know its not the router.
     
  2. whitedragon551

    whitedragon551 Registered Member

    Joined:
    Sep 30, 2008
    Posts:
    3,189
    Location:
    USA
    I figured it out. I added a rule to internet filtering to allow uTorrent inbound and outbound connections on any port. The configuration is attached below. Can I get some insight on if I did it right?
     

    Attached Files:

    • lns.jpg
      lns.jpg
      File size:
      159.6 KB
      Views:
      609
  3. Creer

    Creer Registered Member

    Joined:
    Jun 29, 2008
    Posts:
    1,345
    Hi,

    first of all go to uTorrent Settings >> Connections, and copy&paste port from box: "Port used for incoming connections"
     
  4. whitedragon551

    whitedragon551 Registered Member

    Joined:
    Sep 30, 2008
    Posts:
    3,189
    Location:
    USA
    Which box would it go in in the my screenshot?
     
  5. Creer

    Creer Registered Member

    Joined:
    Jun 29, 2008
    Posts:
    1,345
    OK, for example - in uTorrent "Port used for incoming connections" you have set up port 33123.
    You need two rules. So your rules in LnS should look like these:
    - for TCP connections:
    lns_tcp_utorrent.jpg

    - for UDP connections:
    lns_udp_utorrent.png


    Also because this port (33123) is related only for uTorrent you can define the application which will be trigger for these rules. To do this you have to click "Applications..." button in both rules (TCP and UDP) and choose from list uTorrent:
    lns_udp_utorrent_app.png
     
    Last edited: Mar 25, 2010
  6. whitedragon551

    whitedragon551 Registered Member

    Joined:
    Sep 30, 2008
    Posts:
    3,189
    Location:
    USA
    Alright Ill take a look when I get home and have my external with me.

    I have another question about activation. I have put my email and activation code in and hit activate. The homepage says some options will open up. What options open up? When I hit activate the email disappears and the code stays there. When I reboot, both are gone. Is this normal?
     
  7. Creer

    Creer Registered Member

    Joined:
    Jun 29, 2008
    Posts:
    1,345
    It's not normal - it happened to me once (email desappears) when I entered wrong code (one digit I entered wrong accidentally).
    About options open up, I'm not sure here so It will be better if Frederic clarify it for you.
     
  8. whitedragon551

    whitedragon551 Registered Member

    Joined:
    Sep 30, 2008
    Posts:
    3,189
    Location:
    USA
    Before you put the activation code in it says:

    That leads me to believe some settings arent available in the trial.

    Im home now with my external HD. I followed the exact layout you have in your images and I get a red connection in the bottom of uTorrent.
     
    Last edited: Mar 25, 2010
  9. Creer

    Creer Registered Member

    Joined:
    Jun 29, 2008
    Posts:
    1,345
    Did you click after created rules Save button then Apply button? Can you paste/screenshot here logs from LnS?
    Did you restart uTorrent?
     
  10. whitedragon551

    whitedragon551 Registered Member

    Joined:
    Sep 30, 2008
    Posts:
    3,189
    Location:
    USA
    Yup I did all that and I have logs disabled I believe.

    I can post the screenshots. The ports are in there and they came straight out of uTorrent.
     

    Attached Files:

    • TCP.jpg
      TCP.jpg
      File size:
      67.9 KB
      Views:
      564
    • UDP.jpg
      UDP.jpg
      File size:
      69.1 KB
      Views:
      578
  11. Creer

    Creer Registered Member

    Joined:
    Jun 29, 2008
    Posts:
    1,345
    Strange, OK then can you do just screenshot of your Log tab in LnS (there should be logs no matter if you have logs enabled - save to txt file - or disabled) during using of uTorrent?
     
  12. whitedragon551

    whitedragon551 Registered Member

    Joined:
    Sep 30, 2008
    Posts:
    3,189
    Location:
    USA
    These are only uTorrent connections. I cleared the log and started a download with uTorrent and this is what I have. I know what opendns is. I have it configured in my wireless router at home.
     

    Attached Files:

  13. Creer

    Creer Registered Member

    Joined:
    Jun 29, 2008
    Posts:
    1,345
    Your log looks OK since ICMP entries are normal when you're using torrent software, have a look here:
    https://www.wilderssecurity.com/showpost.php?p=1091799&postcount=2
    I don't see from your logs any reason why uTorrent doesn't work for you, but I'm new in LnS and I'm still learning how it works, so maybe wait for response from more experienced person.
     
  14. wrathchild

    wrathchild Registered Member

    Joined:
    Feb 7, 2008
    Posts:
    170
    Location:
    Neoplantesis
    In Internet Filtering, there is a rule 'Block incoming connections'.
    Your TCP rule for uTorrent (and port 33123 as example) must be placed before that rule. Because rules in L'n'S are applied from top to bottom.
    Also you need to add a port forwarding entry into your router for port used for incoming connections in uTorrent (33123 as example).
     
    Last edited: Mar 26, 2010
  15. Frederic

    Frederic LnS Developer

    Joined:
    Jan 9, 2003
    Posts:
    4,354
    Location:
    France
    No, during the trial period all features are available.
    Actually this message applies after the trial period, where some features are disabled (Application Filtering, and Advanced Options).

    Frederic
     
  16. whitedragon551

    whitedragon551 Registered Member

    Joined:
    Sep 30, 2008
    Posts:
    3,189
    Location:
    USA
    Ok thanks. I got this from a guy who won it here and he didnt want it and I was hoping to try it out. I have to wait on him for his email address so I can register it.

    I dont see a block incoming connections rule in the internet filtering tab.

    Are you talking about the rules for TCP: Any other packet and UDP: Any other packet? Both of the rules for uTorrent were at the very top.

    Port Forwarding isnt an issue. I have my router port forwarding disabled. Its just a straight SPI firewall with allowed programs that either A) get all network access or B) get no access at all.
     
    Last edited: Mar 26, 2010
  17. wrathchild

    wrathchild Registered Member

    Joined:
    Feb 7, 2008
    Posts:
    170
    Location:
    Neoplantesis
    Well, I don't know did you change default rules, but there should be rule 'TCP: Block incoming connections' (at least in EnhancedRulesSet.rls).

    Right now I don't have L'n'S installed, but from my memory, with Enhanced rules and TCP rule for uTorrent (as described before by Creer) placed before 'TCP: Block incoming connections' and UDP rule for uTorrent placed before 'UDP: Any other packet' I had port forwarded properly.
     
  18. whitedragon551

    whitedragon551 Registered Member

    Joined:
    Sep 30, 2008
    Posts:
    3,189
    Location:
    USA
    Heres the layouts of both rule sets. Im using the basic rule set. You can see the added rules for uTorrent.
     

    Attached Files:

  19. whitedragon551

    whitedragon551 Registered Member

    Joined:
    Sep 30, 2008
    Posts:
    3,189
    Location:
    USA
    Ok I see it in the enhanced rule set. How do I make sure the standard rule set is default again? Just to make sure I didnt delete something I should have.

    EDIT- After checking through what was said this is what I have so far.
     

    Attached Files:

  20. wrathchild

    wrathchild Registered Member

    Joined:
    Feb 7, 2008
    Posts:
    170
    Location:
    Neoplantesis
    Did you take the screenshots with uTorrent started? Because rules for uTorrent aren't active.
    I assume port is still not being forwarded properly?
     
  21. whitedragon551

    whitedragon551 Registered Member

    Joined:
    Sep 30, 2008
    Posts:
    3,189
    Location:
    USA
    No they werent taken with uTorrent active, but they still arent being forwarded properly.

    As soon as I take the port number out and only have 1 rule it works. If I add the port to that rule and allow traffic both ways it doesnt work. Heres how its currently setup:

    https://www.wilderssecurity.com/showpost.php?p=1646333&postcount=2
     
    Last edited: Mar 27, 2010
  22. whitedragon551

    whitedragon551 Registered Member

    Joined:
    Sep 30, 2008
    Posts:
    3,189
    Location:
    USA
  23. Phant0m

    Phant0m Registered Member

    Joined:
    Jun 7, 2003
    Posts:
    3,684
    Location:
    Canada
    What port is uTorrent application configured to use?

     
  24. whitedragon551

    whitedragon551 Registered Member

    Joined:
    Sep 30, 2008
    Posts:
    3,189
    Location:
    USA
    Heres the setup. I uninstalled LnS and reinstalled it. Im on the wall between LnS and Windows FW in Win7.

    I attached the screen capture. If I change ethernet type to IP it doesnt work.
     

    Attached Files:

  25. Phant0m

    Phant0m Registered Member

    Joined:
    Jun 7, 2003
    Posts:
    3,684
    Location:
    Canada
    You certainly don’t want to be using such a rule with ‘Ethernet : type’ set to ‘All’, either specify IP or IPv4.

    And change 'IP - Protocol' to ‘TCP or UDP

    If you have an seperate uTorrent rule to authorize UDP packets, .. remove it, let just the one do both. :)
     
Thread Status:
Not open for further replies.