uTorrent Rules Revisited

Discussion in 'LnS English Forum' started by whitedragon551, Nov 23, 2010.

Thread Status:
Not open for further replies.
  1. whitedragon551

    whitedragon551 Registered Member

    Joined:
    Sep 30, 2008
    Posts:
    3,189
    Location:
    USA
    Alright I had a discussion here:

    https://www.wilderssecurity.com/showthread.php?t=268498&page=2&highlight=utorrent

    And since the thread wont let me reply in it I created a new one.

    All of my settings are identical to what it shows in the last few posts there with the exception that I changed port numbers. However I also changed port numbers to reflect in LnS as well.

    [​IMG]

    Now nothing in my router has changed, nothing in my HOST file has changed, nothing within uTorrent has changed, but I still cant get it to connect properly.

    One thing I did notice is that running the setup guide it will finish the speed test properly. On the network test it tests for a properly forwarded port and that is where the error is within uTorrent. It says that the port is not open, but it is according to LnS.

    Applications of course has uTorrent listed.
     
  2. Stem

    Stem Firewall Expert

    Joined:
    Oct 5, 2005
    Posts:
    4,948
    Location:
    UK
    Some steps to check for open port.

    1: Delete the inbound rule.(click "Apply")
    2: Check your router for correct port and internal IP for forwarding.
    3: Go to shieldsup and scan the specific port.
    4: check firewall log for log entry of blocked packets to that port. If no log for that port: go back to 2.
    5: when blocked packet shows, you can create a rule from that log entry and add the application. Make sure you click on "Apply" after creating the rule


    If still problems, then run a shields up scan with the PC IP in router DMZ to check if your ISP is blocking port(s)

    - Stem
     
  3. whitedragon551

    whitedragon551 Registered Member

    Joined:
    Sep 30, 2008
    Posts:
    3,189
    Location:
    USA
    Router's internal firewall is off so port forwarding doesnt apply.
    No blocked packets are visible in the log for that port.
     
  4. Stem

    Stem Firewall Expert

    Joined:
    Oct 5, 2005
    Posts:
    4,948
    Location:
    UK
    Unless the PC is in router DMZ, then you will still need to port forward, or the unsolicited inbound cannot be translated(NAT) to internal IP.
     
  5. whitedragon551

    whitedragon551 Registered Member

    Joined:
    Sep 30, 2008
    Posts:
    3,189
    Location:
    USA
    Not sure if its in the DMZ zone or not, but Ive never dont any port forwarding on my router EVER and uTorrent was working fine with the last rule set posted in the OP.
     
  6. Stem

    Stem Firewall Expert

    Joined:
    Oct 5, 2005
    Posts:
    4,948
    Location:
    UK
    As I do not know how you are set up, it is not easy to know the problem.

    If you where set up in DMZ then the unsolicited inbound should hit your PC firewall. As the win firewall been enabled> Check to make sure it is off.
    Does your PC have a private IP?(internal LAN IP).
    As utorrent been opening the ports in the router itself via uPnP and now maybe a problem with that?
     
  7. whitedragon551

    whitedragon551 Registered Member

    Joined:
    Sep 30, 2008
    Posts:
    3,189
    Location:
    USA
    No private IP. Thats assigned to my router via my ISP.

    uTorrent has uPnP enabled, but I have never configured the router to use anything like that. I have always just turned the router FW off and used LnS and allowed uTorrent through the port that I specify.
     
  8. Stem

    Stem Firewall Expert

    Joined:
    Oct 5, 2005
    Posts:
    4,948
    Location:
    UK
    Your ISP will issue the IP for the external IP of the router, but the router will issue a private IP for your PC(or should do). I was asking to try and see if you where is some sort of bridging mode.
    The router will not just allow unsolicited inbound connections and then know which internal IP to send that inbound, unless is is configured to do so.
    You are going to have to check your setup to see what was opening/forwarding the ports in the router. It would probably of been utorrent using uPnP. You would possibly be better, and easier, to disable uPnP and manually set up port forwarding in the router.
     
  9. whitedragon551

    whitedragon551 Registered Member

    Joined:
    Sep 30, 2008
    Posts:
    3,189
    Location:
    USA
    uTorrent has always had uPnP enabled and my router was setup to allow such actions. Ive never ran into an issue with it until now.

    How you suggest I go about port forwarding properly for uTorrent? My router is a Netgear WGR614v7
     
  10. isail

    isail Registered Member

    Joined:
    Apr 4, 2008
    Posts:
    16
    Location:
    Mianyang, Sichuan, China
    See it? I'm using utorrent 2.2.1 build 25110, and I just set it like this in my LNS. I only allow the UDP port, It works well.

    But there's still many TCP packages blocked from different ports and IPs, I think perhaps it's because uTP's turned on (bt.transp_disposition=31).

    About uTP, you can see it here:
    http://forum.mininova.org/index.php?showtopic=235064426
     

    Attached Files:

    Last edited: Mar 19, 2011
Thread Status:
Not open for further replies.