Using Paragon HDM in VMWare Virtual Machine

Discussion in 'Paragon Drive Backup Product Line' started by sambul14, Oct 6, 2010.

Thread Status:
Not open for further replies.
  1. sambul14

    sambul14 Registered Member

    Joined:
    Oct 6, 2010
    Posts:
    10
    When I boot from Paragon HDM 10 WinPE CD in a VMWare Win7 64-bit Virtual Machine, it doesn't show connected to that VM USB Flash drives (despite showing USB Hard Drives), and neither shows content of Shared Host Folders, despite the VM is connected to the host according to Windows Network Manager. It neither shows local internal hard drives, connected to the VM as network drives. HDM shows a list of shared folders on the host, but not their content at all.

    I was thinking, may be some drivers are missing, but its hard to believe, USB Mass Storage Device Driver is not included with HDM CD. I tried to add the usbstore.inf driver, since its listed in HDM CD DriverStore\FileRepository directory, but the error pops up "The system can't find the pass specified", when I point to it.

    What can be the cause of these issues, and how to fix?
     
  2. MudCrab

    MudCrab Imaging Specialist

    Joined:
    Nov 3, 2006
    Posts:
    6,483
    Location:
    California
    I see my flash drive in HDM 2010 Server booted in my VMWare Windows 7 x64 VM (currently ver. 7.1.0).

    I wouldn't expect to have the other features working since VMWare Tools are not installed in WinPE.
     
  3. sambul14

    sambul14 Registered Member

    Joined:
    Oct 6, 2010
    Posts:
    10
    Normal network support is standard VMWare feature, it doesn't require VMWare Tools be installed. Paragon should add standard virtual machine drivers and normal security login routings to its recovery CDs. It simply doesn't work as it should.
     
  4. Mech_An

    Mech_An Registered Member

    Joined:
    Mar 29, 2010
    Posts:
    855
    sambul14,

    You need to add drivers for VMWare Network & VMWare USB.
    Use 'Add Drivers' option from WinPE.

    Then click Network Configurator and enter network details. Go to Network drives tab and map desired shared folder. It will be available in wizards as all drives.
     
  5. sambul14

    sambul14 Registered Member

    Joined:
    Oct 6, 2010
    Posts:
    10
    Where to get VMWare drivers from? They're not supplied as a separate install by VMWare as far as I know. Also, can you read my 1-st post regarding USB support? It looks like Paragon's CD has an empty DriverStore directory. Did you try it yourself step-by-step using Paragon's CD before giving advice? If yes, where did you get the above drivers from? Just try to insert your USB Stick and see if its visible with Paragon's CD...
     
  6. Mech_An

    Mech_An Registered Member

    Joined:
    Mar 29, 2010
    Posts:
    855
    sambul14,

    I have no problems with USB at all. I usually do:
    * connect flash to my PC
    * run VMWare from WinPE ISO
    * go to VM - Removable Devices - connect removable drive
    * reload Paragon program if needed (press F5 or re-open)
    and it always appears correctly.

    As of Network drivers: I have saved them from WinXP Virtual Machine. You can check if they work for you also View attachment 32bit.7z.txt (please rename the file to *.7z)
     
  7. sambul14

    sambul14 Registered Member

    Joined:
    Oct 6, 2010
    Posts:
    10
    I think I lost you here. Do you have Paragon and VMWare on one WinPE CD that you boot your PC from? Or, are you talking about booting from a VMWare WinPE inside a VMWare virtual machine before booting from the Paragon CD inside the same VM?

    I was talking about a more typical scenario: start your PC OS from internal HD, then start VMWare, then boot from Paragon CD inside VMWare Win7 machine to test its functionality without rebooting your PC and booting it directly from Paragon CD. That's what virtual machines are for: to test various ISO files, downloaded from the web. But, you can't test Paragon ISO inside a VM, since it doesn't show any physical drives at all connected to the VM, except its virtual drives. And how & where from would you add these drivers to Paragon CD?
     
  8. Mech_An

    Mech_An Registered Member

    Joined:
    Mar 29, 2010
    Posts:
    855
    sambul14

    I mean:
    * start your Windows
    * connect WinPE ISO to VMWare and run Virtual machine from ISO

    As of access to physical drives:
    It is VMWare limitation. The only way to 'show' physical internal drives (not USB) is to connect them to Virtual machine. Booting from WinPE, you have all limitations on virtual machine, because WinPE CD doesn't know that it is virtual machine, not physical.

    If you want to access external USB_drive from WInPE, it is possible, but external drive should be connected to virtual machine, not to the host.

    As of drivers: WinPE CD has option 'Add drivers' from main menu. Search for it. Then navigate to the folder where unpacked drivers are saved.
    Note: VMWare network should be configured before configuring network from WinPE.
     
  9. sambul14

    sambul14 Registered Member

    Joined:
    Oct 6, 2010
    Posts:
    10
    Thanks!

    I'll try to install your network drivers on the host and see what happen. However, that same VMWare VM works normally with network, when a different ISO like Acronis is booted inside it. Hence, the VM network drivers are already installed on the host. A VM virtual drive connected to the VM is empty, with no OS installed, so I don't think, Paragon CD will be able to install any drivers to it. As to physical drives, they should be visible inside the VM as network drives without being disconnected from the host. As well, Sandisk USB stick should also show up without any problems (and its connected to the VM from boot), despite (again), local VM virtual drive has no OS on it, so there is nowhere to install any drivers. But again, Paragon CD has its own Win7 PE variant, so I guess, Paragon Menu offers to install extra drivers inside the VM to that PE's RAM drive (because Paragon starts from it) - or to what drive?
     
Loading...
Thread Status:
Not open for further replies.