Using IIS or Apache as update server http for v3

Discussion in 'Other ESET Home Products' started by edwin3333, Dec 9, 2008.

Thread Status:
Not open for further replies.
  1. edwin3333

    edwin3333 Registered Member

    Joined:
    Aug 29, 2007
    Posts:
    244
    The HTTP mirror server doesn't work well in my environment. I want to hand these updates out over IIS.

    I have my Nod 32 2.7 clients updating fine from IIS, however I can't seem to get my 3.0 clients updating from IIS.

    I've followed the changes in this post;
    https://www.wilderssecurity.com/showthread.php?t=194245&page=2&highlight=update.ver

    But I can't get that to work either.

    In Wireshark I see Nod 3.0 download the update.ver. It then says no update available in Egui.exe, though there clearly is.

    If I go to a browser and do http://servername:2221/update.ver it displays in the browser. If I go to :8081/update.ver (IIS) then it prompts for a download. I'm guessing this has something to do with the problem.

    How does get Nod32 3.x to update from IIS? If this requires Apache, I can load the Apache service up too, that is an option.

    Thanks!
     
  2. NOD32 user

    NOD32 user Registered Member

    Joined:
    Jan 23, 2005
    Posts:
    1,766
    Location:
    Australia
    Based on this I'm guessing there's an issue with the default MIME type setting of your IIS and I would guess that using text/plain would fix it.

    Cheers :)
     
  3. edwin3333

    edwin3333 Registered Member

    Joined:
    Aug 29, 2007
    Posts:
    244
    I tried configuring ver as a mime type of text/plain and the iisreset. No dice. I also tried text/html and many other mime types for ver. Nod would download the .ver file and never see a new update.

    My guessing is that 3.0 doesn't like the additional headers IIS provides.

    The strange thing is that my legacy 2.7 clients update from this same IIS server. The 2.7 files are located at the same server instance/config but under a directory called nod32v2.
     
Thread Status:
Not open for further replies.