User Account Creation

Discussion in 'ProcessGuard' started by Whynot, May 29, 2004.

Thread Status:
Not open for further replies.
  1. Whynot

    Whynot Registered Member

    Joined:
    Feb 8, 2004
    Posts:
    50
    Hi guys
    When I configure a new account on XP Pro and try to switch users PG junps in and requests action. The problem is that there are no buttons to select where normally there are the usual Allow - Allow Once - Block - Block Once. Is this a known bug or something unique to my PC configuration.
     
  2. Pilli

    Pilli Registered Member

    Joined:
    Feb 13, 2002
    Posts:
    6,217
    Location:
    Hampshire UK
    Hi WhyNot, There is a fault in fast user switching which MS has failed to address so far. This is to do with the nature of Process Guard's low level driver and the kernel.

    Here is Jason's response from another thread:

    You can't run multiple versions of procguard.exe on the same system, and never will be. Simply shutdown procguard.exe in the other user account if you want to use it in another.

    BTW there are certain "issues" with fast user switching that most likely will never be resolved. Any process run in any session other than 0 (the first account logged in) will be allowed to run by the execution protection unless it was specifally blocked always or "block all new and changed files from running" option is enabled.

    Basically, you will not get a confirmation in any other account than the first one you logged into.


    Pilli
     
Thread Status:
Not open for further replies.