Unblock .exe Files--Win7x64

Discussion in 'other security issues & news' started by TONPumper, Jun 12, 2014.

Thread Status:
Not open for further replies.
  1. TONPumper

    TONPumper Registered Member

    Joined:
    Jul 20, 2010
    Posts:
    112
    Every time I download a file in Firefox, I always get the security warning prompt. With most programs, this hasn't appeared to be an issue, but whenever I download the latest exe for Firefox and don't unblock the exe, Firefox constantly asks to make FF the default browser, no matter how many times I tell the computer to make it the default browser. The only fix has been to unblock the exe and everything works fine. My concern is that other programs may not function fully unless their files are unblocked, so is there a way to unblock future files permanently?
     
  2. zapjb

    zapjb Registered Member

    Joined:
    Nov 15, 2005
    Posts:
    3,518
    Location:
    USA - Back in a real State in time for a real Pres
    I don't have enough data.

    Security products, recent changes in software & how long since problem started?
     
    Last edited: Jun 12, 2014
  3. TONPumper

    TONPumper Registered Member

    Joined:
    Jul 20, 2010
    Posts:
    112
    I use ESET NOD32 and Malwarebytes'. Recent change in software? Well I always update my programs when they can be updated, so are there certain programs that cause Windows 7 to block exe files? Problems have been here since early this year, when I put my desktop together and loaded an image from my laptop to my desktop.
     
  4. zapjb

    zapjb Registered Member

    Joined:
    Nov 15, 2005
    Posts:
    3,518
    Location:
    USA - Back in a real State in time for a real Pres
    Do you have a FF extension that forces a secure connection? Or are you always using Private Browsing mode?

    I think it's a FF setting or add-on.
     
  5. xxJackxx

    xxJackxx Registered Member

    Joined:
    Oct 23, 2008
    Posts:
    4,047
    Location:
    USA
    If you dare you can use Group Policy to disable Attachment Manager and that will stop it from tagging downloaded files as being from the Internet Zone. That would forever solve your problem if you do not consider it to be an excessive risk. The setting is under Computer Configuration > Administrative Templates > Windows Components > Attachment Manager
     
  6. TONPumper

    TONPumper Registered Member

    Joined:
    Jul 20, 2010
    Posts:
    112
    I just had to go to Internet Options and enable a feature. Now I don't get the security warning.

    http://imgur.com/iVmdjaP.jpg

    EDIT: Turns out that the exe/zip/etc. is still blocked.
     
    Last edited: Jun 14, 2014
  7. TONPumper

    TONPumper Registered Member

    Joined:
    Jul 20, 2010
    Posts:
    112
    I think you might be right. It doesn't block file when I download them in Chrome. I also tried to restart FF with the addons disabled and the exe file was STILL blocked. Seems to be a setting within FF itself.
     
    Last edited: Jun 14, 2014
  8. zapjb

    zapjb Registered Member

    Joined:
    Nov 15, 2005
    Posts:
    3,518
    Location:
    USA - Back in a real State in time for a real Pres
    I guess you could uninstall FF being sure to uninstall all folders that might store previous settings. Then reinstall FF. I don't think FF comes this way otherwise this topic would be 100 pages. Also I'd download a fresh copy of FF from Mozilla.org & ditch your current copy.
     
  9. TONPumper

    TONPumper Registered Member

    Joined:
    Jul 20, 2010
    Posts:
    112
    Is there a way to uninstall without losing my addon settings? Or possibly just a way to reset Firefox with the current copy?
     
  10. zapjb

    zapjb Registered Member

    Joined:
    Nov 15, 2005
    Posts:
    3,518
    Location:
    USA - Back in a real State in time for a real Pres
    Yeah you just gotta find the setting or settings that's screwing it up for you & change them.

    Other than that. My way will work, I think. :)

    I'd copy my bookmarks (export as file). Write a list of add-ons & follow my above instructions. Then restore bookmarks. Add add-ons 1 at a time, testing your problem. Then throw away the problem child add-on.
     
Loading...
Thread Status:
Not open for further replies.