Unable to Update to Version 4.2 Spyware Blaster

Discussion in 'SpywareBlaster & Other Forum' started by wris, Apr 11, 2009.

Thread Status:
Not open for further replies.
  1. wris

    wris Registered Member

    Joined:
    Apr 11, 2009
    Posts:
    5
    I apologize for posting this in the wrong thread - perhaps someone can delete the one in the Version 4.2 Released Thread. Thanks so much.

    I had version 4.1 Spywareblaster and tried updating to 4.2. I had read recommendations that you should shut down spywareblaster, uninstall it through add/remove in control panel, and install newly-downloaded file.

    I wish I had read your forum about not having to uninstall, because now I have NO protection.

    I uninstalled the old version and tried to install Version 4.2, but get this warning: Unable to execute file in the temporary directory. Setup aborted. Error 5: Access is denied. I had downloaded the new version to my desktop, had turned off both antivirus and firewall and was disconnected from the internet while trying to install the files.

    I have deleted the downloaded file and re-downloaded a few times and keep getting the error messages. I did notice when I went into windows explorer that there was still a folder for Spywareblaster, with a couple of files, even after removing spywareblaster from the control panel, and I sent that to my recycle bin.

    Any idea how I can get this program back on my computer.
    Windows XP Home, IE7. I tried reinstalling the older version and get the same error.
     
  2. javacool

    javacool BrightFort Moderator

    Joined:
    Feb 10, 2002
    Posts:
    3,997
    Hi,

    A search on the Internet seems to indicate that this error in the setup program we use (InnoSetup) could be caused by certain anti-virus software with custom rules (although the problem was supposedly fixed).

    Have you tried rebooting? Please try unplugging your computer from the Internet, disabling all anti-virus software, rebooting, double-check to make sure the anti-virus is still disabled, and then try running the SpywareBlaster installer. (Make sure to remember to re-enable your anti-virus afterwards.)

    Best regards,

    -Javacool
     
  3. wris

    wris Registered Member

    Joined:
    Apr 11, 2009
    Posts:
    5
    Thanks for responding.
    I've tried that and still getting the same error message.

    I have my firewall off (though even when on it doesn't usually cause problems - I just have to continually give permission), I use Avast which I disabled.

    I didn't have this problem when I installed the previous version a few months ago.
     
  4. motdaugrnds

    motdaugrnds Registered Member

    Joined:
    Dec 29, 2002
    Posts:
    46
    Location:
    USA
    I, too, am having problems getting the version 4.2 download. I, also, downloaded and installed version 4.1 without having to disable my other protective programs.

    I have tried every single download site I could find (Geeks and LavaCool) in an effort to get this download. Sometimes it starts, then stops, giving me the message it cannot download. Sometimes it starts and gets near half downloaded, then stops and I get that same message.

    I have had to "resume" several times (reconnecting to internet, rebooting, etc) in an attempt to get the download completed. At such time I start the download, still have to hit "resume" and then get the message that the file cannot be found.

    Fortunately I did not uninstall the version 4.1 I have been using; but I still would like to have the updated version 4.2 version.

    Can anyone direct me as to how to get it?
     
  5. Bubba

    Bubba Updates Team

    Joined:
    Apr 15, 2002
    Posts:
    11,271
    Does the user account you are using still have Admin rights or at least rights to write to the %SystemRoot%\TEMP folder ?

    -Bubba
     
  6. wris

    wris Registered Member

    Joined:
    Apr 11, 2009
    Posts:
    5
    Yes, I do seem to have administrator rights.

    I ran Ccleaner, did Disk Cleanup and checked Temp files. Still getting error message and still unable to install the new Version 4.2.

    When I originally removed Spyware Blaster 4.1 from my computer, I disabled it first, then removed thru Add/Remove. When I uninstalled it, it apparently did something to my Windows Installer and that’s why I can’t install the new Version. ( Why doesn’t the program have an uninstall feature with it that might make a cleaner uninstall?)

    I noticed that it somehow corrupted my windows installer because I tried to "uninstall" a different program from my computer last night and got this message: Windows Installer is not accessible. Says installation can’t continue because the windows installer could not be accessed. Error Code 1601. (I guess the installer also works as an uninstaller?)

    I read that this message can occur if you remove a program that uses Windows Installer, but does that only mean Microsoft programs? The only program I’ve uninstalled recently is Spyware Blaster. I had no problems previously adding or removing any program.
     
  7. javacool

    javacool BrightFort Moderator

    Joined:
    Feb 10, 2002
    Posts:
    3,997
    Hi,

    Presumably, that means any program that uses Windows Installer - which many third-party programs do as well. However, SpywareBlaster isn't one of them - and uninstalling an older version of SpywareBlaster shouldn't be able to cause the problems you mentioned.

    Based on the errors you've listed, it sounds like you have some sort of permissions problem on your system. Microsoft's documentation on Windows Installer errors lists the one you mentioned with the following details:

    Although again, SpywareBlaster doesn't use Windows Installer, and thus uninstalling it shouldn't have touched anything remotely related - so it's not clear to me what the cause of these problems may have been.

    Have you experienced any other oddities or permissions-related errors with your system recently?

    Best regards,

    -Javacool
     
  8. wris

    wris Registered Member

    Joined:
    Apr 11, 2009
    Posts:
    5
    I'm not sure what the glitch was that would not let me remove another program from my computer, where I was getting the windows installer error, but that is no longer a problem. I deleted files from the temp folder, as someone suggested. Not sure if that had any bearing, but I was then able to remove the other program.

    So, apparently, my spyware blaster problem has nothing to do with windows installer, as you suggest.

    I am still unable to complete setup for Version 4.2, and I still get this error message: Unable to execute file in the temporary directory. Setup aborted. Error 5: Access is denied. Have no clue what the problem is. I'm not sure what has changed because I did not have this problem with 4.1 when I installed it a couple of months ago.
     
Loading...
Thread Status:
Not open for further replies.