.TXT files nolonger open in notepad (XP)

Discussion in 'other security issues & news' started by justjackOH, Oct 1, 2004.

Thread Status:
Not open for further replies.
  1. justjackOH

    justjackOH Registered Member

    Joined:
    Sep 18, 2004
    Posts:
    5
    I'm having trouble finding a place to post this problem, so hopefilly someone here can help me.
    After installing SP2 for Windows XP, when I double click on a .txt file, it no longer opens in notepad.exe. Instead, it pops up the "Open with" dialog box. To compound the problem, Notepad is not listed in the dialog box as a choice to open the file with. And I tried using the "Browse" button (that is toward the bottom of the popup) to select the location of Notepad.exe on my PC, thinking that would add Notepad to the list, but that did not work either.
    My virus protection files and program are up to date. I also ran my up-to-date spyware programs (Spybot, Adaware, SpywareGuard) and they found no problems.
    Is this a known problem with SP2? How do I fix it?
    Thanks!!
     
  2. Tassie_Devils

    Tassie_Devils Global Moderator

    Joined:
    May 8, 2002
    Posts:
    2,514
    Location:
    State Queensland, Australia
    It could be something simple like a file association problem.

    Can you try this, see if it works.

    Open Windows Explorer.
    Select Tools TAB/Select Folder Options.
    Select File Types TAB
    Scroll down until you find .txt extension, click on it to highlight.
    See what is listed that it opens with.
    If not Notepad, Click on 'Change'
    In the New Window that comes up [Open With] find and select/hihglight Notepad
    Click OK
    Click Apply then OK on original window.

    [Ignore mine, I have EditPad Lite as my default text editor]

    See if that works.

    If the .txt extension is already allocated to Notepad, it won't hurt to reinforce it, just go thru the procedures again as above.

    Cheers, TAS
     

    Attached Files:

    • 017.GIF
      017.GIF
      File size:
      38.5 KB
      Views:
      257
  3. Tassie_Devils

    Tassie_Devils Global Moderator

    Joined:
    May 8, 2002
    Posts:
    2,514
    Location:
    State Queensland, Australia
    PS: Can you actually open Notepad itself via Start/Program Files/Accessories/Notepad?

    Just to see if Notepad itself is really working!

    If not there definitely is a problem, what, at this stage I do not know.

    Cheers, TAS :)
     
  4. justjackOH

    justjackOH Registered Member

    Joined:
    Sep 18, 2004
    Posts:
    5
    Thanks for your reply.
    Under the Windows Explorer --> Folder Options --> File Types, the "Open With" for the TXT file type is blank. And if I try to set this association, I get the same popup window as I described in my previous post; the popup window does not include Notepad in the list of choices. It has the Browse button there, but I've tried using that to browse to C:\Windows\notepad.exe, but that does not work and it does not add notepad to the list of choices.

    An added clarification: when doing a right click on the .txt file to specify the program with which to open the file, it brings up a list that still does not include Notepad as a choice. It does however have a choice to "Choose Program". However, this brings up the same exact popup window that I received when I double clicked on the .txt file. So, I am faced with the same problem; notepad has completely disappeared from the list of choices in this "Open With" dialog box.

    As for notepad itself, it does start ok when I start it explicitly:
    The notepad.exe file at C:\Windows is intact and named properly.
    If I go to the Windows directory and double click on notepad.exe, it does open successfully. Also if I go to Start --> Run and type notepad, it does in fact launch notepad. It also starts when I go to Start-->Program Files-->Accessories-->Notepad. So, it doesn't look like notepad itself is corrupted.
     
  5. puff-m-d

    puff-m-d Registered Member

    Joined:
    Feb 13, 2002
    Posts:
    4,451
    Location:
    North Carolina, USA
    Hi justjack OH,

    If I read your posts correctly, you have windows XP, and when trying to set your file association for .txt files you browse to C:\Windows\notepad.exe. In windows XP, your notepad.exe should be located at C:\Windows\System32\notepad.exe. Go to THIS SITE and follow the instructions to be sure your notepad.exe files are located in the correct locations. Then do the browse in file association for .txt and try to set it at C:\Windows\System32\notepad.exe.

    HTH.....
     
  6. Tassie_Devils

    Tassie_Devils Global Moderator

    Joined:
    May 8, 2002
    Posts:
    2,514
    Location:
    State Queensland, Australia
    Yep... looks like your file path was corrupted at one point and following Kent's posting instructions should fix it. :)

    Let us know how it went.

    Cheers, TAS
     
  7. justjackOH

    justjackOH Registered Member

    Joined:
    Sep 18, 2004
    Posts:
    5
    Thanks Thanks Thanks!!!!!
    That was it. Had a CWS trojan.
    Fixed!!
    This thread can be closed!!
    And congrats. You resolved the problem faster than the folks at the Microsoft support site!!
     
  8. puff-m-d

    puff-m-d Registered Member

    Joined:
    Feb 13, 2002
    Posts:
    4,451
    Location:
    North Carolina, USA
    Hi justjackOH,

    To be sure you got all of your CWS infection, I would do the following:
    1. Run SpyBot Search & Destroy with the latest definitions.
    2. Run Ad Aware SE with the latest definitions.
    3. Run CWShredder.
    4. I also would advise that you post a HJT log to one of the ASAP web sites after doing the first 3 steps to ensure that you are clean. See THIS THREAD for details.
     
  9. justjackOH

    justjackOH Registered Member

    Joined:
    Sep 18, 2004
    Posts:
    5
    Thanks. Had already run CWShredder, Ad-Aware SE and Spybot S&D (after updating them). I've posted my HJT log file at ComputerCops. THX!!
     
Loading...
Thread Status:
Not open for further replies.