trying to mount -> system hangs

Discussion in 'Acronis True Image Product Line' started by jura0001, Feb 11, 2009.

Thread Status:
Not open for further replies.
  1. jura0001

    jura0001 Registered Member

    Jun 27, 2007
    I searched through the forum and saw old threads with the same issues:

    Why is it that sometimes (with some otherwise intact images) trying to mount an image causes a hanging system?

    My system is windows XP:

    When using the freely available version True Image 10 Personal Edition I cannot mount certain images, or my entire system becomes extremely unresponsive. I get the message (after some extended period of time) that the image has been mounted (has a drive letter) but I am no longer able to do anything with my system; even launching the task manager takes an eternity and then I cannot do anything to unmount the image or to shutdown the system.

    some additional remarks:
    - this happens with windows XP SP3, but I restored some very old XP image (pre-SP3) and had the same problem
    - I had that problem with the above mentioned TI 10 PE, but also (after carefully removing any acronis version manually, according to the acronis guidelines) with the 9.1 workstation, and even with the very new TI 2009!
    - the problem is with mounting in the default read-only mode, but (how weird is this?) not when mounting as
    Does anybody have an explanation why "read-write" does NOT cause a severe slow-down of the system, in contrast to
    mounting it "read-only"!?

    And another important fact:

    All these problems only happen with windows XP Professional (in its various versions I have in my images).

    When I use (whatever TI version I can get a hold on) windows 2000 or even windows 7(!) all my images can be easily mounted, in "read-only" mode, too, without causing a virtually blocked or locked up system.

    I am not going to investigate this issue any further, but I would like to hear from others about their experience with TI in combo with XP.

    Something that may (?) be important is that the image that causes these issues (but validates ok, even restores ok!) is very, very large (about 80 GB) and I saved it in 700MB chunks, so these are more than 100 fragments!

    On the other hand (see above): windows 7 has zero problems mounting all the different partitions in this big image.

    Regards, jura0001

    I am not going to install some test setup (as often suggested by Acronis) because I did way too much testing for my taste already, but perhaps others can share some of their experiences or explain why "read-write" works in XP but "read-only" NOT...
  2. kevinkar

    kevinkar Registered Member

    Dec 29, 2004
    Open up Event Viewer and see in the System log if any issues are there at the same time you tried this.

    There are many people, myself included, who have had issues with XP and the Distributed Transaction Coordinator service. There are also some other services that seem to hang at the same time. However, if you disable the DTC service, typically True Image will run properly and your PC will not appear to hang. At least that works for the majority of cases I have seen on other forums, this one included.

    Check that out and see it it helps.
  3. jura0001

    jura0001 Registered Member

    Jun 27, 2007
    Thanks for your answer, but unfortunately, there is nothing in the event viewer; but that may be due to the fact that I always have to power off the machine because trying to shut it down properly does not work...

    As to the DTC service (trkwks), no, thanks for the hint, but I had disabled that service a long time ago.

    If someone else has some experience to share with problems under XP but not so under other operating systems, I will be pleased to hear about it.

    best regards, jura0001

    I would simply mount all images "read-write", but unfortunately, each and every mounting adds a new .tib to my image fragments and I don't see a way to prevent this from happening even though I do not change anything...
  4. jura0001

    jura0001 Registered Member

    Jun 27, 2007
    Something I'd like to add here:

    While mounting an image "read-only" is problematic and can cause the computer to hang, I have no special issues with "exploring" images (o.k., sometimes the explorer crashes, but nothing more serious happens, and explorer just restarts).

    Since I am a big friend (and have always been) of "total commander" (years ago called "windows commander"), I would like to know whether it is possible to "explore" images NOT inside windows explorer, but instead inside "total commander".

    Did someone try this or know if it is feasible?

    thanks, jura0001
  5. jura0001

    jura0001 Registered Member

    Jun 27, 2007
    Well, doesn't anybody have an idea?

    Why does read-write mounting work perfectly (apart from the annoyance of seeing another .tib created!) whereas "read-only" mounting locks up the computer?

    Some more information:
    So far, this has ONLY happened with images of my windows7 partition, but it may also have another reason: ntfs, for instance.

    Back to the event logger:
    in the "system" department of event logger I always get 4 entries after unplugging an image (some ftdisk error, id 57), but this happens after successful mounts; when mounting is NOT successful, I cannot see anything in the event logger because my system is unresponsive.

    I would like to stress again that the mount issues ONLY happen under XP (even pre-SP3), but that windows2000 has absolutely no problems mounting any one of my various windows 7 images! - The XP problems do NOT depend on the version of True Image either (tested from versions 9 to 2009).

    Those of the readers of this forum who have mounting issues, do you always have these issues when it is a ntfs image or when it is read-only or both? Or are some of you experiencing problems with fat32, for example?

    I was almost beginning to believe that it is only with "hot images" of windows 7, done while windows 7 was up and running - until I made another such image which perfectly mounts even under XP!?

    So I am still puzzled...

    thanks, jura0001
  6. Acronis Support

    Acronis Support Acronis Support Staff

    Apr 28, 2004
    Hello jura0001,

    Thank you for your interesting in Acronis True Image

    Make sure that Acronis True Image Backup Archive Explorer is Enabled in Device Manager (Right-click on MY Computer -> Properties -> Hardware -> Device Manager -> Unfold Acronis Devices -> Right-click on Acronis Devices -> Select Acronis True Image Backup Archive Explorer -> Choose Enabled).

    Best regards,
    Dmitry Nikolaev
  7. onurbi

    onurbi Registered Member

    Feb 28, 2009
    Hi jura001,

    my system hangs in exact the same manner as you described!

    I hope Acronis will find a solution soon!

    With Version 7 of TI i used it often in R/O and R/W mode under W2K and it worked perfect.

    The hint from Dmitry concerning the device manager is negative for me. It was already enabeld.


Thread Status:
Not open for further replies.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.