Truecrypt problem

Discussion in 'encryption problems' started by Redbandit, Apr 7, 2013.

Thread Status:
Not open for further replies.
  1. Redbandit

    Redbandit Registered Member

    Joined:
    Apr 7, 2013
    Posts:
    2
    This may be a bit vague so if further information is needed, let me know. I encrypted my entire portable hard drive using truecrypt. Everything went well for about a year or so, until i hit dismount, and something was holding it up, without realizing it hadnt dismounted properly, i unplugged the hard drive. Later i discovered it was messed up. i could mount it, but it said i needed to format it every way i tried to open it (i tried from my computer and the truecrypt window). I messed around with it, nothing special at first, i tried using the backup header in the hard drive and that didnt work. i tried running various retrieval programs, and that also didnt net me any results in getting some of my things back. After awhile i got frustrated, and assumed all was lost, so i tried some of the steps on another post recklessly. (the following)


    1) To play it safe and to reduce possible confusion, disconnect any external drives that can be disconnected. It's OK to disconnect unwanted internal drives too if you like. Fewer drives = fewer chances to select the wrong one.

    2) Bring up the Run window and type DiskPart so we can run DiskPart at the command line inside a window. Approve any UAC messages that may appear.

    3) At the DISKPART prompt, type the following command:
    List disk

    4) Carefully look over the list of disks. Examine the size of each drive and identify the disk that we need to modify, then note down its listed drive number (in your case it will probably be Disk 2, 3 or 4)

    5) Type the following:
    Select Disk <number> (For example, "Select Disk 4")
    Be very careful to enter the correct disk number or you'll be very sorry later! Diskpart will confirm that you have selected Disk <number>.

    6) Detail disk
    (review the displayed information to ensure you've selected the correct disk)

    7) List partition
    Are any partitions listed? There shouldn't be. I expect your disk to be completely raw unless you've recently altered it. If there are any partitions present, stop here, type Exit and let me know.

    Here comes the command that creates your new partition:
    8. Create partition primary offset=1024
    (the above offset is in KB, so this should result in offset 1048576 dec) Wait for the DiskPart prompt indicating success. Since we didn't indicate a Size, the partition should extend to the end of the disk, or as close as Windows will allow.

    9) List Partition
    (Oh, why not. We want to confirm that your new partition was created and has an offset of 1024 KB.)

    10) Select Partition 1
    (probably not necessary, but it doesn't hurt)

    11) Detail Partition
    More information. Look it over. Fun! The displayed offset in bytes should be 1048576.

    12) Exit
    That's enough fun with DiskPart.

    Now open TrueCrypt; Select Device; select Partition1 under the appropriate harddisk; assign a drive letter, choose Mount, provide the password for the outer volume, browse the volume using Windows Explorer and see if there is a functional file system. Browse your data if possible.


    And now it wont mount, and says its not a truecrypt file or i have the wrong password. i realize i made a mistake in doing this, but im posting here to see if all is truely lost now, or if theres any slim hope.
     
  2. Redbandit

    Redbandit Registered Member

    Joined:
    Apr 7, 2013
    Posts:
    2
    I restored the volume header on partition 0 and it will mount but wont open, the only difference is now it says the parameter is incorrect
     
    Last edited: Apr 7, 2013
Loading...
Thread Status:
Not open for further replies.