TrueCrypt Partition Declared itself as “Free Space”

Discussion in 'encryption problems' started by HinterlandNerd, Dec 23, 2014.

  1. HinterlandNerd

    HinterlandNerd Registered Member

    Joined:
    Dec 23, 2014
    Posts:
    2
    One of my TrueCrypt partitions (of the TC encrypted internal system disk, 500GB) has declared itself as “free space” (when viewed in the Disk Management). Ouch!

    Goal: Access my files and get them out of “Free Space”. Can anyone help?


    How the funk did this happened?

    My Win7 (the whole system drive being TC encrypted) on my laptop worked just fine for several years. Then recently, typed in password, password accepted, all nice, windows starts booting and BANG! Blue screen, wouldn’t boot any more. However in Safe Mode, I could still access all my files on all four (yes, four) of my partitions on the internal drive. So I thought it would be safest to copy all my personal and very dear files from the system partition to the d-partition – just in case Windows collapse completely. Note: I originally designated this partition for my personal data with the letter “D” way back when, even though physically it is the last (i.e. 4th and biggest, 320 GB) partition on the internal system drive.

    Thinking that my files were safe (stupid me), I tried to make Windows boot again and I took a few steps that were probably counter-productive (i.e. very):

    1. Don’t ask me why, but at some point, I defragmented, either the whole drive or only the c-partition – I am not sure now which it was. But as I’ve read in the meantime that may have caused my d-drive to disappear.

    2. I ran CCleaner after Safe Mode start up.

    3. I booted Windows from Win7 installer CD and clicked Repair Your Computer > Start Up Repair. That also didn’t make Windows boot. Probably the worst thing I did then was go into the Command Prompt and typed “bootrec /fixmbr” and “bootrec /fixboot” – which I had picked up somewhere on the WWW. Computer stopped booting altogether thereafter. Couldn’t even enter TC password, just a flashing underscore to admire.

    4. So I looked for my TrueCrypt Recovery CD and tried the Repair Options: (2) Restore TC Boot Loader, (3) Restore Key Data (Volume Header), (4) Restore Original System Header. Though I did not try (1) Permanently Decrypt System Drive. Tried to open the partitions with my password. However the system hung itself up right after pressing enter to confirm password.

    As a result I was then able to enter my password upon starting the computer, however the machine got stuck immediately after entering the password.

    So I took the physical drive out of the machine and hocked it up as an external drive to another Win7 run machine. Using TrueCrypt on that other machine I am able to open and access three of the four partitions using the wonderful function “Mount without pre-boot authentication”. But the d-drive (where all my unique files are) is not accessible and is in fact marked as “free space” in Disk Management. HOLY BIT! Don’t let this be DATACIDE!

    My objective now is “only” to recover my data from the d-partition (NOT to restore Windows – funk that!). Obviously running a regular data recovery program over the partition would not help, since the drive is encrypted, i.e. will find nothing. So I need to find a way of transforming the “free space“ back into a regular partition that TrueCrypt can work with.


    What have I tied so far?

    I made a complete sector by sector copy of the drive using HDD Raw Copy onto another drive. This allows me now to manipulate the copy without causing any more damage to the original.

    Using TestDisk, I searched for lost partitions. Even after Deep Scan found: none.

    Then finally I tried WinHex (trial vesion) Tools > Disk Tools > Search for Lost Partitions. It found more than 128, but only displayed the first 128. I read a dew posts by Dantz here and he describes how to copy the back up volume headers from one place of the partition to the beginning of the partition using WinHex so that Win7 will recognize them. Is that what I should try?

    Btw, “Initialize Free Space” is not highlighted as an option under Tools > Disk Tools.

    In summary, I am not sure whether WinHex (as a trial or even full version) could possibly help me to convince Win7 or TC that the “free space” is in fact my treasured d-partition.

    I am on my knees and will kiss any one’s virtual feet for advice or pointing me to a post that helps me resolve my crisis.
     
  2. HinterlandNerd

    HinterlandNerd Registered Member

    Joined:
    Dec 23, 2014
    Posts:
    2
    Hello, anyone there in WWW willing to help me, please?
     
  3. breathe87

    breathe87 Registered Member

    Joined:
    Jan 10, 2015
    Posts:
    11
    I'm having my own issue with TC as well, but if this is a system drive you have made a copy of, possibly decrypt it with the rescue CD and try to use traditional data recovery tools....?

    I've been happy with parted magic for cloning drives, but it is a bit more advanced and I don't know your skill level.

    This seems to be a "start here" landing page for TC encrypted data loss:
    https://www.wilderssecurity.com/threads/guide-truecrypt-recovery.367106/
     
    Last edited: Jan 30, 2015
Loading...