Truecrypt does not accept password on external formated drive.

Discussion in 'encryption problems' started by MarTomch, Aug 22, 2016.

  1. MarTomch

    MarTomch Registered Member

    Aug 19, 2016
    Hi All,

    I have a 750 GB external hard-drive that worked fine. I encrypted the whole drive partition with Truecrypt and mounted with no problem. Password was saved in an email and easy to remember. So no issues of a wrong password. I had mounted the external USB drive in several laptops, for about a month, with no problems. After the drive was disconnected for 2 months, Truecrypt does not accept the password. Answering "Password incorrect or not a true crypt drive". I tried an option to retrieve the header, with no avail. Do any of you have hints on what to do? I thought that maybe that was an issue with Win10 updates, so tried to mount in several PCs, even in an old XP. Same frustration. The partition is there, but I get that nagging answer.... Thanks... :)
  2. Palancar

    Palancar Registered Member

    Oct 26, 2011
    Its tough to know whether or not the drive was connected during a time that Windows did any updates? Windows breaks more encrypted drives than a person can count. When I was writing dozens of posts a day over at the TC forum I would always stress two requirements for Windows users:

    1. Make and securely keep a backup volume header (not the pathetic wannabe nested in the original volume structure) for EACH volume and do it NOW!

    2. Backup the MBR on any device encrypted volume without question. Takes 30 seconds.

    Both of these items take mere minutes to create and store. As noted above; 750 Gig is alot to gamble on when a few minutes makes it all go away.

    Please readers of this thread: if you have these two items handy, this thread is history 98% of the time in maybe 2 minutes. If you ignore this post, the next thread can be yours, it happens!

    OP, I didn't want to hang you out here. I have seen this exact thread without exaggeration, thousands of times. So then this post is just a warning for the dozens that will read it.
  3. samy234

    samy234 Registered Member

    Sep 20, 2016
    I had a similar issue. A fresh windows install accidently overwrote my 1tb truecrypt volume with a 1tb boot partition. After that truecrypt was not able to mount the volume anymore. The normal truecrypt program was not able to recouver the embedded header, but testcrypt did. Maybe you can give it a try: