TrueCrypt - disk structure corrupted and unreadable

Discussion in 'encryption problems' started by Robert S, Aug 30, 2016.

  1. Robert S

    Robert S Registered Member

    Aug 30, 2016

    This is my first post here, been googling for the past day and I ended up here.
    My problem is with a 2TB SSD from Samsung that I have been using as an external hard drive so I can access my data from PC or Laptop without the need of copy/paste or cloud drives etc...
    The whole drive is encrypted with single password ( not hidden ), as of yesterday when I tried to mount my hard drive and access it I received the error: "The disk structure is corrupted and unreadable", under Disk Management the hard drive appears as "healthy" and in RAW format. I am still able to mount the drive using my password.

    I tried what I found on google so far,
    - chkdsk - not working "Unable to determine volume version and state. CHKDSK aborted."
    - tried restoring the truecrypt volume header, nothing changed.

    I am a noobie in what comes about hard disk problems so using WinHex or TestDisk is out of my knowledge.
    Any help would be much appreciated.