TrueCrypt and 32 Gig usb

Discussion in 'encryption problems' started by Palancar, Feb 20, 2013.

Thread Status:
Not open for further replies.
  1. Palancar

    Palancar Registered Member

    Joined:
    Oct 26, 2011
    Posts:
    1,592
    TrueCrypt and hardware issue

    THREAD TITLE CHANGED. ITS MY COMPUTER and I am working on it

    _________________________________________--

    I am a very long time user of TC. I am also somewhat of a computer geek so I am perplexed by this problem and wanted to run it by some of you guys.

    For some reason I cannot create a hidden volume on my new 32 Gig USB. This is the first time I have ever owned a 32 Gig flash. I am somewhat suspicious that the size has something to do with my issues.

    Background: its a name brand SanDisk Cruzer flash. I have done all the normal prep work. This means its been formatted and wiped and is a clean slate before starting the construction of the device based volumes. I very easily created the outer volume and its working perfectly every single time and on multiple computers it works great.

    When I try to create the hidden volume TC stalls and then pops up saying access denied and some other gibberish. I am running in absolute Admin mode. I have even tried making the hidden volume using a RAM disk with TC installed on it. I can see the decoy but again when I try to construct the hidden volume the same thing happens as on the live OS.

    BTW --- when going about creating the hidden volume it goes through all but the FORMAT process. The bitmap scan etc... is all fine. It locks up when I click to format the hidden volume. The messages I put at the bottom here.

    I was thinking that just maybe the flash was defective so I took it back and exchanged it for another new one. Same thing as the first so its not likely a hardware defect. Hmmmm!

    I have constructed many really large decoy/hidden volumes in the 1 TB plus size on external drives, without any issues using this exact same machine. I have also made many decoy/hidden flash volumes on 8 Gig and smaller units.

    Would there be any reason to suspect that something due to SIZE of the flash drive is the culprit? 32 Gig is small by external HDD standards, but maybe the flash works differently.

    I have also blown away the partition of the flash and recreated it without issues to try that angle. That was on the first flash (exact same model as this one) but I haven't done that with this flash as of yet.

    For my needs I must have greater than 8 Gig and I prefer not to tote around a portable HDD. I would do that if needed.

    I'ld love to hear any suggestions.



    TC messages displayed: (approximate from memory)

    Access is Denied


    make sure the selected volume exists or that it is not read only, etc...
     
    Last edited: Feb 21, 2013
  2. LockBox

    LockBox Registered Member

    Joined:
    Nov 20, 2004
    Posts:
    2,275
    Location:
    Here, There and Everywhere
  3. Palancar

    Palancar Registered Member

    Joined:
    Oct 26, 2011
    Posts:
    1,592
    Lockbox,

    Thanks for the ideas.

    I have compiled TC a few times and the code is just something that I fully trust (as much as reasonable anyway). Regarding flash encryption; I have never had an issue of any kind until I went to these larger flash units.

    Update: I took the 32 Gig SanDisk back and exchanged it for a PNY 64 Gig. Same result as above. I can only deduce that these larger flash sizes are causing a problem.

    I need at least 25 Gig and preferably 30 Gig so anything smaller isn't going to work. Integral's that size are expensive (about $100.00 for 32 Gb) and I really don't know "what makes them tick" like I do with TC.

    Wally World has new WD/Toshiba 500 Gig portable HDDs for $65.00. I know those would work without question. They are bit larger than I preferred but then again an actual hard drive allows for different partitions and some other options as well. Unless I can figure this out in the next day or so I'll go the external HDD route.

    Although frustrating; I am enjoying beating away on this little stumbling block. In the end it looks like an external is the answer.
     
  4. Palancar

    Palancar Registered Member

    Joined:
    Oct 26, 2011
    Posts:
    1,592
    Re: TrueCrypt and hardware issue

    More weirdness. Its something to do with my laptop and probably has nothing to do with "flash drives". I returned this morning with a 500 Gig external and had issues creating a device based volume. Hmmmmm.

    I took the external to an old XP era desktop and I am creating a volume on the external with no issues at all. Something has changed in the configuration of my laptop. The funny thing is that both the decoy and the hidden OS experienced issues creating volumes, and they have worked flawlessly for years now.

    The only thing I have changed recently is that I went to Comodo for my firewall/AV suite. Previously I had used PrivateFirewall, ESET, Unthreat, etc without any issues.

    I exited comodo and shut it down on the laptop but it didn't help.

    To add to the weirdness please remember that I also mounted a UBCD4Win RAM disk with TC and tried to create a volume using that approach. On my laptop it was a no go. I can see and use all previously created volumes using the RAM disk. So, Comodo isn't even on that system.

    I am suspicious that some kind of hardware update has "shot me in the foot" but I have never heard of such a thing. This laptop can see and use any previously created volumes with no issues at all. It simply can't create a hidden volume and sometimes not even a shell volume.

    I have some older saved and archived system disks for this laptop. I am considering writing the C drive back just to confirm that something update wise has changed. That would be a few hours down the tubes. Before I do that in a day or so does anyone reading here have any ideas short of using the archive image?

    Any guesses as to what gives?
     
  5. aklies14

    aklies14 Registered Member

    Joined:
    Jun 22, 2012
    Posts:
    29
    Location:
    America
    I am using 64GB sandisk,single partition encrypt with outer and hidden volume and it is working fine for me.added 20Gb in hidden and no problem.
     
Loading...
Thread Status:
Not open for further replies.