True Image 8.0-914 for Linux: trueimangecmd error

Discussion in 'Acronis True Image Product Line' started by olibaer116, May 9, 2005.

Thread Status:
Not open for further replies.
  1. olibaer116

    olibaer116 Registered Member

    Joined:
    May 9, 2005
    Posts:
    6
    True Image 8.0-914 for Linux: trueimagecmd error

    I have a problem installing Acronis True Image 8.0 Server for Linux.
    My System is a Debian sarge 3.0 with Kernel 2.4.27-1-386.
    I followed the HOWTO.INSTALL, installed the snapapi module (no errors), then the Acronis True Image (no errors - "installed successfully").
    When I issue the command trueimagecmd --list, I get the response "Cannot find the necessary program modules. Please reinstall the program."

    Here is what I did:
    1. /installs/trueimage-setup (=>"snapapi not found", "quit")
    2. I installed + unpacked the kernel sources (no errors)
    3. dkms build -m snapapi -v 0.6.4 --config /boot/config-2.4.27-1-386 --kernelsourcedir /usr/src/linux-2.4.27-1-386 (no errors)
    4. dkms install -m snapapi -v 0.6.4 --config /boot/config-2.4.27-1-386 --kernelsourcedir /usr/src/linux-2.4.27-1-386 (no errors)
    5. started your script as described in HOWTO.INSTALL, VI - 3. (no errors)
    6. mkdir /devfs ; mount -t devfs devfs /devfs (no errors)
    7. /installs/trueimage-setup (=>"installed successfully")

    the build version of acronis true image 8.0 linux server is 914.

    I tried to run "modprobe snapapi", this leads to the following errors:
    /lib/modules/2.4.27-1-386/kernel/drivers/block/snapapi.o: /lib/modules/2.4.27-1-386/kernel/drivers/block/snapapi.o: unresolved symbol irq_stat_R7228bf63
    /lib/modules/2.4.27-1-386/kernel/drivers/block/snapapi.o: /lib/modules/2.4.27-1-386/kernel/drivers/block/snapapi.o: unresolved symbol flush_signals_Rfe7fb250
    /lib/modules/2.4.27-1-386/kernel/drivers/block/snapapi.o: /lib/modules/2.4.27-1-386/kernel/drivers/block/snapapi.o: unresolved symbol drop_super_Ra07b0920
    /lib/modules/2.4.27-1-386/kernel/drivers/block/snapapi.o: /lib/modules/2.4.27-1-386/kernel/drivers/block/snapapi.o: unresolved symbol blkdev_put_R7f065436
    /lib/modules/2.4.27-1-386/kernel/drivers/block/snapapi.o: /lib/modules/2.4.27-1-386/kernel/drivers/block/snapapi.o: unresolved symbol __pollwait_R43c77cc3
    /lib/modules/2.4.27-1-386/kernel/drivers/block/snapapi.o: /lib/modules/2.4.27-1-386/kernel/drivers/block/snapapi.o: unresolved symbol refile_buffer_R89576be4
    /lib/modules/2.4.27-1-386/kernel/drivers/block/snapapi.o: /lib/modules/2.4.27-1-386/kernel/drivers/block/snapapi.o: unresolved symbol _alloc_pages_Rfd287ee7
    /lib/modules/2.4.27-1-386/kernel/drivers/block/snapapi.o: /lib/modules/2.4.27-1-386/kernel/drivers/block/snapapi.o: unresolved symbol blkdev_get_R43cdf7b4
    /lib/modules/2.4.27-1-386/kernel/drivers/block/snapapi.o: /lib/modules/2.4.27-1-386/kernel/drivers/block/snapapi.o: unresolved symbol __wait_on_buffer_R85111add
    /lib/modules/2.4.27-1-386/kernel/drivers/block/snapapi.o: /lib/modules/2.4.27-1-386/kernel/drivers/block/snapapi.o: unresolved symbol get_super_R122b1cd2
    /lib/modules/2.4.27-1-386/kernel/drivers/block/snapapi.o: /lib/modules/2.4.27-1-386/kernel/drivers/block/snapapi.o: unresolved symbol unlock_buffer_R84d0ea0c
    /lib/modules/2.4.27-1-386/kernel/drivers/block/snapapi.o: /lib/modules/2.4.27-1-386/kernel/drivers/block/snapapi.o: unresolved symbol bdget_R7a6e8908
    /lib/modules/2.4.27-1-386/kernel/drivers/block/snapapi.o: /lib/modules/2.4.27-1-386/kernel/drivers/block/snapapi.o: unresolved symbol submit_bh_R5c40f1f6
    /lib/modules/2.4.27-1-386/kernel/drivers/block/snapapi.o: /lib/modules/2.4.27-1-386/kernel/drivers/block/snapapi.o: unresolved symbol blk_get_queue_R143991ea
    /lib/modules/2.4.27-1-386/kernel/drivers/block/snapapi.o: /lib/modules/2.4.27-1-386/kernel/drivers/block/snapapi.o: unresolved symbol zone_table_R5072368b
    /lib/modules/2.4.27-1-386/kernel/drivers/block/snapapi.o: /lib/modules/2.4.27-1-386/kernel/drivers/block/snapapi.o: unresolved symbol register_chrdev_R9d36a825
    /lib/modules/2.4.27-1-386/kernel/drivers/block/snapapi.o: /lib/modules/2.4.27-1-386/kernel/drivers/block/snapapi.o: unresolved symbol set_bh_page_R0d54e0ae
    /lib/modules/2.4.27-1-386/kernel/drivers/block/snapapi.o: /lib/modules/2.4.27-1-386/kernel/drivers/block/snapapi.o: unresolved symbol get_gendisk_R4f7bdc03
    /lib/modules/2.4.27-1-386/kernel/drivers/block/snapapi.o: /lib/modules/2.4.27-1-386/kernel/drivers/block/snapapi.o: unresolved symbol __free_pages_R1fbe825f
    /lib/modules/2.4.27-1-386/kernel/drivers/block/snapapi.o:

    Hint: You are trying to load a module without a GPL compatible license
    and it has unresolved symbols. The module may be trying to access
    GPLONLY symbols but the problem is more likely to be a coding or
    user error. Contact the module supplier for assistance, only they
    can help you.

    /lib/modules/2.4.27-1-386/kernel/drivers/block/snapapi.o: insmod /lib/modules/2.4.27-1-386/kernel/drivers/block/snapapi.o failed
    /lib/modules/2.4.27-1-386/kernel/drivers/block/snapapi.o: insmod snapapi failed

    The system has the standard Debian distribution kernel, not a self-compiled kernel.

    Thanks
     
    Last edited: May 9, 2005
  2. Acronis Support

    Acronis Support Acronis Support Staff

    Joined:
    Apr 28, 2004
    Posts:
    25,885
    Re: True Image 8.0-914 for Linux: trueimagecmd error

    Hello olibaer116,

    Thank you for choosing Acronis Linux Server Disk Backup Software.

    Please uninstall Acronis True Image for Linux and then install again from scratch indicating the architecture type with the option --arch <architecture number>. To get the architecture number please use the command

    uname -m

    If the problem persists please issue the following commands:

    strace -o log trueimagecmd --list
    dmesg > dmesg.txt
    mount > mount.txt
    lsmod > lsmod.txt

    After that please pick up the files created and send them to support@acronis.com along with the description of the problem. We will certainly help you with the solution.

    Thank you.
    --
    Ilya Toytman
     
  3. handy75

    handy75 Guest

    Re: True Image 8.0-914 for Linux: trueimagecmd error

    I have a question where have you got the source for 2.4.27-1-386 ??

    i search everywhere but cant find it. pls help thx.
     
  4. olibaer116

    olibaer116 Registered Member

    Joined:
    May 9, 2005
    Posts:
    6
    Re: True Image 8.0-914 for Linux: trueimagecmd error

    Hello Ilya,

    did what you said, but problem persists, on both Debian servers (kernel 2.4.27 and 2.4.18 ). Sending you the files you asked for by email -thank you.

    Here is exactly what I did:

    enif:/home/progs/_downloads/trueimagelinuxserver8.0-914.s.e# ./trueimage-setup --uninstall
    ((( uninstall completed successfully )))
    enif:/home/progs/_downloads/trueimagelinuxserver8.0-914.s.e# cd /usr/src/
    enif:/usr/src# uname -a
    Linux enif 2.4.27-1-386 #1 Fri Sep 3 06:24:46 UTC 2004 i686 GNU/Linux
    enif:/usr/src# uname -m
    i686
    enif:/usr/src# dkms build -m snapapi -v 0.6.4 -k 2.4.27-1-386 --config /boot/config-2.4.27-1-386 --arch i686 --kernelsourcedir /usr/src/kernel-source-2.4.27

    Error! This module/version has already been built on: 2.4.27-1-386
    Directory: /var/lib/dkms/snapapi/0.6.4/2.4.27-1-386/i686
    already exists. Use the dkms remove function before trying to build again.
    enif:/usr/src# dkms remove -m snapapi -v 0.6.4 -k 2.4.27-1-386

    -------- Uninstall Beginning --------
    Module: snapapi
    Version: 0.6.4
    Kernel: 2.4.27-1-386 (i686)
    -------------------------------------

    Status: Before uninstall, this module version was ACTIVE on this kernel.

    snapapi.o:
    - Uninstallation
    - Deleting from: /lib/modules/2.4.27-1-386/kernel/drivers/block//
    - Original module
    - No original module was found for this module on this kernel.
    - Use the dkms install command to reinstall any previous module version.


    snumbd.o:
    - Uninstallation
    - Deleting from: /lib/modules/2.4.27-1-386/kernel/drivers/block//
    - Original module
    - No original module was found for this module on this kernel.
    - Use the dkms install command to reinstall any previous module version.


    DKMS: uninstall Completed.
    enif:/usr/src# dkms build -m snapapi -v 0.6.4 -k 2.4.27-1-386 --config /boot/config-2.4.27-1-386 --arch i686 --kernelsourcedir /usr/src/kernel-source-2.4.27

    Preparing kernel 2.4.27-1-386 for module build:
    (This is not compiling a kernel, only just preparing kernel symbols)
    Storing current .config to be restored when complete
    Running Generic preparation routine
    make mrproper....
    using /boot/config-2.4.27-1-386
    make oldconfig......
    make dep..................................

    Building module:
    cleaning build area....
    make KERNELRELEASE=2.4.27-1-386 -C /usr/src/kernel-source-2.4.27 SUBDIRS=/var/lib/dkms/snapapi/0.6.4/build modules.....
    cleaning build area....
    cleaning kernel tree (make mrproper).....

    DKMS: build Completed.
    enif:/usr/src# dkms install -m snapapi -v 0.6.4 -k 2.4.27-1-386 --config /boot/config-2.4.27-1-386 --arch i686 --kernelsourcedir /usr/src/kernel-source-2.4.27
    Running module version sanity check.

    snapapi.o:
    - Original module
    - No original module exists within this kernel
    - Installation
    - Installing to /lib/modules/2.4.27-1-386/kernel/drivers/block//

    snumbd.o:
    - Original module
    - No original module exists within this kernel
    - Installation
    - Installing to /lib/modules/2.4.27-1-386/kernel/drivers/block//

    depmod.....

    DKMS: install Completed.
    enif:/usr/src# cd /home/progs/_downloads/trueimagelinuxserver8.0-914.s.e
    enif:/home/progs/_downloads/trueimagelinuxserver8.0-914.s.e# ./trueimage-setup
    ((( install completed successfully!!!)))
    enif:/home/progs/_downloads/trueimagelinuxserver8.0-914.s.e# trueimagecmd --list
    Cannot find the necessary program modules. Please reinstall the program.
    enif:/home/progs/_downloads/trueimagelinuxserver8.0-914.s.e# o_Oo_O?
     
  5. olibaer116

    olibaer116 Registered Member

    Joined:
    May 9, 2005
    Posts:
    6
    Re: True Image 8.0-914 for Linux: trueimagecmd error

    Handy75: "apt-get install kernel-source-2.4.27" - This only worx with Debian.
     
  6. Acronis Support

    Acronis Support Acronis Support Staff

    Joined:
    Apr 28, 2004
    Posts:
    25,885
    Re: True Image 8.0-914 for Linux: trueimagecmd error

    Hello olibaer116,

    Thank you for taking time to contact Acronis Support Team. If you don't get any response within 48 hours please let me know your Acronis request # that was sent to you in autoreply to your letter.

    Thank you.
    --
    Ilya Toytman
     
  7. martin75

    martin75 Guest

    Seems to b a general Problem with debian - I have the same troubles as you have :(
     
  8. Acronis Support

    Acronis Support Acronis Support Staff

    Joined:
    Apr 28, 2004
    Posts:
    25,885
    Hello martin75,

    Thank you for choosing Acronis Disk Backup Software for Linux.

    If you have Kernel 2.4.27-1-386 please update it to 2.4.27-2 or 2.6.8. If the problem remains please contact us.

    Thank you.
    --
    Irina Shirokova
     
Thread Status:
Not open for further replies.