Trouble with Privoxy

Discussion in 'ESET Smart Security v3 Beta Forum' started by neverfox, Oct 13, 2007.

Thread Status:
Not open for further replies.
  1. neverfox

    neverfox Registered Member

    Joined:
    Oct 13, 2007
    Posts:
    2
    I just installed ESS RC1 on Vista 32-bit and can't get network connection to work via Privoxy (a personal proxy server). I route all my traffic (browser, updates etc.) through this proxy and I've never had any problems with other firewalls. With other programs like Look'n'stop or Comodo, they detect Privoxy just like any other network app and ask for approval. I can then set a rule to allow it which consequently allows all programs that point to it to get out to the internet.

    But with ESS, it never seems to detect Privoxy and thus I can't get any of the network apps that are set to use the proxy to get out. I've tried setting the firewall to interactive mode but I don't get any indication that Privoxy is trying to connect like I would expect. It's as if it is never receiving any traffic. My browser (Maxthon2) triggers the firewall and says it is trying to connect to localhost port 8118 (the Privoxy port) and I allow it. But then nothing else happens and the page I'm trying to load fails. I even tried manually adding a rule for Privoxy and that didn't help. Also, I turned off the firewall and it STILL didn't work. I had to completely turn off the proxy setting in my browser to get out to the internet. This is not acceptable because the whole point of Privoxy is to filter all my browser traffic for privacy and safety. Why would simply having ESS running, even with the firewall off, basically break my Privoxy setup? After uninstalling ESS, everything worked fine.
     
  2. neverfox

    neverfox Registered Member

    Joined:
    Oct 13, 2007
    Posts:
    2
    Since there are no responses, perhaps it is because no one is familiar with Privoxy. So forget for a minute that I'm talking about Privoxy. Let's look at this from a more general standpoint.

    Has anyone had any problem with the ESS firewall not detecting network-related apps such as local proxies etc.? If so, do you know why and how to resolve it?

    I've never had a software firewall not detect and ask about a network app before so I'm a little stunned that ESS isn't working. I'm even more stunned that it prevents the normal functioning of my browser->proxy chain even when turned off. I'm hoping it's a pre-release bug. But if it's part of the planned behavior of the product and I'm doing something wrong with the configuration, I'd like to figure it out. But even if a special setup will fix it, why should it need special advanced knowledge to work when other products don't?

    I hope there is an fix for this because I reall want to like the product the way I like NOD32 AV.
     
  3. phaedrus

    phaedrus Registered Member

    Joined:
    Aug 18, 2002
    Posts:
    95
    Using Proxomitron and ESS here without problems. I can`t think why Privoxy isn`t being detected?
    Double check in ESS firewall Zone and Rule setup (Advanced mode>Setup>Personal Firewall>Configure rules and zones) to see if Privoxy got detected and blocked.
     
  4. webyourbusiness

    webyourbusiness Registered Member

    Joined:
    Nov 16, 2004
    Posts:
    2,640
    Location:
    Throughout the USA and Canada
    have you tried Eset Smart Security in Interactive mode?
     
Thread Status:
Not open for further replies.