Triple Boot,Xp,Vista32,Vista64 -MFT limitations?!?!

Discussion in 'Acronis Disk Director Suite' started by DopeShow, Jul 10, 2007.

Thread Status:
Not open for further replies.
  1. DopeShow

    DopeShow Registered Member

    Joined:
    Feb 21, 2006
    Posts:
    5
    In short here is what i tried:

    Situation: all is happening on DISK 0

    starting with System on C:\ - XP Pro Sp2
    then
    installed in dual boot configuration VISTA 32 to : E:\
    ( both OS use C: as bootdrive and vistabootloader takes care
    of OS Selection ,all productive and working fine)
    method to install vista32 was to boot the DVD with bios methods
    and select a new vista install on target drive E:

    so far so good that is all working like i want it to no problems at all...NOW....

    Goal...install vista x64 as third OS
    So far no big deal one would think.

    Well i had some space problems so i fired up VISTA 32´s diskmanager
    and used the shrink feature on one of my data partitions and
    used the freed space to make a new 12 GB part for X64.
    (point out that Acronis was already present in vista32 before
    i started all of this) but i prefered onboard methods.
    Well at least it worked with no obvious errors so far.

    Now to install x64
    Same method..booting into Vista X64 DVD going through
    the whole install just like always ..no problems.
    The x64 OS is completely installed now.

    With one SLIGHT difference. Vista x64 (although accessible
    over the same bootloader menu in which XP,Vista 32 are...
    choses to remap drive letters (Now you damn thing dont touch
    my C: drive letter...no no no, swish swish ....:ninja: )
    Well anyway although annoying i can still live with that so far.

    Next thing im doing...installed Chipset driver X64 (nforce 680SLI)
    of nvidia site. Reboot...all fine so far.

    Next thing i do get Forceware 158.24 installs fine.

    Now ...the **** hits the fan...next reboot :
    Dirty Bit on system drive (remember i installed x64
    to I:, which was made C: as long as X64 is booted,
    due to stupid drive letter remap) ...chkdsk starts
    running and finds about 10000 bad index entries.
    Best thing...chkdsk cant complete and stops with
    error message about having not enough space to
    recreate the MFT volume Bitmap whatever) Totally
    bull since theres about a couple of GB free.
    So i think wth ...forget it, delete that partion and
    start over again. Guess what same **** happens again,
    just after ure done with everything ROFL. Before
    the partition is 100% error free.

    By this time my horses where about soaking and steaming
    i tell ya... i delete that partition again and burn the X64
    DVD on a small campfire slowly slowly :ninja:

    now have 16 gb of unallocated space which i had taken from
    a other drive to make a new partition for triple boot X64 vista
    alongside with my XP PRo, VISTA 32. But guess what ...
    i have found NO method to put that space BACK into the
    partition i took it from. Enlarge in vista? forget it ..grayed out.
    DD 10 ? Forget it performs only idiotic nonsense if u try to
    do that. Create a new partition again and merge with existing?
    Error cant be done.

    So much for VISTA Frustation i just f.. h8 this piece of Shambala OS.:isay: :gack: o_O :rolleyes:

    And to put some butter to the fish ..when i unstalled DD10 from vista 32
    it killed my vista 32 completely...had to repair install.

    Now please someone tell me ...how can i use the unallocated space i have
    to enlarge one of my old partitions again...best would be the one i took it from.
    I repeat..no method i could possible think of has yielded any result.
    All i could do was to make a new partition again and hope that it doesnt freak
    out with errors again.. Something must be messed up in MFT...im pretty sure
    i have no physical errors. All other partitions are 100% fine and i have smart
    enabled for my drives too.

    Well it seems i have overlooked a small detail which might explain the problem
    with the X64 data loss.
    The amount of Partitions on drive 0 had been 4. By removing size of one and
    adding a new one i had FIVE partitions on drive 0. Since drive 0 is a MBR
    drive this is interesting. MBR drives dont SUPPORT over 4 Partitions per drive
    (according to Microsoft)

    DOH?! How could i then create a 5th in the first place with their own freaking
    tool? And btw DD 10 doesnt mention that either. And i cant remember thinking
    of that in 15 years of fuzzing around with Microsoft ^^

    Well im still stuck with those 15 GB of unallocated space...anyone good at the
    disk editor ^^?


    (Hardware: ASUS STRIKER EXTREME. C2duo E4300, GF8800 GTX,2GB Mushkin RAM, 2 WD PATA Drives (no raid), USB DVD, USB HD
     
    Last edited: Jul 10, 2007
  2. MudCrab

    MudCrab Imaging Specialist

    Joined:
    Nov 3, 2006
    Posts:
    6,481
    Location:
    California
    Normally, you can only have a maximum of 4 primary partitions on one drive or less than 4 and then an extended partition which can contain any number of logical partitions.

    It may help if you posted a screenshot of your partition layout (from DD).

    Was the original Data partition you took the space from a Logical partition?

    You say "one of your data partitions" so it sounds like you already had two primary partitions (XP and Vista) and two data partitions.
     
Thread Status:
Not open for further replies.