TOR and Startpage having problems with search requests

Discussion in 'privacy problems' started by Palancar, Nov 6, 2014.

  1. Palancar

    Palancar Registered Member

    Joined:
    Oct 26, 2011
    Posts:
    1,592
    Just curious how many of you guys are running into this today? I am in a situation where I have been using the default search engine startpage from inside my TBB. About every 3rd time I have been getting a flag from startpage.

    You guys getting this too??

    Paste of startpage notice:


    Welcome Tor Users!

    We are happy to welcome you to Startpage, the world's most private search engine. Startpage now serves well over 2 million searches per day, making us the biggest private search service on the Internet.

    Like Tor, Startpage was private long before privacy was cool. We have a fourteen-year company track record, and we are the only search engine that can back up our privacy promises with third-party certification.

    Here are just a few of our powerful, privacy-protecting features:

    We do not record anything about you — not your IP address, not your search queries, and we never use tracking cookies.
    We provide 100% Google results — We submit your search anonymously to Google and return their results to you in total privacy.
    We encrypt all traffic — using HTTPS, so even your ISP can't snoop on your searches.
    We offer a powerful free proxy — that lets you anonymously view third-party websites with every search.
    We're third-party certified and independently audited — by EuroPrise and Certified Secure, so you can take our privacy promises to the bank.

    We love Tor!

    We believe in the Tor project and its privacy mission and we applaud your efforts to pursue serious Internet privacy.

    As you know, Tor recently included Startpage as the default search engine in the new Tor Browser Bundles. Thank you! We're honored to be associated with all of you like-minded, hard-core privacy fanatics.
    Just One Small Catch...

    However, the avalanche of new Tor users has created an issue with the algorithm we use to detect and reject automated screen-scraping programs. When multiple Tor users are searching through the same end node, Startpage may wrongly conclude that the searches are coming from a scraper.

    The unfortunate result is that Startpage may occasionally not return results with Tor. But don't panic, we're committed to fixing it.
    Here's a Temporary Solution

    We are reaching out to the Tor developers to find a permanent solution. In the meantime, here is a workaround for Tor users:

    If you use the Tor Browser Bundle:
    Switching to a new Tor identity is easy and fast. Click the green onion icon next to your address bar, then click "New Identity" and try your search again. In some cases, you may have to switch identities a few times for this to work.

    We want Tor users to have a great private search experience with Startpage, and we appreciate your patience while we develop a long-term solution. As you use Startpage, we'd love to hear from you and get your impressions.

    Meanwhile, thanks for supporting the vision of Tor and Startpage and a completely private Internet!
     
    Last edited: Nov 6, 2014
  2. luciddream

    luciddream Registered Member

    Joined:
    Mar 22, 2007
    Posts:
    2,497
    I use Ixquick as my search engine, and home page, and have had trouble over the past week+ as well. It was more like 50% of the time for me... even worse. I wasn't getting that message you were. I was just getting the ol' "Page Not Found" message when the search page would fail to load. It's a good thing I have all my usual/favorite sites bookmarked.

    Just the past day it has been working better again, so I hope it's back to normal.
     
Loading...