Tool to remove uninstallation remnants

Discussion in 'Prevx Releases' started by ams963, Jan 24, 2013.

Thread Status:
Not open for further replies.
  1. ams963

    ams963 Registered Member

    Joined:
    May 3, 2011
    Posts:
    5,965
    Location:
    Parallel Universe
    Hi,

    I've uninstalled WSA. But it leaves behind WSA folder in Program Files and WRkn driver in WINDOWS system. I don't know what else is left behind. When I try to delete them a pop up window says it's being used by another program and I need to close that program first then try again.

    Is there a tool to remove WSA completely after uninstallation something like MBAM's mbamclean.exe?

    Best Regards,
    Amit
     
  2. fax

    fax Registered Member

    Joined:
    May 30, 2005
    Posts:
    3,727
    Location:
    localhost
  3. ams963

    ams963 Registered Member

    Joined:
    May 3, 2011
    Posts:
    5,965
    Location:
    Parallel Universe
    @fax
    The Webroot Clean WDF tool is for older Webroot products. I tried it anyways but it did not clean anything. The remnants are still there.
     
  4. pegas

    pegas Registered Member

    Joined:
    May 22, 2008
    Posts:
    2,016
    @ Amit
    I would try to install it again and uninstall afterwards because it looks that something went wrong during uninstallation. I know that upon correct unistallation all remnants are gone.
     
  5. ams963

    ams963 Registered Member

    Joined:
    May 3, 2011
    Posts:
    5,965
    Location:
    Parallel Universe
    @pegas
    Is that the only option? No specialized tool? :(
     
  6. pegas

    pegas Registered Member

    Joined:
    May 22, 2008
    Posts:
    2,016
    Yes unless you contact support. I think they have an uninstall tool but are not sharing it publicly because in the most cases install/uninstall is enough.
     
  7. PrevxHelp

    PrevxHelp Former Prevx Moderator

    Joined:
    Sep 14, 2008
    Posts:
    8,242
    Location:
    USA/UK
    Rebooting should remove anything which isn't removed by default.
     
  8. ams963

    ams963 Registered Member

    Joined:
    May 3, 2011
    Posts:
    5,965
    Location:
    Parallel Universe
    Okay reinstalling and uninstalling removed the files and drivers.:D Thanks a lot.:thumb:
     
  9. zfactor

    zfactor Registered Member

    Joined:
    Mar 10, 2005
    Posts:
    6,012
    Location:
    on my zx10-r
    yeah i see this once in a while where it does not uninstall properly for some reason. like joe said most of the time i just reboot and the rest is gone. otherwise a quick reinstall / uninstall works fine.
     
  10. Techfox1976

    Techfox1976 Registered Member

    Joined:
    Jul 22, 2010
    Posts:
    749
    I would expect a reboot would be needed after uninstall to clear out the kernel drivers, as I don't think Windows would like people deleting the file when it's loaded. I could be wrong, but that's my impression.
     
  11. ams963

    ams963 Registered Member

    Joined:
    May 3, 2011
    Posts:
    5,965
    Location:
    Parallel Universe
    Oh I had rebooted after uninstallation as I always do. But remnants were there.

    Anyways re-installing and uninstalling did the trick.;)
     
  12. pegas

    pegas Registered Member

    Joined:
    May 22, 2008
    Posts:
    2,016
    Yes, that's also my experience and I beg to disagree with Joe in this case. In my cases it proved only re/un-installing solved the issue.
     
  13. ams963

    ams963 Registered Member

    Joined:
    May 3, 2011
    Posts:
    5,965
    Location:
    Parallel Universe
    @pegas
    Yeah you're absolutely right.:thumb:
     
  14. Bodhitree

    Bodhitree Registered Member

    Joined:
    Dec 5, 2012
    Posts:
    567
    Webroot leaves a lot of traces.. I couldn't even install GDATA on any machine WR was on because it scans for traces of conflicting programs. Even manually editing Registry, and carefully scanning for files, traces were still around.

    WR doesn't have a clean uninstall, and this needs to be addressed. Rebooting changes nothing.
     
  15. The Red Moon

    The Red Moon Registered Member

    Joined:
    May 17, 2012
    Posts:
    3,871
    This is where images come into action..clean image and no remnants.:gack:
     
  16. Bodhitree

    Bodhitree Registered Member

    Joined:
    Dec 5, 2012
    Posts:
    567
    Agreed, I use RollbackRX and simply go back to a snapshot when I want to remove crap. BUT I had WR on this machine before it had Rollback, so no hope for me there.. Always be traces. Unfortunately WR was one of the only things on it when Rollback was added.. LOL
     
  17. PrevxHelp

    PrevxHelp Former Prevx Moderator

    Joined:
    Sep 14, 2008
    Posts:
    8,242
    Location:
    USA/UK
    WSA should have an extremely clean uninstall - could you let me know if you started with the 7.0 version of Webroot or if you've only used SecureAnywhere? The changes that WSA makes are very minimal across the system but if you have specifics for what was left on your system, I'd definitely be interested in the details.

    Thanks!
     
Thread Status:
Not open for further replies.